summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-core/zlib/zlib_1.2.13.bb
diff options
context:
space:
mode:
authordheerajpdsk <p.dheeraj.srujan.kumar@intel.com>2022-12-13 12:17:13 +0300
committerGitHub <noreply@github.com>2022-12-13 12:17:13 +0300
commit9ad1806592d6c8e3111b9c26db1882f2af49d64c (patch)
treede9cd6bf9a4312ca38c65f68faa41638693237a0 /meta-openbmc-mods/meta-common/recipes-core/zlib/zlib_1.2.13.bb
parente9e8ce6060c3c89cff2ca181cf95e3dec1a6c78d (diff)
parent2856c9ab56260bdd398de617bf610e4f7334cafd (diff)
downloadopenbmc-7966edfa52ee4debfefbc56ddf427cd2c2ba8270.tar.xz
Merge pull request #126 from Intel-BMC/update1-0.92-41
Update to internal 1-0.92-41
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-core/zlib/zlib_1.2.13.bb')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-core/zlib/zlib_1.2.13.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-core/zlib/zlib_1.2.13.bb b/meta-openbmc-mods/meta-common/recipes-core/zlib/zlib_1.2.13.bb
new file mode 100644
index 000000000..ec977a303
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-core/zlib/zlib_1.2.13.bb
@@ -0,0 +1,47 @@
+SUMMARY = "Zlib Compression Library"
+DESCRIPTION = "Zlib is a general-purpose, patent-free, lossless data compression \
+library which is used by many different programs."
+HOMEPAGE = "http://zlib.net/"
+SECTION = "libs"
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://zlib.h;beginline=6;endline=23;md5=5377232268e952e9ef63bc555f7aa6c0"
+
+# The source tarball needs to be .gz as only the .gz ends up in fossils/
+SRC_URI = "https://zlib.net/${BP}.tar.gz \
+ file://0001-configure-Pass-LDFLAGS-to-link-tests.patch \
+ file://run-ptest \
+ "
+UPSTREAM_CHECK_URI = "http://zlib.net/"
+
+SRC_URI[sha256sum] = "b3a24de97a8fdbc835b9833169501030b8977031bcb54b3b3ac13740f846ab30"
+
+# When a new release is made the previous release is moved to fossils/, so add this
+# to PREMIRRORS so it is also searched automatically.
+PREMIRRORS:append = " https://zlib.net/ https://zlib.net/fossils/"
+
+CFLAGS += "-D_REENTRANT"
+
+RDEPENDS:${PN}-ptest += "make"
+
+inherit ptest
+
+B = "${WORKDIR}/build"
+
+do_configure() {
+ LDCONFIG=true ${S}/configure --prefix=${prefix} --shared --libdir=${libdir} --uname=GNU
+}
+do_configure[cleandirs] += "${B}"
+
+do_compile() {
+ oe_runmake shared
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+do_install_ptest() {
+ install ${B}/examplesh ${D}${PTEST_PATH}
+}
+
+BBCLASSEXTEND = "native nativesdk"