summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-devtools/dtoverlay
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-02-14 03:51:50 +0300
committerEd Tanous <ed.tanous@intel.com>2019-03-13 00:58:57 +0300
commita7715486507e75e4a7cee843a48067b15595defa (patch)
tree9fd209d468c42cfb6553a50e2523c1d7e1fb120a /meta-openbmc-mods/meta-common/recipes-devtools/dtoverlay
parent9b44ea7e2de71224bce792654cab12b7a5ceaa7d (diff)
downloadopenbmc-a7715486507e75e4a7cee843a48067b15595defa.tar.xz
Initial commit of intel repository
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-devtools/dtoverlay')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-devtools/dtoverlay/dtoverlay.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-devtools/dtoverlay/dtoverlay.bb b/meta-openbmc-mods/meta-common/recipes-devtools/dtoverlay/dtoverlay.bb
new file mode 100644
index 000000000..66107d81b
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-devtools/dtoverlay/dtoverlay.bb
@@ -0,0 +1,31 @@
+SUMMARY = "dtoverlay"
+DESCRIPTION = "device tree overlay application"
+
+SRC_URI = "git://github.com/raspberrypi/userland.git"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=0448d6488ef8cc380632b1569ee6d196"
+
+SRCREV = "11389772c79685442e0ab8aa9be8ad0e32703f68"
+requires = "chrpath-native"
+
+S = "${WORKDIR}/git"
+
+PV = "1"
+
+inherit cmake
+
+FILES_${PN} += "${libdir} ${libdir}libdtovl.so.${PV}"
+
+do_compile_append(){
+ chrpath -d ${S}/build/bin/dtoverlay
+}
+
+do_install() {
+ install -d ${D}${libdir}
+ install -m 0644 ${S}/build/lib/libdtovl.so ${D}${libdir}/libdtovl.so.${PV}
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/build/bin/dtoverlay ${D}${bindir}/dtoverlay
+
+ ln -sf libdtovl.so.${PV} ${D}{libdir}libdtovl.so
+}
+