summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-graphics/jpeg/files/0001-libjpeg-turbo-fix-package_qa-error.patch
diff options
context:
space:
mode:
authorP Dheeraj Srujan Kumar <p.dheeraj.srujan.kumar@intel.com>2024-01-01 18:04:20 +0300
committerP Dheeraj Srujan Kumar <p.dheeraj.srujan.kumar@intel.com>2024-01-01 21:54:16 +0300
commitfaa49504c47a58dfe23e7b478c964e12ea86efb8 (patch)
tree7b6fe1094bb65a16ccdff6f9c619bdaa7ccfb73d /meta-openbmc-mods/meta-common/recipes-graphics/jpeg/files/0001-libjpeg-turbo-fix-package_qa-error.patch
parent0127bdba37b5e22adcc423d170589211de377e2e (diff)
downloadopenbmc-faa49504c47a58dfe23e7b478c964e12ea86efb8.tar.xz
Update to internal 1-1.14
Signed-off-by: P Dheeraj Srujan Kumar <p.dheeraj.srujan.kumar@intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-graphics/jpeg/files/0001-libjpeg-turbo-fix-package_qa-error.patch')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-graphics/jpeg/files/0001-libjpeg-turbo-fix-package_qa-error.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-graphics/jpeg/files/0001-libjpeg-turbo-fix-package_qa-error.patch b/meta-openbmc-mods/meta-common/recipes-graphics/jpeg/files/0001-libjpeg-turbo-fix-package_qa-error.patch
new file mode 100644
index 000000000..152db441b
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-graphics/jpeg/files/0001-libjpeg-turbo-fix-package_qa-error.patch
@@ -0,0 +1,32 @@
+From 5cf847b5bef8dc3f9f89bd09dd5af4e6603f393c Mon Sep 17 00:00:00 2001
+From: Changqing Li <changqing.li@windriver.com>
+Date: Mon, 27 Aug 2018 16:10:55 +0800
+Subject: [PATCH] libjpeg-turbo: fix package_qa error
+
+Fix package qa errors like below:
+libjpeg.so.62.3.0 contains probably-redundant RPATH /usr/lib [useless-rpaths]
+usr/bin/cjpeg contains probably-redundant RPATH /usr/lib
+
+Upstream-Status: Inappropriate[oe-specific]
+
+Signed-off-by: Changqing Li <changqing.li@windriver.com>
+Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
+---
+ CMakeLists.txt | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2bc3458..ea3041e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -191,10 +191,6 @@ endif()
+ report_option(ENABLE_SHARED "Shared libraries")
+ report_option(ENABLE_STATIC "Static libraries")
+
+-if(ENABLE_SHARED)
+- set(CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR})
+-endif()
+-
+ if(WITH_JPEG8 OR WITH_JPEG7)
+ set(WITH_ARITH_ENC 1)
+ set(WITH_ARITH_DEC 1)