summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:45:20 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-10 01:15:05 +0300
commit82dbc15a05125a812c140a3c8cff81c366482229 (patch)
tree9c8f1ad262a2e281f20340cf8646aca6f8596044 /meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend
parent8d6ae7f2a817751fad151168fa10ce28ee0869d8 (diff)
downloadopenbmc-82dbc15a05125a812c140a3c8cff81c366482229.tar.xz
Update to internal 0.26
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend85
1 files changed, 6 insertions, 79 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend
index 8250ec919..4875050a9 100644
--- a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -1,5 +1,11 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+KBRANCH = "dev-5.8-intel"
+KSRC = "git://github.com/Intel-BMC/linux;protocol=ssh;branch=${KBRANCH}"
+# Include this as a comment only for downstream auto-bump
+# SRC_URI = "git://github.com/Intel-BMC/linux;protocol=ssh;branch=dev-5.8-intel"
+SRCREV="9f71530c30ebbec6fc5267475b5517add7ad40ce"
+
do_compile_prepend(){
# device tree compiler flags
export DTC_FLAGS=-@
@@ -7,85 +13,6 @@ do_compile_prepend(){
SRC_URI += " \
file://intel.cfg \
- file://0001-arm-dts-add-DTS-for-Intel-ast2500-platforms.patch \
- file://0001-arm-dts-intel-s2600wf-dts-fixups.patch \
- file://0001-arm-dts-add-DTS-for-Intel-ast2600-platforms.patch \
- file://0001-arm-dts-base-aspeed-g6-dtsi-fixups.patch \
- file://0002-Enable-pass-through-on-GPIOE1-and-GPIOE3-free.patch \
- file://0003-Enable-GPIOE0-and-GPIOE2-pass-through-by-default.patch \
- file://0006-Allow-monitoring-of-power-control-input-GPIOs.patch \
- file://0007-aspeed-pwm-tacho-change-default-fan-speed.patch \
- file://0014-arm-dts-aspeed-g5-add-espi.patch \
- file://0015-New-flash-map-for-intel.patch \
- file://0016-Add-ASPEED-SGPIO-driver.patch \
- file://0017-SGPIO-DT-and-pinctrl-fixup.patch \
- file://0019-Add-I2C-IPMB-support.patch \
- file://0020-misc-aspeed-add-lpc-mbox-driver.patch \
- file://0021-Initial-Port-of-Aspeed-LPC-SIO-driver.patch \
- file://0022-Add-AST2500-eSPI-driver.patch \
- file://0028-Add-AST2500-JTAG-driver.patch \
- file://0030-Add-dump-debug-code-into-I2C-drivers.patch \
- file://0031-Add-high-speed-baud-rate-support-for-UART.patch \
- file://0032-misc-aspeed-Add-Aspeed-UART-routing-control-driver.patch \
- file://0034-arm-dts-aspeed-Swap-the-mac-nodes-numbering.patch \
- file://0035-Implement-a-memory-driver-share-memory.patch \
- file://0039-Add-Aspeed-PWM-driver-which-uses-FTTMR010-timer-IP.patch \
- file://0040-i2c-Add-mux-hold-unhold-msg-types.patch \
- file://0042-Add-bus-timeout-ms-and-retries-device-tree-propertie.patch \
- file://0043-char-ipmi-Add-clock-control-logic-into-Aspeed-LPC-BT.patch \
- file://0044-misc-Add-clock-control-logic-into-Aspeed-LPC-SNOOP-d.patch \
- file://0045-char-ipmi-Add-clock-control-logic-into-Aspeed-LPC-KC.patch \
- file://0047-misc-Block-error-printing-on-probe-defer-case-in-Asp.patch \
- file://0049-Suppress-excessive-HID-gadget-error-logs.patch \
- file://0051-Add-AST2500-JTAG-device.patch \
- file://0052-drivers-jtag-Add-JTAG-core-driver.patch \
- file://0053-Add-Aspeed-SoC-24xx-and-25xx-families-JTAG.patch \
- file://0054-Documentation-jtag-Add-bindings-for-Aspeed-SoC.patch \
- file://0055-Documentation-jtag-Add-ABI-documentation.patch \
- file://0056-Documentation-jtag-Add-JTAG-core-driver-ioctl-number.patch \
- file://0057-drivers-jtag-Add-JTAG-core-driver-Maintainers.patch \
- file://0061-i2c-aspeed-add-buffer-mode-transfer-support.patch \
- file://0062-i2c-aspeed-add-DMA-mode-transfer-support.patch \
- file://0063-i2c-aspeed-add-general-call-support.patch \
- file://0064-set-idle-disconnect-to-true-in-all-cases.patch \
- file://0068-i2c-aspeed-add-H-W-timeout-support.patch \
- file://0069-i2c-aspeed-add-SLAVE_ADDR_RECEIVED_PENDING-interrupt.patch \
- file://0070-gpio-aspeed-temporary-fix-for-gpiochip-range-setting.patch \
- file://0072-pmbus-add-fault-and-beep-attributes.patch \
- file://0073-Add-IO-statistics-to-USB-Mass-storage-gadget.patch \
- file://0075-Refine-initialization-flow-in-I2C-driver.patch \
- file://0076-arm-ast2600-add-pwm_tacho-driver-from-aspeed.patch \
- file://0077-soc-aspeed-Add-read-only-property-support.patch \
- file://0078-Fix-NCSI-driver-issue-caused-by-host-shutdown.patch \
- file://0080-i2c-aspeed-filter-garbage-interrupts-out.patch \
- file://0084-ARM-dts-aspeed-g6-add-GFX-node.patch \
- file://0085-drm-add-AST2600-GFX-support.patch \
- file://0086-ADC-linux-driver-for-AST2600.patch \
- file://0086-ARM-dts-aspeed-g6-add-video-node.patch \
- file://0087-media-aspeed-add-aspeed-ast2600-video-engine-compati.patch \
- file://0088-clk-ast2600-enable-ESPICLK-always.patch \
- file://0089-ast2600-enable-high-speed-uart-in-kernel.patch \
- file://0090-peci-cpupower-driver-1.patch \
- file://0092-SPI-Quad-IO-driver-support-AST2600.patch \
- file://0093-ipmi-ipmb_dev_int-add-quick-fix-for-raw-I2C-type-reg.patch \
- file://0094-Return-link-speed-and-duplex-settings-for-the-NCSI-c.patch \
- file://0095-pwm-and-tach-driver-changes-for-ast2600.patch \
- file://0096-Fix-truncated-WrEndPointConfig-MMIO-command.patch \
- file://0100-Mailbox-Enabling-interrupt-based-mailbox.patch \
- file://0101-Add-poll-fops-in-eSPI-driver.patch \
- file://0102-Fix-for-dirty-node-in-jffs2-summary-entry.patch \
- file://0103-Refine-clock-settings.patch \
- file://0104-Add-chip-unique-id-reading-interface.patch \
- file://0105-i2c-aspeed-fix-arbitration-loss-handling-logic.patch \
- file://0106-enable-AST2600-I3C.patch \
- file://0107-arm-dts-aspeed-g6-Add-ast2600-mctp-node.patch \
- file://0108-soc-aspeed-mctp-Add-initial-driver-for-ast2600-mctp.patch \
- file://0110-USB-gadget-fix-illegal-array-access-in-binding-with-.patch \
- file://0111-Unconditionally-calculate-the-PECI-AW-FCS.patch \
- file://0112-AST2600-enable-UART-routing.patch \
- file://0116-watchdog-aspeed-fix-AST2600-support.patch \
- file://0117-Copy-raw-PECI-response-to-user-space-on-timeout.patch \
- file://0118-Recalculate-AW-FCS-on-WrEndPointConfig-command.patch \
"
SRC_URI += "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', 'file://0005-128MB-flashmap-for-PFR.patch', '', d)}"