summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-kernel/linux
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-03-26 01:45:09 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-03-27 01:41:36 +0300
commit12bef3e1bf292dec5ac15af9fb41e86f7bcfb0cb (patch)
tree608a905372f3f545d2686e29512ae3f5f5b4a78c /meta-openbmc-mods/meta-common/recipes-kernel/linux
parent0a1ece0568a37de9f17fd6e0bcdfd2cad2c6503f (diff)
downloadopenbmc-12bef3e1bf292dec5ac15af9fb41e86f7bcfb0cb.tar.xz
Update to internal 0.43
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-kernel/linux')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0001-peci-Add-debug-printing-to-check-caller-PID.patch10
-rw-r--r--meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0003-Fix-libmctp-build-error.patch116
-rw-r--r--meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0004-Add-a-quick-fix-to-resolve-USB-gadget-DMA-issue.patch33
-rw-r--r--meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend8
4 files changed, 159 insertions, 8 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0001-peci-Add-debug-printing-to-check-caller-PID.patch b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0001-peci-Add-debug-printing-to-check-caller-PID.patch
index 0a7d4007f..fbd51df7a 100644
--- a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0001-peci-Add-debug-printing-to-check-caller-PID.patch
+++ b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0001-peci-Add-debug-printing-to-check-caller-PID.patch
@@ -1,4 +1,4 @@
-From 63d053b12cc7ca63a668872ce70e6592fe1dd7e5 Mon Sep 17 00:00:00 2001
+From 7474fe190f770e064a5ce5e939bd713ce2aa1de5 Mon Sep 17 00:00:00 2001
From: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
Date: Wed, 3 Feb 2021 16:18:37 -0800
Subject: [PATCH] peci: Add debug printing to check caller PID
@@ -16,18 +16,18 @@ Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
1 file changed, 5 insertions(+)
diff --git a/drivers/peci/peci-core.c b/drivers/peci/peci-core.c
-index 0fc2f246ada8..0fdb26a15150 100644
+index 10375e6087a5..02c8502fd846 100644
--- a/drivers/peci/peci-core.c
+++ b/drivers/peci/peci-core.c
-@@ -193,6 +193,7 @@ static int __peci_xfer(struct peci_adapter *adapter, struct peci_xfer_msg *msg,
+@@ -194,6 +194,7 @@ static int __peci_xfer(struct peci_adapter *adapter, struct peci_xfer_msg *msg,
bool do_retry, bool has_aw_fcs)
{
- uint interval_ms = PECI_DEV_RETRY_INTERVAL_MIN_MSEC;
+ uint interval_us = PECI_DEV_RETRY_INTERVAL_MIN_USEC;
+ char task_name[TASK_COMM_LEN];
ulong timeout = jiffies;
u8 aw_fcs;
int ret;
-@@ -213,6 +214,10 @@ static int __peci_xfer(struct peci_adapter *adapter, struct peci_xfer_msg *msg,
+@@ -214,6 +215,10 @@ static int __peci_xfer(struct peci_adapter *adapter, struct peci_xfer_msg *msg,
}
}
diff --git a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0003-Fix-libmctp-build-error.patch b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0003-Fix-libmctp-build-error.patch
new file mode 100644
index 000000000..b9a6ca527
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0003-Fix-libmctp-build-error.patch
@@ -0,0 +1,116 @@
+From af414e45bade3cf7277215d82b59a31c9b459cea Mon Sep 17 00:00:00 2001
+From: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+Date: Mon, 22 Feb 2021 15:27:22 -0800
+Subject: [PATCH] Fix libmctp build error
+
+This is a quick fix for libmctp building which includes staging
+kernel headers. It's a temporary fix until kernel tree fixes the
+rwonce.h including issue.
+
+Note: Do not upstream it.
+
+Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+---
+ include/asm/rwonce.h | 90 ++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 90 insertions(+)
+ create mode 100644 include/asm/rwonce.h
+
+diff --git a/include/asm/rwonce.h b/include/asm/rwonce.h
+new file mode 100644
+index 000000000000..11619bdbebae
+--- /dev/null
++++ b/include/asm/rwonce.h
+@@ -0,0 +1,90 @@
++/* SPDX-License-Identifier: GPL-2.0 */
++/*
++ * Prevent the compiler from merging or refetching reads or writes. The
++ * compiler is also forbidden from reordering successive instances of
++ * READ_ONCE and WRITE_ONCE, but only when the compiler is aware of some
++ * particular ordering. One way to make the compiler aware of ordering is to
++ * put the two invocations of READ_ONCE or WRITE_ONCE in different C
++ * statements.
++ *
++ * These two macros will also work on aggregate data types like structs or
++ * unions.
++ *
++ * Their two major use cases are: (1) Mediating communication between
++ * process-level code and irq/NMI handlers, all running on the same CPU,
++ * and (2) Ensuring that the compiler does not fold, spindle, or otherwise
++ * mutilate accesses that either do not require ordering or that interact
++ * with an explicit memory barrier or atomic instruction that provides the
++ * required ordering.
++ */
++#ifndef __ASM_GENERIC_RWONCE_H
++#define __ASM_GENERIC_RWONCE_H
++
++#ifndef __ASSEMBLY__
++
++#include <linux/compiler_types.h>
++#include <linux/kasan-checks.h>
++#include <linux/kcsan-checks.h>
++
++/*
++ * Yes, this permits 64-bit accesses on 32-bit architectures. These will
++ * actually be atomic in some cases (namely Armv7 + LPAE), but for others we
++ * rely on the access being split into 2x32-bit accesses for a 32-bit quantity
++ * (e.g. a virtual address) and a strong prevailing wind.
++ */
++#define compiletime_assert_rwonce_type(t) \
++ compiletime_assert(__native_word(t) || sizeof(t) == sizeof(long long), \
++ "Unsupported access size for {READ,WRITE}_ONCE().")
++
++/*
++ * Use __READ_ONCE() instead of READ_ONCE() if you do not require any
++ * atomicity. Note that this may result in tears!
++ */
++#ifndef __READ_ONCE
++#define __READ_ONCE(x) (*(const volatile __unqual_scalar_typeof(x) *)&(x))
++#endif
++
++#define READ_ONCE(x) \
++({ \
++ compiletime_assert_rwonce_type(x); \
++ __READ_ONCE(x); \
++})
++
++#define __WRITE_ONCE(x, val) \
++do { \
++ *(volatile typeof(x) *)&(x) = (val); \
++} while (0)
++
++#define WRITE_ONCE(x, val) \
++do { \
++ compiletime_assert_rwonce_type(x); \
++ __WRITE_ONCE(x, val); \
++} while (0)
++
++static __always_inline
++unsigned long __read_once_word_nocheck(const void *addr)
++{
++ return __READ_ONCE(*(unsigned long *)addr);
++}
++
++/*
++ * Use READ_ONCE_NOCHECK() instead of READ_ONCE() if you need to load a
++ * word from memory atomically but without telling KASAN/KCSAN. This is
++ * usually used by unwinding code when walking the stack of a running process.
++ */
++#define READ_ONCE_NOCHECK(x) \
++({ \
++ compiletime_assert(sizeof(x) == sizeof(unsigned long), \
++ "Unsupported access size for READ_ONCE_NOCHECK()."); \
++ (typeof(x))__read_once_word_nocheck(&(x)); \
++})
++
++static __always_inline
++unsigned long read_word_at_a_time(const void *addr)
++{
++ kasan_check_read(addr, 1);
++ return *(unsigned long *)addr;
++}
++
++#endif /* __ASSEMBLY__ */
++#endif /* __ASM_GENERIC_RWONCE_H */
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0004-Add-a-quick-fix-to-resolve-USB-gadget-DMA-issue.patch b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0004-Add-a-quick-fix-to-resolve-USB-gadget-DMA-issue.patch
new file mode 100644
index 000000000..2d435c796
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0004-Add-a-quick-fix-to-resolve-USB-gadget-DMA-issue.patch
@@ -0,0 +1,33 @@
+From cdd7104850d34cfe22902c45d69dac6cb506b087 Mon Sep 17 00:00:00 2001
+From: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+Date: Fri, 26 Feb 2021 11:00:54 -0800
+Subject: [PATCH] Add a quick fix to resolve USB gadget DMA issue.
+
+This is a quick fix to resolve USB gadget DMA issue and it should
+be removed when a real fix is added.
+
+Tested: Keyboard and mouse in KVM feature worked.
+
+Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+---
+ kernel/dma/mapping.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/kernel/dma/mapping.c b/kernel/dma/mapping.c
+index 51bb8fa8eb89..7bcfedeb1e30 100644
+--- a/kernel/dma/mapping.c
++++ b/kernel/dma/mapping.c
+@@ -146,8 +146,10 @@ dma_addr_t dma_map_page_attrs(struct device *dev, struct page *page,
+
+ BUG_ON(!valid_dma_direction(dir));
+
++#if 0 /* Quick fix to resolve USB gadget issue */
+ if (WARN_ON_ONCE(!dev->dma_mask))
+ return DMA_MAPPING_ERROR;
++#endif
+
+ if (dma_map_direct(dev, ops))
+ addr = dma_direct_map_page(dev, page, offset, size, dir, attrs);
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend
index b2865e511..5ca73f0d8 100644
--- a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -1,10 +1,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-KBRANCH = "dev-5.8-intel"
+KBRANCH = "dev-5.10-intel"
KSRC = "git://github.com/Intel-BMC/linux;protocol=ssh;branch=${KBRANCH}"
# Include this as a comment only for downstream auto-bump
-# SRC_URI = "git://github.com/Intel-BMC/linux;protocol=ssh;branch=dev-5.8-intel"
-SRCREV="0f6cc27c3bed1e633100e9ea8d8e0384ca51e613"
+# SRC_URI = "git://github.com/Intel-BMC/linux;protocol=ssh;branch=dev-5.10-intel"
+SRCREV="c306c95688f3e2d9ee9b5270eff4bfb3e6e34b8a"
do_compile_prepend(){
# device tree compiler flags
@@ -15,6 +15,8 @@ SRC_URI += " \
file://intel.cfg \
file://0001-peci-Add-debug-printing-to-check-caller-PID.patch \
file://0002-soc-aspeed-add-AST2600-A0-specific-fix-into-mbox-dri.patch \
+ file://0003-Fix-libmctp-build-error.patch \
+ file://0004-Add-a-quick-fix-to-resolve-USB-gadget-DMA-issue.patch \
"
SRC_URI += "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', 'file://0005-128MB-flashmap-for-PFR.patch', '', d)}"