summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-kernel
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-03-09 01:14:22 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-03-09 02:20:11 +0300
commit0cfc19e6565d8e3a1aa563c59edb347f9128026f (patch)
tree7146561723137e206a983483b06466d7ab5a9e2a /meta-openbmc-mods/meta-common/recipes-kernel
parent930df2e58b9725756edbccf99fd4979026fc28fd (diff)
downloadopenbmc-0cfc19e6565d8e3a1aa563c59edb347f9128026f.tar.xz
Update to internal 0.35
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-kernel')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0001-peci-Add-debug-printing-to-check-caller-PID.patch43
-rw-r--r--meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0002-soc-aspeed-add-AST2600-A0-specific-fix-into-mbox-dri.patch42
-rw-r--r--meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend4
3 files changed, 88 insertions, 1 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0001-peci-Add-debug-printing-to-check-caller-PID.patch b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0001-peci-Add-debug-printing-to-check-caller-PID.patch
new file mode 100644
index 000000000..0a7d4007f
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0001-peci-Add-debug-printing-to-check-caller-PID.patch
@@ -0,0 +1,43 @@
+From 63d053b12cc7ca63a668872ce70e6592fe1dd7e5 Mon Sep 17 00:00:00 2001
+From: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+Date: Wed, 3 Feb 2021 16:18:37 -0800
+Subject: [PATCH] peci: Add debug printing to check caller PID
+
+This commit adds debug printing out to check caller PID for traffic
+profiling.
+
+The printing can be enabled by this command:
+echo -n 'file drivers/peci/peci-core.c line 218 +p' > /sys/kernel/debug/dynamic_debug/control
+echo '8' > /proc/sys/kernel/printk
+
+Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+---
+ drivers/peci/peci-core.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/drivers/peci/peci-core.c b/drivers/peci/peci-core.c
+index 0fc2f246ada8..0fdb26a15150 100644
+--- a/drivers/peci/peci-core.c
++++ b/drivers/peci/peci-core.c
+@@ -193,6 +193,7 @@ static int __peci_xfer(struct peci_adapter *adapter, struct peci_xfer_msg *msg,
+ bool do_retry, bool has_aw_fcs)
+ {
+ uint interval_ms = PECI_DEV_RETRY_INTERVAL_MIN_MSEC;
++ char task_name[TASK_COMM_LEN];
+ ulong timeout = jiffies;
+ u8 aw_fcs;
+ int ret;
+@@ -213,6 +214,10 @@ static int __peci_xfer(struct peci_adapter *adapter, struct peci_xfer_msg *msg,
+ }
+ }
+
++ get_task_comm(task_name, current);
++ dev_dbg(&adapter->dev, "%s is called by %s(%d) through %s\n",
++ __func__, task_name, current->pid, adapter->name);
++
+ /*
+ * For some commands, the PECI originator may need to retry a command if
+ * the processor PECI client responds with a 0x8x completion code. In
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0002-soc-aspeed-add-AST2600-A0-specific-fix-into-mbox-dri.patch b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0002-soc-aspeed-add-AST2600-A0-specific-fix-into-mbox-dri.patch
new file mode 100644
index 000000000..1e1dac7a8
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed/0002-soc-aspeed-add-AST2600-A0-specific-fix-into-mbox-dri.patch
@@ -0,0 +1,42 @@
+From ae96ce5f2a5bd76b234cea6fc3f0bf1df74387f3 Mon Sep 17 00:00:00 2001
+From: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+Date: Thu, 4 Feb 2021 00:29:55 -0800
+Subject: [PATCH] soc: aspeed: add AST2600 A0 specific fix into mbox driver
+
+AST2600 A0 has the same LPC mbox register structure with AST2500
+but AST2600 A1 and later revision is different so this commit adds
+AST2600 A0 specific fix into the mbox driver.
+
+Signed-off-by: Jae Hyun Yoo <jae.hyun.yoo@intel.com>
+---
+ drivers/soc/aspeed/aspeed-lpc-mbox.c | 14 ++++++++++++++
+ 1 file changed, 14 insertions(+)
+
+diff --git a/drivers/soc/aspeed/aspeed-lpc-mbox.c b/drivers/soc/aspeed/aspeed-lpc-mbox.c
+index 8dd3345682c7..12bb436dda78 100644
+--- a/drivers/soc/aspeed/aspeed-lpc-mbox.c
++++ b/drivers/soc/aspeed/aspeed-lpc-mbox.c
+@@ -363,6 +363,20 @@ static int aspeed_mbox_probe(struct platform_device *pdev)
+ return -EINVAL;
+
+ config = match->data;
++
++ if (of_device_is_compatible(pdev->dev.of_node,
++ "aspeed,ast2600-mbox")) {
++ #define REV_ID_IO_OFFSET 0x1e6e2014
++ #define REV_ID_AST2600A0 0x05000303
++ void __iomem *chip_id_base = devm_ioremap(&pdev->dev,
++ REV_ID_IO_OFFSET,
++ sizeof(u32));
++
++ if (!IS_ERR(chip_id_base) &&
++ readl(chip_id_base) == REV_ID_AST2600A0)
++ config = &ast2500_config;
++ }
++
+ memcpy(&mbox->configs, config, sizeof(mbox->configs));
+
+ rc = of_property_read_u32(dev->of_node, "reg", &mbox->base);
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend
index b01cd0d24..b2865e511 100644
--- a/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -4,7 +4,7 @@ KBRANCH = "dev-5.8-intel"
KSRC = "git://github.com/Intel-BMC/linux;protocol=ssh;branch=${KBRANCH}"
# Include this as a comment only for downstream auto-bump
# SRC_URI = "git://github.com/Intel-BMC/linux;protocol=ssh;branch=dev-5.8-intel"
-SRCREV="fc4c626deff9447cd5453b180826ed4f48fc828d"
+SRCREV="0f6cc27c3bed1e633100e9ea8d8e0384ca51e613"
do_compile_prepend(){
# device tree compiler flags
@@ -13,6 +13,8 @@ do_compile_prepend(){
SRC_URI += " \
file://intel.cfg \
+ file://0001-peci-Add-debug-printing-to-check-caller-PID.patch \
+ file://0002-soc-aspeed-add-AST2600-A0-specific-fix-into-mbox-dri.patch \
"
SRC_URI += "${@bb.utils.contains('IMAGE_FSTYPES', 'intel-pfr', 'file://0005-128MB-flashmap-for-PFR.patch', '', d)}"