summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/dbus
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 01:11:22 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-07-10 20:11:31 +0300
commitd071adf43ac87f21dde2f84287120960c723962c (patch)
tree05a1d365e0faa6ce8570b2d0c2d0f100dc8df1d4 /meta-openbmc-mods/meta-common/recipes-phosphor/dbus
parentf24c1e9afc47a421831278b57377951e71494d92 (diff)
downloadopenbmc-d071adf43ac87f21dde2f84287120960c723962c.tar.xz
Update to internal 0.66
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/dbus')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0027-Apply-Options-interface-for-Software.patch47
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0028-MCTP-Daemon-D-Bus-interface-definition.patch21
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend7
3 files changed, 64 insertions, 11 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0027-Apply-Options-interface-for-Software.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0027-Apply-Options-interface-for-Software.patch
new file mode 100644
index 000000000..3d2cc43e2
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0027-Apply-Options-interface-for-Software.patch
@@ -0,0 +1,47 @@
+From 153b125043c28f933579330727d82658979caef3 Mon Sep 17 00:00:00 2001
+From: Vikram Bodireddy <vikram.bodireddy@intel.com>
+Date: Mon, 18 May 2020 20:16:04 +0530
+Subject: [PATCH] Apply Options interface for Software
+
+Apply Options interface is used to pass the settings related to
+firmware image activation such as ClearConfig.
+ClearConfig property is used to denote whether to clear firmware
+configurations along with firmware image activation or not.
+
+Example case:
+BIOS usually requires its NVRAM configuration to be updated or
+erased for certain BIOS firmware updates. Current implementation
+doesn't support to take this option and provide interface to do
+the necessary actions.
+
+Signed-off-by: Vikram Bodireddy <vikram.bodireddy@intel.com>
+---
+ .../Software/ApplyOptions.interface.yaml | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+ create mode 100644 xyz/openbmc_project/Software/ApplyOptions.interface.yaml
+
+diff --git a/xyz/openbmc_project/Software/ApplyOptions.interface.yaml b/xyz/openbmc_project/Software/ApplyOptions.interface.yaml
+new file mode 100644
+index 0000000..45a68ab
+--- /dev/null
++++ b/xyz/openbmc_project/Software/ApplyOptions.interface.yaml
+@@ -0,0 +1,16 @@
++description: >
++ To implement the Activation apply options for a newly uploaded firmware
++ image. The apply options property is global and is specifically used with
++ each firmware update and is used during firmware activation.
++ ApplyOptions usage during firmware activation is implementation specific,
++ not all firmware targets need ApplyOptions.
++ The default value of this property is false.
++properties:
++ - name: ClearConfig
++ type: boolean
++ default: false
++ description: >
++ This property indicates whether to clear the software configurations
++ when the firmware image update is getting applied. A value of true
++ indicates the firmware configurations should be cleared along with
++ firmware image activation.
+--
+2.17.1
+
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0028-MCTP-Daemon-D-Bus-interface-definition.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0028-MCTP-Daemon-D-Bus-interface-definition.patch
index fba025207..dc44d7a0d 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0028-MCTP-Daemon-D-Bus-interface-definition.patch
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0028-MCTP-Daemon-D-Bus-interface-definition.patch
@@ -1,4 +1,4 @@
-From 7a3fc3a969d2a187be20a972a5a7209944731bea Mon Sep 17 00:00:00 2001
+From 9bcc45f1a4d872e9968fdebf675c5fff6921c2f3 Mon Sep 17 00:00:00 2001
From: "Kowalski, Mariusz" <mariusz.kowalski@intel.com>
Date: Thu, 27 Feb 2020 15:48:56 +0100
Subject: [PATCH] MCTP Daemon D-Bus interface definition.
@@ -7,6 +7,7 @@ This interface definition was created on base of the MCTP design
proposed in this document:
https://gerrit.openbmc-project.xyz/c/openbmc/docs/+/28424/9/designs/mctp.md
+Signed-off-by: Arun P. Mohanan <arun.p.m@linux.intel.com>
Signed-off-by: Mariusz Kowalski <mariusz.kowalski@intel.com>
Signed-off-by: Karol Wachowski <karol.wachowski@intel.com>
Change-Id: Ida66f8ffcf00003655edcb0fb0112202797b8e1a
@@ -14,11 +15,11 @@ Change-Id: Ida66f8ffcf00003655edcb0fb0112202797b8e1a
xyz/openbmc_project/MCTP/Base.interface.yaml | 231 ++++++++++++++++++
.../MCTP/Binding/PCIe.interface.yaml | 29 +++
.../MCTP/Binding/SMBus.interface.yaml | 17 ++
- .../MCTP/BusOwner.interface.yaml | 15 ++
+ .../MCTP/BusOwner.interface.yaml | 17 ++
.../MCTP/Endpoint.interface.yaml | 19 ++
xyz/openbmc_project/MCTP/README.md | 38 +++
.../MCTP/SupportedMessageTypes.interface.yaml | 36 +++
- 7 files changed, 385 insertions(+)
+ 7 files changed, 387 insertions(+)
create mode 100644 xyz/openbmc_project/MCTP/Base.interface.yaml
create mode 100644 xyz/openbmc_project/MCTP/Binding/PCIe.interface.yaml
create mode 100644 xyz/openbmc_project/MCTP/Binding/SMBus.interface.yaml
@@ -29,7 +30,7 @@ Change-Id: Ida66f8ffcf00003655edcb0fb0112202797b8e1a
diff --git a/xyz/openbmc_project/MCTP/Base.interface.yaml b/xyz/openbmc_project/MCTP/Base.interface.yaml
new file mode 100644
-index 0000000..9a649a5
+index 0000000..f27c1c7
--- /dev/null
+++ b/xyz/openbmc_project/MCTP/Base.interface.yaml
@@ -0,0 +1,231 @@
@@ -324,17 +325,19 @@ index 0000000..9219ad0
+ description: Slave address to be used for this medium
diff --git a/xyz/openbmc_project/MCTP/BusOwner.interface.yaml b/xyz/openbmc_project/MCTP/BusOwner.interface.yaml
new file mode 100644
-index 0000000..0853381
+index 0000000..d46298e
--- /dev/null
+++ b/xyz/openbmc_project/MCTP/BusOwner.interface.yaml
-@@ -0,0 +1,15 @@
+@@ -0,0 +1,17 @@
+description: >
+ Interface exposed by MCTP root object, when executing in Bus Owner mode.
+
+properties:
+ - name: EidPool
+ type: array[struct[byte, byte]]
-+ description: Pool of allowed EIDs to be used
++ description: >
++ Pool of allowed EIDs to be used.
++ EID pool of 10-100 can be specified as {{10,100}}.
+
+ - name: TopMostBusOwner
+ type: boolean
@@ -370,7 +373,7 @@ index 0000000..b7f9a67
+ MCTP network within a platform.
diff --git a/xyz/openbmc_project/MCTP/README.md b/xyz/openbmc_project/MCTP/README.md
new file mode 100644
-index 0000000..1c3b4aa
+index 0000000..3255ef2
--- /dev/null
+++ b/xyz/openbmc_project/MCTP/README.md
@@ -0,0 +1,38 @@
@@ -408,7 +411,7 @@ index 0000000..1c3b4aa
+following interfaces.
+1. `xyz.openbmc_project.MCTP.SupportedMessageTypes` which exposes supported MCTP
+message types for the discovered MCTP Endpoint.
-+2. `xyz.openbmc_project.MCTP.Enpoint` which exposes properties like UUID and endpoint
++2. `xyz.openbmc_project.MCTP.Endpoint` which exposes properties like UUID and endpoint
+mode (to identify Bus Owner or Bridge or Endpoint) for the discovered MCTP Endpoint.
+3. `xyz.openbmc_project.MCTP.Bridge` available only for discovered MCTP Bridges to
+expose properties like EID pool. (TBD)
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
index 762efe2b4..adebde874 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
@@ -1,5 +1,7 @@
-SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces.git"
-SRCREV = "fdd88281dd243b3b9e6140b3f7b59aaaa188f37e"
+SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces.git;nobranch=1"
+
+# todo(Johnathan) fix nobranch
+SRCREV = "26ff1c84469e470e28257f3584e1b1126d4783f0"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
@@ -12,5 +14,6 @@ SRC_URI += "file://0005-Add-DBUS-interface-of-CPU-and-Memory-s-properties.patch
file://0025-Add-PreInterruptFlag-properity-in-DBUS.patch \
file://0001-Reapply-Enhance-DHCP-beyond-just-OFF-and-IPv4-IPv6-e.patch \
file://0026-Add-StandbySpare-support-for-software-inventory.patch \
+ file://0027-Apply-Options-interface-for-Software.patch \
file://0028-MCTP-Daemon-D-Bus-interface-definition.patch \
"