summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/dbus
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-07-31 20:43:37 +0300
committerEd Tanous <ed.tanous@intel.com>2019-08-01 18:19:38 +0300
commitd0f63ef62c76c932a2003eaa42c0b250065ae06f (patch)
tree4c0e3cb32dc80f80460bdbf82ff6d401d4ff194f /meta-openbmc-mods/meta-common/recipes-phosphor/dbus
parentb4f66bacb1b8e661d794fa7a189e2f66f5092e2e (diff)
downloadopenbmc-d0f63ef62c76c932a2003eaa42c0b250065ae06f.tar.xz
Update to internal 7-31-19
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/dbus')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0002-Modify-Dbus-for-IPv6.patch38
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0003-Chassis-Power-Control-are-implemented.patch264
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0009-Add-host-restart-cause-property.patch98
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0014-Add-multiple-state-signal-for-host-start-and-stop.patch63
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0019-Creating-the-Session-interface-for-Host-and-LAN.patch116
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-Add-interface-suppot-for-provisioning-modes.patch52
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-D-Bus-Intf-Security-modes-property-intf-update.patch80
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0023-Add-host-interrupt-to-the-Host-State.patch31
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0025-Add-PreInterruptFlag-properity-in-DBUS.patch39
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend10
10 files changed, 140 insertions, 651 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0002-Modify-Dbus-for-IPv6.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0002-Modify-Dbus-for-IPv6.patch
index 3ca81c388..fc09da3bd 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0002-Modify-Dbus-for-IPv6.patch
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0002-Modify-Dbus-for-IPv6.patch
@@ -1,26 +1,24 @@
-From 068b816b3c9bf75dcd2a808fc81c67a32fbe29ea Mon Sep 17 00:00:00 2001
+From 62240a7ef12bb2ed3730a625ad7a809a9a6d0512 Mon Sep 17 00:00:00 2001
From: David Cobbley <david.j.cobbley@linux.intel.com>
Date: Wed, 6 Jun 2018 10:11:58 -0700
-Subject: [PATCH] Modify Dbus for IPv6.
+Subject: [PATCH 1/1] Modify Dbus for IPv6.
Add additional interfaces for IPv6 use.
+
+Signed-off-by: James Feist <james.feist@linux.intel.com>
---
- .../Network/EthernetInterface.interface.yaml | 17 ++++++++++++++++-
- xyz/openbmc_project/Network/IP.interface.yaml | 4 ++++
- 2 files changed, 20 insertions(+), 1 deletion(-)
+ .../Network/EthernetInterface.interface.yaml | 13 ++++++++++++-
+ xyz/openbmc_project/Network/IP.interface.yaml | 4 ++++
+ 2 files changed, 16 insertions(+), 1 deletion(-)
diff --git a/xyz/openbmc_project/Network/EthernetInterface.interface.yaml b/xyz/openbmc_project/Network/EthernetInterface.interface.yaml
-index 744ac77..6b7cd9a 100644
+index 6fa1d0b..6b7cd9a 100644
--- a/xyz/openbmc_project/Network/EthernetInterface.interface.yaml
+++ b/xyz/openbmc_project/Network/EthernetInterface.interface.yaml
-@@ -42,6 +42,14 @@ properties:
+@@ -46,6 +46,10 @@ properties:
+ type: boolean
description: >
- This indicates link local auto configuration on this ethernet
- interface and configured on this ethernet interface.
-+ - name: IPv6AcceptRA
-+ type: boolean
-+ description: >
-+ Boolean for accepting router advertisements in IPv6
+ Boolean for accepting router advertisements in IPv6
+ - name: IPAddressEnables
+ type: enum[self.IPAllowed]
+ description: >
@@ -28,7 +26,7 @@ index 744ac77..6b7cd9a 100644
enumerations:
- name: LinkLocalConf
-@@ -52,4 +60,11 @@ enumerations:
+@@ -56,4 +60,11 @@ enumerations:
- name: v4
- name: v6
- name: none
@@ -42,13 +40,13 @@ index 744ac77..6b7cd9a 100644
+ - name: IPv4Only
+ - name: IPv6Only
diff --git a/xyz/openbmc_project/Network/IP.interface.yaml b/xyz/openbmc_project/Network/IP.interface.yaml
-index 565dcd6..2ffb016 100644
+index 5091ac9..b2442a5 100644
--- a/xyz/openbmc_project/Network/IP.interface.yaml
+++ b/xyz/openbmc_project/Network/IP.interface.yaml
-@@ -22,6 +22,10 @@ properties:
- type: string
- description: >
- This is the IP gateway for this address.
+@@ -34,6 +34,10 @@ properties:
+ errors:
+ - xyz::openbmc_project.Common.Error.NotAllowed
+
+ - name: BackupGateway
+ type: string
+ description: >
@@ -57,5 +55,5 @@ index 565dcd6..2ffb016 100644
type: enum[self.Protocol]
description: >
--
-2.7.4
+2.17.1
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0003-Chassis-Power-Control-are-implemented.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0003-Chassis-Power-Control-are-implemented.patch
deleted file mode 100644
index 0e25856ac..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0003-Chassis-Power-Control-are-implemented.patch
+++ /dev/null
@@ -1,264 +0,0 @@
-From a20f9fa9941533b591b6bbfe6b22a74b7c0dfe64 Mon Sep 17 00:00:00 2001
-From: Ed Tanous <ed.tanous@intel.com>
-Date: Thu, 24 Jan 2019 09:29:01 -0800
-Subject: [PATCH] Chassis Power Control are implemented.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Feature level:
-Power on server is ready
-Power off server is ready
-Power cycle server is ready
-Power reset server is ready
-
-Framework level:
-WebUI is enabled.
-IPMI Commands is enabled.
-Restful API is enabled.
-Physical buttons (Power/Reset/ID) are enabled.
-Chassis state manager is enabled.
-Host state manager is enabled.
-
-Enabled IPMI commands:
-ipmitool -H <ip_addr> -P <pass_word> -I lanplus chassis status
-ipmitool -H <ip_addr>  -P <pass_word> -I lanplus chassis power status
-ipmitool -H <ip_addr>  -P <pass_word> -I lanplus chassis power on
-ipmitool -H <ip_addr>  -P <pass_word> -I lanplus chassis power off
-ipmitool -H <ip_addr>  -P <pass_word> -I lanplus chassis power cycle
-ipmitool -H <ip_addr>  -P <pass_word> -I lanplus chassis power reset
-
-Enabled Restful APIs:
-Login: curl --noproxy <ip_addr> -c cjar -b cjar -k -H "Content-Type: application/json" -X POST https://<ip_addr>/login -d "{\"data\": [ \"root\", \"0penBmc\" ] }“
-Host State: curl --noproxy <ip_addr> -b cjar -k https://<ip_addr>/xyz/openbmc_project/state/host0
-Chassis State: curl --noproxy <ip_addr> -b cjar -k https://<ip_addr>/xyz/openbmc_project/state/chassis0
-Power state: curl --noproxy <ip_addr> -b cjar -k https://<ip_addr>/xyz/openbmc_project/Chassis/Control/Power0
-Power on/off: curl --noproxy <ip_addr> -q1c cjar -b cjar -k -H "Content-Type: application/json" -d '{"data": "xyz.openbmc_project.State.Host.Transition.Off"}' -X PUT https://<ip_addr>/xyz/openbmc_project/state/host0/attr/RequestedHostTransition
-
-Signed-off-by: Kuiying Wang <kuiying.wang@intel.com>
-Signed-off-by: Yong Li <yong.b.li@linux.intel.com>
----
- .../Chassis/Control/Chassis.interface.yaml | 94 ++++++++++++++++++++++
- .../Chassis/Control/Power.interface.yaml | 92 ++++++++++++++++++---
- 2 files changed, 173 insertions(+), 13 deletions(-)
- create mode 100644 xyz/openbmc_project/Chassis/Control/Chassis.interface.yaml
-
-diff --git a/xyz/openbmc_project/Chassis/Control/Chassis.interface.yaml b/xyz/openbmc_project/Chassis/Control/Chassis.interface.yaml
-new file mode 100644
-index 0000000..c28492a
---- /dev/null
-+++ b/xyz/openbmc_project/Chassis/Control/Chassis.interface.yaml
-@@ -0,0 +1,94 @@
-+description: >
-+ chassis control service
-+methods:
-+ - name: powerOn
-+ description: >
-+ Power on system.
-+ returns:
-+ - name: state
-+ type: int32
-+ description: >
-+ The result of command.
-+ errors:
-+ - xyz.openbmc_project.Chassis.Common.Error.UnsupportedCommand
-+
-+ - xyz.openbmc_project.Chassis.Common.Error.IOError
-+
-+ - name: powerOff
-+ description: >
-+ Power Off system.
-+ returns:
-+ - name: state
-+ type: int32
-+ description: >
-+ The result of command.
-+ errors:
-+ - xyz.openbmc_project.Chassis.Common.Error.UnsupportedCommand
-+
-+ - xyz.openbmc_project.Chassis.Common.Error.IOError
-+
-+ - name: softPowerOff
-+ description: >
-+ Soft Power off system.
-+ returns:
-+ - name: state
-+ type: int32
-+ description: >
-+ The result of command.
-+ errors:
-+ - xyz.openbmc_project.Chassis.Common.Error.UnsupportedCommand
-+
-+ - xyz.openbmc_project.Chassis.Common.Error.IOError
-+
-+ - name: reboot
-+ description: >
-+ reboot system.
-+ returns:
-+ - name: state
-+ type: int32
-+ description: >
-+ The result of command.
-+ errors:
-+ - xyz.openbmc_project.Chassis.Common.Error.UnsupportedCommand
-+
-+ - xyz.openbmc_project.Chassis.Common.Error.IOError
-+
-+ - name: softReboot
-+ description: >
-+ Soft Reboot system.
-+ returns:
-+ - name: state
-+ type: int32
-+ description: >
-+ The result of command.
-+ errors:
-+ - xyz.openbmc_project.Chassis.Common.Error.UnsupportedCommand
-+
-+ - xyz.openbmc_project.Chassis.Common.Error.IOError
-+
-+ - name: quiesce
-+ description: >
-+ Quiesce system.
-+ returns:
-+ - name: state
-+ type: int32
-+ description: >
-+ The result of command.
-+ errors:
-+ - xyz.openbmc_project.Chassis.Common.Error.UnsupportedCommand
-+
-+ - xyz.openbmc_project.Chassis.Common.Error.IOError
-+
-+ - name: getPowerState
-+ description: >
-+ Get system power state.
-+ returns:
-+ - name: state
-+ type: int32
-+ description: >
-+ The result of command.
-+ errors:
-+ - xyz.openbmc_project.Chassis.Common.Error.UnsupportedCommand
-+
-+ - xyz.openbmc_project.Chassis.Common.Error.IOError
-+
-diff --git a/xyz/openbmc_project/Chassis/Control/Power.interface.yaml b/xyz/openbmc_project/Chassis/Control/Power.interface.yaml
-index 082586f..368beca 100644
---- a/xyz/openbmc_project/Chassis/Control/Power.interface.yaml
-+++ b/xyz/openbmc_project/Chassis/Control/Power.interface.yaml
-@@ -1,31 +1,97 @@
- description: >
-- Power control service
-+ Chassis control service
- methods:
-+ - name: setPowerState
-+ description: >
-+ set host power state.
-+ parameters:
-+ - name: state
-+ type: int32
-+ description: >
-+ 0 for force power off host
-+ 1 for power on host
-+ returns:
-+ - name: status
-+ type: int32
-+ description: >
-+ The result of command.
-+ errors:
-+ - xyz.openbmc_project.Chassis.Common.Error.UnsupportedCommand
-+
-+ - xyz.openbmc_project.Chassis.Common.Error.IOError
-+
-+ - name: getPowerState
-+ description: >
-+ Get current host power status.
-+ returns:
-+ - name: status
-+ type: int32
-+ description: >
-+ Current host status,
-+ 0 for host power off
-+ 1 for host power on
-+ errors:
-+ - xyz.openbmc_project.Chassis.Common.Error.UnsupportedCommand
-+
-+ - xyz.openbmc_project.Chassis.Common.Error.IOError
-+
- - name: forcePowerOff
- description: >
- Force power off the host.
- returns:
- - name: status
-- type: boolean
-+ type: int32
- description: >
- The result of power off command.
- errors:
- - xyz.openbmc_project.Chassis.Common.Error.UnsupportedCommand
-+
- - xyz.openbmc_project.Chassis.Common.Error.IOError
-
- properties:
-- - name: PGood
-- type: boolean
-- default: false
-+ - name: vrd_good
-+ type: int32
-+ default: 0
-+ description: >
-+ ACPI status
-+ - name: s4s5_state
-+ type: int32
-+ default: 0
-+ description: >
-+ ACPI status
-+ - name: pgood
-+ type: int32
-+ default: 0
- description: >
-- PSU Power good property
-- It is a read-only property.
-- - name: State
-+ pgood property
-+ - name: state
- type: int32
- default: 0
- description: >
-- System power status
-- 0: power is off
-- 1: power is on
-- Setting its value to change the system state
-- Read its value to get the system state.
-\ No newline at end of file
-+ state property
-+ - name: pgood_timeout
-+ type: int32
-+ default: 0
-+ description: >
-+ pgoodtimeout property
-+ - name: post_complete
-+ type: boolean
-+ default: false
-+ description: >
-+ The current BIOS POST state,
-+ false means not completed or system reset,
-+ true means BIOS POST completed.
-+ - name: PFail
-+ type: boolean
-+ default: true
-+ description: >
-+ The current booting status,
-+ true means booting from AC loss,
-+ false means not booting from AC loss.
-+signals:
-+ - name: PowerGood
-+ description: >
-+ Signal for powergood
-+ - name: PowerLost
-+ description: >
-+ Signal for powerlost
---
-2.7.4
-
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0009-Add-host-restart-cause-property.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0009-Add-host-restart-cause-property.patch
deleted file mode 100644
index 1221a0ab4..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0009-Add-host-restart-cause-property.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From 72b7b30a5dda56c170ee2ce82c1082c26f4663e3 Mon Sep 17 00:00:00 2001
-From: Kuiying Wang <kuiying.wang@intel.com>
-Date: Tue, 31 Jul 2018 16:55:21 +0800
-Subject: [PATCH] Add host restart cause property.
-
-Add host restart cause property to track the information about what
-action last caused the system to restart.
-According to IPMI Spec, it includes 12 types as following:
-1. Unknown 0x0
-2. IpmiCommand 0x1
-3. ResetButton 0x2
-4. PowerButton 0x3
-5. WatchdogTimer 0x4
-6. OEM 0x5
-7. PowerPolicyAlwaysOn 0x6
-8. PowerPolicyPreviousState 0x7
-9. PEF-Reset 0x8
-10. PEF-PowerCycle 0x9
-11. SoftReset 0xA
-12. RTC-Wakeup 0xB
-
-Change-Id: Id2cc6a18b98e485a978940e5ffc085bf5c4fbed8
-Signed-off-by: Kuiying Wang <kuiying.wang@intel.com>
----
- xyz/openbmc_project/State/Host.interface.yaml | 52 +++++++++++++++++++
- 1 file changed, 52 insertions(+)
-
-diff --git a/xyz/openbmc_project/State/Host.interface.yaml b/xyz/openbmc_project/State/Host.interface.yaml
-index 8f481b8..a4d88d0 100644
---- a/xyz/openbmc_project/State/Host.interface.yaml
-+++ b/xyz/openbmc_project/State/Host.interface.yaml
-@@ -17,6 +17,12 @@ properties:
- comparing the CurrentHostState and the RequestedHostTransition
- properties.
-
-+ - name: HostRestartCause
-+ type: enum[self.RestartCause]
-+ default: Unknown
-+ description: >
-+ The information about what action last caused the system to restart.
-+
- enumerations:
- - name: Transition
- description: >
-@@ -45,3 +51,49 @@ enumerations:
- - name: 'Quiesced'
- description: >
- Host firmware is quiesced
-+
-+ - name: RestartCause
-+ description: >
-+ The information about what action last caused the system to restart.
-+ values:
-+ - name: Unknown
-+ description: >
-+ System start/restart detected but the reason is unknown.
-+ - name: IpmiCommand
-+ description: >
-+ System start/restart detected and caused by ipmi command.
-+ - name: ResetButton
-+ description: >
-+ System start/restart detected and caused by reset button.
-+ - name: PowerButton
-+ description: >
-+ System start/restart detected and caused by power button.
-+ - name: WatchdogTimer
-+ description: >
-+ System start/restart detected and casued by watchdog expiration.
-+ - name: OEM
-+ description: >
-+ System start/restart detected and caused by OEM command.
-+ - name: PowerPolicyAlwaysOn
-+ description: >
-+ System start/restart detected and caused by power restore policy
-+ "chassis always powers up after AC/mains is applied or returns".
-+ - name: PowerPolicyPreviousState
-+ description: >
-+ System start/restart detected and caused by power restore policy
-+ "after AC/mains is applied or returns, power is restored to the
-+ state was in effect when AC/mains removed or lost".
-+ - name: PEFReset
-+ description: >
-+ System start/restart detected and caused by PEF(reset).
-+ - name: PEFPowerCycle
-+ description: >
-+ System start/restart detected and caused by PEF(power-cycle).
-+ - name: SoftReset
-+ description: >
-+ System start/restart detected and caused by soft reset like
-+ "CTRL-ALT-DEL".
-+ - name: RTCWakeup
-+ description: >
-+ System start/restart detected and caused by system real time
-+ clock(RTC) wakeup.
-\ No newline at end of file
---
-2.17.0
-
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0014-Add-multiple-state-signal-for-host-start-and-stop.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0014-Add-multiple-state-signal-for-host-start-and-stop.patch
deleted file mode 100644
index a8d732dab..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0014-Add-multiple-state-signal-for-host-start-and-stop.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 6d0069f4a2b4637c58fd321c9db3034ac9dd17c7 Mon Sep 17 00:00:00 2001
-From: Kuiying Wang <kuiying.wang@intel.com>
-Date: Wed, 12 Sep 2018 15:03:26 +0800
-Subject: [PATCH] Add multiple state signal for host start and stop
-
-Add six host state signals like following:
- - name: PreHostStart
- description: >
- This is the signal to indicate host is at pre start stage.
- - name: PostHostStart
- description: >
- This is the signal to indicate host is at start complete stage.
- - name: HostStarting
- description: >
- This is the signal to indicate host is at starting stage.
- - name: HostStoping
- description: >
- This is the signal to indicate host is at stoping stage.
- - name: PreHostStop
- description: >
- This is the signal to indicate host is at pre stop stage.
- - name: PostHostStop
- description: >
- This is the signal to indicate host is at stop complete stage.
-
-Signed-off-by: Kuiying Wang <kuiying.wang@intel.com>
----
- xyz/openbmc_project/State/Host.interface.yaml | 21 ++++++++++++++++++++-
- 1 file changed, 20 insertions(+), 1 deletion(-)
-
-diff --git a/xyz/openbmc_project/State/Host.interface.yaml b/xyz/openbmc_project/State/Host.interface.yaml
-index 8531a27..1ceba13 100644
---- a/xyz/openbmc_project/State/Host.interface.yaml
-+++ b/xyz/openbmc_project/State/Host.interface.yaml
-@@ -96,4 +96,23 @@ enumerations:
- - name: RTCWakeup
- description: >
- System start/restart detected and caused by system real time
-- clock(RTC) wakeup.
-\ No newline at end of file
-+ clock(RTC) wakeup.
-+signals:
-+ - name: PreHostStart
-+ description: >
-+ This is the signal to indicate host is at pre start stage.
-+ - name: PostHostStart
-+ description: >
-+ This is the signal to indicate host is at start complete stage.
-+ - name: HostStarting
-+ description: >
-+ This is the signal to indicate host is at starting stage.
-+ - name: HostStoping
-+ description: >
-+ This is the signal to indicate host is at stoping stage.
-+ - name: PreHostStop
-+ description: >
-+ This is the signal to indicate host is at pre stop stage.
-+ - name: PostHostStop
-+ description: >
-+ This is the signal to indicate host is at stop complete stage.
---
-2.16.2
-
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0019-Creating-the-Session-interface-for-Host-and-LAN.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0019-Creating-the-Session-interface-for-Host-and-LAN.patch
deleted file mode 100644
index 47fab819b..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0019-Creating-the-Session-interface-for-Host-and-LAN.patch
+++ /dev/null
@@ -1,116 +0,0 @@
-From 28fac58dc6ef975e1e9283163d9f1e4c7764c3cc Mon Sep 17 00:00:00 2001
-From: Suryakanth Sekar <suryakanth.sekar@linux.intel.com>
-Date: Sat, 2 Mar 2019 03:31:09 +0530
-Subject: [PATCH] Creating the Session interface- for Host and LAN
-
-Defined all needed session properites to manage the session in
-host and also in LAN
-
-Change-Id: Ic7cccfc3333a602ee07fcd60077ec58fd8f06304
-Signed-off-by: Suryakanth Sekar <suryakanth.sekar@linux.intel.com>
-
-%% original patch: 0019-Creating-the-Session-interface-for-Host-and-LAN.patch
----
- xyz/openbmc_project/Ipmi/SESSION_README.md | 25 ++++++++++
- .../Ipmi/SessionInfo.interface.yaml | 57 ++++++++++++++++++++++
- 2 files changed, 82 insertions(+)
- create mode 100644 xyz/openbmc_project/Ipmi/SESSION_README.md
- create mode 100644 xyz/openbmc_project/Ipmi/SessionInfo.interface.yaml
-
-diff --git a/xyz/openbmc_project/Ipmi/SESSION_README.md b/xyz/openbmc_project/Ipmi/SESSION_README.md
-new file mode 100644
-index 0000000..c59b251
---- /dev/null
-+++ b/xyz/openbmc_project/Ipmi/SESSION_README.md
-@@ -0,0 +1,25 @@
-+# Session Management
-+
-+## Overview
-+IPMI RMCP+ sessions are created and maintained by phosphor-ipmi-net daemon,
-+whereas we need to provide details about the same using phosphor-ipmi-host.
-+Hence IPMI RMCP+ session details has to be exposed through D-Bus interface,
-+so that both phosphor-ipmi-host & phosphr-ipmi-net will be in sync.
-+
-+
-+#### xyz.openbmc_project.Ipmi.SessionInfo interface
-+##### properties
-+* SessionHandle - SessionHandle,unique one-byte number to locate the session.
-+* Channel - Session created channel.
-+* SessionPrivilege - Privilege of the session.
-+* RemoteIPAddr – Remote IP address.
-+* RemotePort - Remote port address.
-+* RemoteMACAddress -Remote MAC Address.
-+* UserID - Session created by given user id.
-+
-+
-+
-+#### xyz.openbmc_project.Object.Delete
-+#### methods
-+* Delete - To delete the session object in the system.
-+
-diff --git a/xyz/openbmc_project/Ipmi/SessionInfo.interface.yaml b/xyz/openbmc_project/Ipmi/SessionInfo.interface.yaml
-new file mode 100644
-index 0000000..d461628
---- /dev/null
-+++ b/xyz/openbmc_project/Ipmi/SessionInfo.interface.yaml
-@@ -0,0 +1,57 @@
-+description: >
-+ Provides properties for IPMI RMCP+ session objects.
-+ Provides RMCP+ session information as session objects
-+ with Session ID (unique identifier) as path suffix.
-+
-+properties:
-+ - name: SessionHandle
-+ type: byte
-+ description: >
-+ Session Handle,unique number to locate the session.
-+ errors:
-+ - xyz.openbmc_project.Common.Error.InternalFailure
-+ - name: ChannelNum
-+ type: byte
-+ description: >
-+ channelnumber which session is created.
-+ errors:
-+ - xyz.openbmc_project.Common.Error.InternalFailure
-+ - name: CurrentPrivilege
-+ type: byte
-+ description: >
-+ Privilege of the session.
-+ errors:
-+ - xyz.openbmc_project.Common.Error.InternalFailure
-+ - name: RemoteIPAddr
-+ type: uint32
-+ description: >
-+ Remote IP address.
-+ errors:
-+ - xyz.openbmc_project.Common.Error.InternalFailure
-+ - name: RemotePort
-+ type: uint16
-+ description: >
-+ Remote IP Port.
-+ errors:
-+ - xyz.openbmc_project.Common.Error.InternalFailure
-+ - name: RemoteMACAddress
-+ type: array[byte]
-+ description: >
-+ Remote MAC address.
-+ errors:
-+ - xyz.openbmc_project.Common.Error.InternalFailure
-+ - name: UserID
-+ type: byte
-+ description: >
-+ Session created by given user ID.
-+ errors:
-+ - xyz.openbmc_project.Common.Error.InternalFailure
-+ - name: State
-+ type: byte
-+ default: 0
-+ description: >
-+ Session state.
-+ errors:
-+ - xyz.openbmc_project.Common.Error.InternalFailure
-+
-+# vim: tabstop=8 expandtab shiftwidth=4 softtabstop=4
---
-2.7.4
-
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-Add-interface-suppot-for-provisioning-modes.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-Add-interface-suppot-for-provisioning-modes.patch
deleted file mode 100644
index f6e200cab..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-Add-interface-suppot-for-provisioning-modes.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 94fb1ac5dd4d54ea5a6d49597e1f15c384be7fd6 Mon Sep 17 00:00:00 2001
-From: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
-Date: Mon, 8 Apr 2019 11:48:22 +0530
-Subject: [PATCH] Add interface suppot for provisioning modes
-
-Support for provisioning modes are added in
-RestrictionMode.interface.yaml
-
-Tested:
-1. Verified build, and verified specified modes are available
-and able to set / get the same using busctl command
-
-Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
----
- .../Security/RestrictionMode.interface.yaml | 24 ++++++++++++++++++++++
- 1 file changed, 24 insertions(+)
-
-diff --git a/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml b/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml
-index 8e4fd8d..d328dac 100644
---- a/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml
-+++ b/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml
-@@ -21,3 +21,27 @@ enumerations:
- - name: Blacklist
- description: >
- Prevent, if in the blacklist.
-+ - name: Provisioning
-+ description: >
-+ Indicate that system is in provisioning mode
-+ and all commands are allowed in KCS inteface
-+ in both pre and post BIOS boot.
-+ - name: ProvisionedKCSWhiteList
-+ description: >
-+ Commands in the whitelist will only be executed
-+ through KCS interface after BIOS POST complete.
-+ All KCS commands are supported before POST complete.
-+ - name: ProvisionedKCSDisabled
-+ description: >
-+ Commands through KCS interface are executed only
-+ till BIOS POST complete notification, after
-+ which no KCS commands will be executed(other
-+ than BIOS SMI based ones).
-+ - name: ValidationUnsecure
-+ description: >
-+ To indicate that BMC is in unsecure mode, and many
-+ operations which are not meant for end-user will be
-+ allowed in this mode. Interface which sets this
-+ property has to make sure due diligence is made
-+ as in this mode, many security intrinsic commands
-+ can be executed.
---
-2.7.4
-
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-D-Bus-Intf-Security-modes-property-intf-update.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-D-Bus-Intf-Security-modes-property-intf-update.patch
new file mode 100644
index 000000000..62d5376d6
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0021-D-Bus-Intf-Security-modes-property-intf-update.patch
@@ -0,0 +1,80 @@
+From 9b0630f40c7fb1143901f7d114c376426cc03501 Mon Sep 17 00:00:00 2001
+From: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
+Date: Sat, 15 Jun 2019 01:04:41 +0530
+Subject: [PATCH] [D-Bus Intf] Security modes property & intf update
+
+Defined new values for RestrictionMode property and defined
+SpecialMode interfaces to handle special cases like manufacturing
+and validation mode in OpenBMC.
+
+Note: Please refer Security mode design doc under review for more
+details
+https://gerrit.openbmc-project.xyz/#/c/openbmc/docs/+/21195/
+
+Change-Id: I270e7d23ca2ed260f2d121e3844c2ca79150070e
+Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
+---
+ .../Security/RestrictionMode.interface.yaml | 16 +++++++++++++
+ .../Control/Security/SpecialMode.interface.yaml | 26 ++++++++++++++++++++++
+ 2 files changed, 42 insertions(+)
+ create mode 100644 xyz/openbmc_project/Control/Security/SpecialMode.interface.yaml
+
+diff --git a/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml b/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml
+index 8e4fd8d..afd2279 100644
+--- a/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml
++++ b/xyz/openbmc_project/Control/Security/RestrictionMode.interface.yaml
+@@ -21,3 +21,19 @@ enumerations:
+ - name: Blacklist
+ description: >
+ Prevent, if in the blacklist.
++ - name: Provisioning
++ description: >
++ Indicate that system is in provisioning mode
++ and all commands are allowed in system inteface
++ in both pre and post BIOS boot.
++ - name: ProvisionedHostWhitelist
++ description: >
++ Commands in the whitelist will only be executed
++ through system interface after BIOS POST complete.
++ All KCS commands are supported before POST complete.
++ - name: ProvisionedHostDisabled
++ description: >
++ Commands through system interface are executed only
++ till BIOS POST complete notification, after
++ which no system interface commands will be executed(other
++ than BIOS SMI based ones).
+diff --git a/xyz/openbmc_project/Control/Security/SpecialMode.interface.yaml b/xyz/openbmc_project/Control/Security/SpecialMode.interface.yaml
+new file mode 100644
+index 0000000..6760076
+--- /dev/null
++++ b/xyz/openbmc_project/Control/Security/SpecialMode.interface.yaml
+@@ -0,0 +1,26 @@
++description: >
++ Implement to specify a special mode of operation
++
++properties:
++ - name: SpecialMode
++ type: enum[self.Modes]
++ description: >
++ The special mode.
++
++enumerations:
++ - name: Modes
++ description: >
++ Possible modes available.
++ values:
++ - name: None
++ description: >
++ BMC is under normal working condition.
++ - name: Manufacturing
++ description: >
++ Indicate that BMC is in manufacturing mode
++ and is allowed to perform any manufacturing related
++ activity
++ - name: ValidationUnsecure
++ description: >
++ Indicate that BMC is in validation mode, and can
++ execute any special validation related commands
+--
+2.7.4
+
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0023-Add-host-interrupt-to-the-Host-State.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0023-Add-host-interrupt-to-the-Host-State.patch
deleted file mode 100644
index 650fd3bc9..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0023-Add-host-interrupt-to-the-Host-State.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 9c94439a5a55efbb72bee10e9cfa0827dbedf511 Mon Sep 17 00:00:00 2001
-From: "Jason M. Bills" <jason.m.bills@linux.intel.com>
-Date: Mon, 3 Jun 2019 16:35:46 -0700
-Subject: [PATCH] Add host interrupt to the Host State
-
-This adds host Interrupt as possible Transition value for the
-Host State. This is to support an interrupt signal to the host
-firmware or software.
-
-Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
----
- xyz/openbmc_project/State/Host.interface.yaml | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/xyz/openbmc_project/State/Host.interface.yaml b/xyz/openbmc_project/State/Host.interface.yaml
-index 1ceba13..3d71280 100644
---- a/xyz/openbmc_project/State/Host.interface.yaml
-+++ b/xyz/openbmc_project/State/Host.interface.yaml
-@@ -28,6 +28,9 @@ enumerations:
- description: >
- The desired transition for host firmware
- values:
-+ - name: 'Interrupt'
-+ description: >
-+ Host firmware should be interrupted
- - name: 'Off'
- description: >
- Host firmware should be off
---
-2.7.4
-
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0025-Add-PreInterruptFlag-properity-in-DBUS.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0025-Add-PreInterruptFlag-properity-in-DBUS.patch
new file mode 100644
index 000000000..d7e66abd2
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces/0025-Add-PreInterruptFlag-properity-in-DBUS.patch
@@ -0,0 +1,39 @@
+From b7c487750c05dcc081219ccdd4ef539beef6aa30 Mon Sep 17 00:00:00 2001
+From: Ren Yu <yux.ren@intel.com>
+Date: Mon, 29 Jul 2019 10:51:12 +0800
+Subject: [PATCH] Add PreInterruptFlag properity in DBUS.
+
+PreTimeoutInterruptOccurFlag in DBUS would be set 'true'
+when watchdog pre-timeout interrupt occurred.
+
+Tested:
+Enable command(raw 0x06 0x31) that get message flag
+can set right bit about watchdog,
+need record PreTimeoutInterruptOccurFlag
+at xyz.openbmmc_project.State.Watchdog when watchdog
+pre-timeout interrupt occurred.
+
+Signed-off-by: Ren Yu <yux.ren@intel.com>
+---
+ xyz/openbmc_project/State/Watchdog.interface.yaml | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/xyz/openbmc_project/State/Watchdog.interface.yaml b/xyz/openbmc_project/State/Watchdog.interface.yaml
+index bf4cca0..6579368 100644
+--- a/xyz/openbmc_project/State/Watchdog.interface.yaml
++++ b/xyz/openbmc_project/State/Watchdog.interface.yaml
+@@ -59,6 +59,11 @@ properties:
+ description: >
+ The timer user at the time of expiration.
+ default: 'Reserved'
++ - name: PreTimeoutInterruptOccurFlag
++ type: boolean
++ description: >
++ PreTimeoutInterruptOccurFlag that preTimeoutInterrupt action occurred.
++ default: false
+
+ enumerations:
+ - name: Action
+--
+2.7.4
+
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
index 89b8da753..40b00e70f 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
@@ -1,22 +1,18 @@
SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces.git"
-SRCREV = "1f0e2ce6e1cb78a59a0015b160816b71156b03c6"
+SRCREV = "ddc9e9f9d6ed0282ec6c1421a706b45f3c09ebcc"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://0002-Modify-Dbus-for-IPv6.patch \
- file://0003-Chassis-Power-Control-are-implemented.patch \
file://0005-Add-DBUS-interface-of-CPU-and-Memory-s-properties.patch \
file://0007-ipmi-set-BIOS-id.patch \
- file://0009-Add-host-restart-cause-property.patch \
file://0010-Increase-the-default-watchdog-timeout-value.patch \
file://0012-Add-RestoreDelay-interface-for-power-restore-delay.patch \
file://0013-Add-ErrConfig.yaml-interface-for-processor-error-config.patch \
- file://0014-Add-multiple-state-signal-for-host-start-and-stop.patch \
file://0016-Add-DBUS-interface-of-SMBIOS-MDR-V2.patch \
file://0018-Define-post-code-interfaces-for-post-code-manager.patch \
- file://0019-Creating-the-Session-interface-for-Host-and-LAN.patch \
- file://0021-Add-interface-suppot-for-provisioning-modes.patch \
+ file://0021-D-Bus-Intf-Security-modes-property-intf-update.patch \
file://0022-Add-chassis-power-cycle-and-reset-to-Chassis-State.patch \
- file://0023-Add-host-interrupt-to-the-Host-State.patch \
file://0024-Add-the-pre-timeout-interrupt-defined-in-IPMI-spec.patch \
+ file://0025-Add-PreInterruptFlag-properity-in-DBUS.patch \
"