summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/fru/default-fru.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-11-04 00:40:53 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-11-04 01:28:00 +0300
commit61f1ca1b31a9a1108e9e7f71e47fdc19beb0490b (patch)
tree5aadf91080299b1583caed86a31da368dfcda2da /meta-openbmc-mods/meta-common/recipes-phosphor/fru/default-fru.bb
parent901ced0812b458fdc599fe40b0a4233d422d6df9 (diff)
downloadopenbmc-61f1ca1b31a9a1108e9e7f71e47fdc19beb0490b.tar.xz
Update to internal 0.77
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/fru/default-fru.bb')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/fru/default-fru.bb22
1 files changed, 8 insertions, 14 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/fru/default-fru.bb b/meta-openbmc-mods/meta-common/recipes-phosphor/fru/default-fru.bb
index b113547da..a8dd35487 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/fru/default-fru.bb
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/fru/default-fru.bb
@@ -1,18 +1,15 @@
SUMMARY = "Default Fru"
DESCRIPTION = "Builds a default FRU file at runtime based on board ID"
-inherit systemd
+inherit obmc-phosphor-systemd
inherit cmake
-SYSTEMD_SERVICE:${PN} = "SetBaseboardFru.service"
-
-S = "${WORKDIR}"
-SRC_URI = "file://checkFru.sh \
- file://decodeBoardID.sh \
- file://SetBaseboardFru.service \
- file://mkfru.cpp \
- file://CMakeLists.txt \
+SRC_URI = "file://checkFru.sh;subdir=${BP} \
+ file://decodeBoardID.sh;subdir=${BP} \
+ file://mkfru.cpp;subdir=${BP} \
+ file://CMakeLists.txt;subdir=${BP} \
"
+SYSTEMD_SERVICE:${PN} = "SetBaseboardFru.service"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "\
@@ -24,9 +21,6 @@ RDEPENDS:${PN} = "bash"
do_install:append() {
install -d ${D}${bindir}
- install -m 0755 ${S}/checkFru.sh ${D}/${bindir}/checkFru.sh
- install -m 0755 ${S}/decodeBoardID.sh ${D}/${bindir}/decodeBoardID.sh
-
- install -d ${D}${base_libdir}/systemd/system
- install -m 0644 ${S}/SetBaseboardFru.service ${D}${base_libdir}/systemd/system
+ install -m 0755 ${S}/checkFru.sh ${D}${bindir}/checkFru.sh
+ install -m 0755 ${S}/decodeBoardID.sh ${D}${bindir}/decodeBoardID.sh
}