summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-05-03 20:49:59 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-05-03 21:06:56 +0300
commite370fd750e2821620ec427f26f8efab0069824ff (patch)
tree9acce8ae4bf8b88a4e71b1bbcd2e69cd3c166ea5 /meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend
parentab16ab3d0de4dc9d130ae3db366c38888f1ada5a (diff)
downloadopenbmc-e370fd750e2821620ec427f26f8efab0069824ff.tar.xz
Update to internal 0.47
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend18
1 files changed, 15 insertions, 3 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend
index db8a7a90f..d42618b78 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/interfaces/bmcweb_%.bbappend
@@ -1,5 +1,5 @@
SRC_URI = "git://github.com/openbmc/bmcweb.git"
-SRCREV = "2b3da45876aac57a36d3093379a992d699e7e396"
+SRCREV = "8e6c099ac8d4b4b3163a26b58fa0f9abb987979a"
DEPENDS += "boost-url"
RDEPENDS_${PN} += "phosphor-nslcd-authority-cert-config"
@@ -15,7 +15,6 @@ GROUPADD_PARAM_${PN} = "web; redfish "
SRC_URI += "file://0001-Firmware-update-configuration-changes.patch \
file://0002-Use-chip-id-based-UUID-for-Service-Root.patch \
file://0004-bmcweb-handle-device-or-resource-busy-exception.patch \
- file://0005-EventService-https-client-support.patch \
file://0006-Define-Redfish-interface-Registries-Bios.patch \
file://0007-BIOS-config-Add-support-for-PATCH-operation.patch \
file://0008-Add-support-to-ResetBios-action.patch \
@@ -28,8 +27,18 @@ SRC_URI += "file://0001-Firmware-update-configuration-changes.patch \
SRC_URI += "file://0037-Add-state-sensor-messages-to-the-registry.patch \
"
+# EventService: Temporary pulled to downstream. See eventservice\README for details
+SRC_URI += "file://eventservice/0001-EventService-Fix-retry-handling-for-http-client.patch \
+ file://eventservice/0002-EventService-https-client-support.patch \
+ file://eventservice/0003-Move-EventService-init-to-later-stage.patch \
+ file://eventservice/0004-Add-Server-Sent-Events-support.patch \
+ file://eventservice/0005-Add-SSE-style-subscription-support-to-eventservice.patch \
+ file://eventservice/0006-Add-EventService-SSE-filter-support.patch \
+"
+
# Temporary downstream mirror of upstream patches, see telemetry\README for details
-SRC_URI += "file://telemetry/0002-Add-POST-and-DELETE-in-MetricReportDefinitions.patch \
+SRC_URI += "file://telemetry/0001-Sync_ReadingUnit_with_Redfish_Sensor_Schema.patch \
+ file://telemetry/0002-Add-POST-and-DELETE-in-MetricReportDefinitions.patch \
file://telemetry/0003-Add-support-for-MetricDefinition-scheme.patch \
file://telemetry/0004-Sync-Telmetry-service-with-EventService.patch \
"
@@ -39,6 +48,9 @@ SRC_URI += "file://0001-Add-ConnectedVia-property-to-virtual-media-item-temp.pat
file://0003-Set-Inserted-redfish-property-for-not-inserted-resou.patch \
"
+SRC_URI += "file://0038-Revert-Disable-nbd-proxy-from-the-build.patch \
+"
+
# Temporary fix: Move it to service file
do_install_append() {
install -d ${D}/var/lib/bmcweb