summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-phosphor/settings
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-07-31 20:43:37 +0300
committerEd Tanous <ed.tanous@intel.com>2019-08-01 18:19:38 +0300
commitd0f63ef62c76c932a2003eaa42c0b250065ae06f (patch)
tree4c0e3cb32dc80f80460bdbf82ff6d401d4ff194f /meta-openbmc-mods/meta-common/recipes-phosphor/settings
parentb4f66bacb1b8e661d794fa7a189e2f66f5092e2e (diff)
downloadopenbmc-d0f63ef62c76c932a2003eaa42c0b250065ae06f.tar.xz
Update to internal 7-31-19
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-phosphor/settings')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-defaults-native.bbappend4
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-defaults-native/defaults.yaml209
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-manager/0001-settings-initialize-data-file-with-default-setting.patch37
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend9
-rw-r--r--meta-openbmc-mods/meta-common/recipes-phosphor/settings/settings_git.bb4
5 files changed, 2 insertions, 261 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-defaults-native.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-defaults-native.bbappend
deleted file mode 100644
index 436623234..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-defaults-native.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://defaults.yaml \
- "
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-defaults-native/defaults.yaml b/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-defaults-native/defaults.yaml
deleted file mode 100644
index 05d3df07e..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-defaults-native/defaults.yaml
+++ /dev/null
@@ -1,209 +0,0 @@
-/xyz/openbmc_project/control/minimum_ship_level_required:
- - Interface: xyz.openbmc_project.Control.MinimumShipLevel
- Properties:
- MinimumShipLevelRequired:
- Default: 'true'
-
-/xyz/openbmc_project/control/host0/auto_reboot:
- - Interface: xyz.openbmc_project.Control.Boot.RebootPolicy
- Properties:
- AutoReboot:
- Default: 'false'
-
-/xyz/openbmc_project/control/host0/boot:
- - Interface: xyz.openbmc_project.Control.Boot.Source
- Properties:
- BootSource:
- Default: Source::Sources::Default
- - Interface: xyz.openbmc_project.Control.Boot.Mode
- Properties:
- BootMode:
- Default: Mode::Modes::Regular
-
-/xyz/openbmc_project/control/host0/boot/one_time:
- - Interface: xyz.openbmc_project.Control.Boot.Source
- Properties:
- BootSource:
- Default: Source::Sources::Default
- - Interface: xyz.openbmc_project.Control.Boot.Mode
- Properties:
- BootMode:
- Default: Mode::Modes::Regular
- - Interface: xyz.openbmc_project.Object.Enable
- Properties:
- Enabled:
- Default: 'true'
-
-/xyz/openbmc_project/control/host0/power_cap:
- - Interface: xyz.openbmc_project.Control.Power.Cap
- Properties:
- PowerCap:
- Default: 0
- Validation:
- Type: "range"
- Validator: "0..1000"
- Unit: "Watts"
- PowerCapEnable:
- Default: 'false'
-
-/xyz/openbmc_project/control/host0/power_restore_policy:
- - Interface: xyz.openbmc_project.Control.Power.RestorePolicy
- Properties:
- PowerRestorePolicy:
- Default: RestorePolicy::Policy::AlwaysOff
-
-/xyz/openbmc_project/control/power_restore_delay:
- - Interface: xyz.openbmc_project.Control.Power.RestoreDelay
- Properties:
- PowerRestoreDelay:
- Default: 0
-
-/xyz/openbmc_project/control/host0/acpi_power_state:
- - Interface: xyz.openbmc_project.Control.Power.ACPIPowerState
- Properties:
- SysACPIStatus:
- Default: ACPIPowerState::ACPI::Unknown
- DevACPIStatus:
- Default: ACPIPowerState::ACPI::Unknown
-
-/xyz/openbmc_project/time/owner:
- - Interface: xyz.openbmc_project.Time.Owner
- Properties:
- TimeOwner:
- Default: Owner::Owners::BMC
-
-/xyz/openbmc_project/time/sync_method:
- - Interface: xyz.openbmc_project.Time.Synchronization
- Properties:
- TimeSyncMethod:
- Default: Synchronization::Method::NTP
-
-/xyz/openbmc_project/network/host0/intf:
- - Interface: xyz.openbmc_project.Network.MACAddress
- Properties:
- MACAddress:
- Default: '"00:00:00:00:00:00"'
- Validation:
- Type: "regex"
- Validator: '^([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2})$'
-
-#needs to implement address validation TODO openbmc/issues/2046
-/xyz/openbmc_project/network/host0/intf/addr:
- - Interface: xyz.openbmc_project.Network.IP
- Properties:
- Address:
- Default: '"0.0.0.0"'
- PrefixLength:
- Default: 0
- Validation:
- Type: "range"
- Validator: 0..128
- Unit: "bits"
- Origin:
- Default: IP::AddressOrigin::Static
- Gateway:
- Default: '"0.0.0.0"'
- Type:
- Default: IP::Protocol::IPv4
-
-/xyz/openbmc_project/control/host0/restriction_mode:
- - Interface: xyz.openbmc_project.Control.Security.RestrictionMode
- Properties:
- RestrictionMode:
- Default: RestrictionMode::Modes::Provisioning
-
-/xyz/openbmc_project/control/host0/TPMEnable:
- - Interface: xyz.openbmc_project.Control.TPM.Policy
- Properties:
- TPMEnable:
- Default: 'false'
-
-/xyz/openbmc_project/control/power_supply_redundancy:
- - Interface: xyz.openbmc_project.Control.PowerSupplyRedundancy
- Properties:
- PowerSupplyRedundancyEnabled:
- Default: 'true'
-
-/xyz/openbmc_project/control/host0/turbo_allowed:
- - Interface: xyz.openbmc_project.Control.Host.TurboAllowed
- Properties:
- TurboAllowed:
- Default: 'true'
-
-/xyz/openbmc_project/control/host0/systemGUID:
- - Interface: xyz.openbmc_project.Common.UUID
- Properties:
- UUID:
- Default: '"00000000-0000-0000-0000-000000000000"'
-
-/xyz/openbmc_project/bios:
- - Interface: xyz.openbmc_project.Inventory.Item.Bios
- Properties:
- BiosId:
- Default: '"NA"'
-
-/xyz/openbmc_project/control/processor_error_config:
- - Interface: xyz.openbmc_project.Control.Processor.ErrConfig
- Properties:
- ResetCfg:
- Default: 0
- ResetErrorOccurrenceCounts:
- Default: 0
-
-/com/intel/control/ocotshutdown_policy_config:
- - Interface: com.intel.Control.OCOTShutdownPolicy
- Properties:
- OCOTPolicy:
- Default: OCOTShutdownPolicy::Policy::NoShutdownOnOCOT
-
-/xyz/openbmc_project/control/chassis_capabilities_config:
- - Interface: xyz.openbmc_project.Control.ChassisCapabilities
- Properties:
- CapabilitiesFlags:
- Default: 0
- FRUDeviceAddress:
- Default: 0x20
- SDRDeviceAddress:
- Default: 0x20
- SELDeviceAddress:
- Default: 0x20
- SMDeviceAddress:
- Default: 0x20
- BridgeDeviceAddress:
- Default: 0x20
-
-/xyz/openbmc_project/control/thermal_mode:
- - Interface: xyz.openbmc_project.Control.ThermalMode
- Properties:
- Current:
- Default: '"Performance"'
- Supported:
- Default: '{"Acoustic", "Performance"}'
-
-/xyz/openbmc_project/control/cfm_limit:
- - Interface: xyz.openbmc_project.Control.CFMLimit
- Properties:
- Limit:
- Default: 0
-
-/xyz/openbmc_project/ipmi/sol:
- - Interface: xyz.openbmc_project.Ipmi.SOL
- Properties:
- Progress:
- Default: 0
- Enable:
- Default: 'true'
- ForceEncryption:
- Default: 'true'
- ForceAuthentication:
- Default: 'true'
- Privilege:
- Default: 4
- AccumulateIntervalMS:
- Default: 12
- Threshold:
- Default: 96
- RetryCount:
- Default: 6
- RetryIntervalMS:
- Default: 20
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-manager/0001-settings-initialize-data-file-with-default-setting.patch b/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-manager/0001-settings-initialize-data-file-with-default-setting.patch
deleted file mode 100644
index fcf2415d6..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-manager/0001-settings-initialize-data-file-with-default-setting.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 9e99aa4f72f4420e03ec2e4a29816eae43c5e748 Mon Sep 17 00:00:00 2001
-From: "Jia, Chunhui" <chunhui.jia@intel.com>
-Date: Tue, 29 May 2018 16:16:06 +0800
-Subject: [PATCH] [settings] initialize data file with default setting
-
-Current code trys to load settings from file at startup. When file
-does not exist, it will just use default setting. However, it will
-still load default on next reboot because no one create files.
-
-This change creates file as well when daemon loads default so next
-time daemon could load/save from file.
-
-Signed-off-by: Jia, Chunhui <chunhui.jia@intel.com>
----
- settings_manager.mako.hpp | 3 +++
- 1 file changed, 3 insertions(+)
- mode change 100644 => 100755 settings_manager.mako.hpp
-
-diff --git a/settings_manager.mako.hpp b/settings_manager.mako.hpp
-old mode 100644
-new mode 100755
-index 09a5a1f..cd592a0
---- a/settings_manager.mako.hpp
-+++ b/settings_manager.mako.hpp
-@@ -323,6 +323,9 @@ class Manager
- else
- {
- initSetting${index}();
-+ std::ofstream ostr(path.c_str(), std::ios::out);
-+ cereal::JSONOutputArchive oarchive(ostr);
-+ oarchive(*std::get<${index}>(settings)); //create file with default
- }
- }
- catch (cereal::Exception& e)
---
-2.16.2
-
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend b/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
deleted file mode 100644
index f5c924b31..000000000
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://0001-settings-initialize-data-file-with-default-setting.patch \
- "
-
-DEPENDS += "intel-dbus-interfaces intel-dbus-interfaces-native"
-RDEPENDS_${PN} += "intel-dbus-interfaces"
-
-EXTRA_OEMAKE += "LDFLAGS='${LDFLAGS} -lintel_dbus'"
diff --git a/meta-openbmc-mods/meta-common/recipes-phosphor/settings/settings_git.bb b/meta-openbmc-mods/meta-common/recipes-phosphor/settings/settings_git.bb
index aadb48fbf..50f644f37 100644
--- a/meta-openbmc-mods/meta-common/recipes-phosphor/settings/settings_git.bb
+++ b/meta-openbmc-mods/meta-common/recipes-phosphor/settings/settings_git.bb
@@ -1,7 +1,7 @@
SUMMARY = "Settings"
-SRC_URI = "git://git-amr-2.devtools.intel.com:29418/openbmc-provingground.git;protocol=ssh"
-SRCREV = "4373d99e1edcbb4c7233abde3a5e53690693007b"
+SRC_URI = "git://git@github.com/Intel-BMC/provingground.git;protocol=ssh"
+SRCREV = "4611d8dcba0c0dc92156bbafdb50607aaff122ab"
PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"