summaryrefslogtreecommitdiff
path: root/meta-openbmc-mods/meta-common/recipes-utilities
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 22:04:51 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 23:07:19 +0300
commitffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (patch)
tree8019999b0ca042482e5193d6cabc06220c71d776 /meta-openbmc-mods/meta-common/recipes-utilities
parentd73e39703a0260c8911cb439b579e1c2bada4b20 (diff)
downloadopenbmc-ffe6d597d9e3d4407cf8062b5d6505a80ce08f41.tar.xz
Update to internal 0.75
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-openbmc-mods/meta-common/recipes-utilities')
-rw-r--r--meta-openbmc-mods/meta-common/recipes-utilities/dimmsensor/dimmsensor.bb2
-rw-r--r--meta-openbmc-mods/meta-common/recipes-utilities/i3c-tools/i3c-tools.bb2
-rw-r--r--meta-openbmc-mods/meta-common/recipes-utilities/lpc-cmds/files/lpc_cmds.c27
-rw-r--r--meta-openbmc-mods/meta-common/recipes-utilities/lpc-cmds/files/lpc_drv.h1
-rw-r--r--meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit/0003-Add-support-for-tls13-ciphers.patch39
-rw-r--r--meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit/0004-Handle-empty-CAInfo-in-curl-plugin-correctly.patch35
-rw-r--r--meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit_git.bb4
-rw-r--r--meta-openbmc-mods/meta-common/recipes-utilities/peci-hwmon-test/peci-hwmon-test.bb2
8 files changed, 108 insertions, 4 deletions
diff --git a/meta-openbmc-mods/meta-common/recipes-utilities/dimmsensor/dimmsensor.bb b/meta-openbmc-mods/meta-common/recipes-utilities/dimmsensor/dimmsensor.bb
index 78240c0f4..0a6cbee25 100644
--- a/meta-openbmc-mods/meta-common/recipes-utilities/dimmsensor/dimmsensor.bb
+++ b/meta-openbmc-mods/meta-common/recipes-utilities/dimmsensor/dimmsensor.bb
@@ -13,5 +13,5 @@ S = "${WORKDIR}"
inherit cmake
# linux-libc-headers guides this way to include custom uapi headers
-CXXFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
+CXXFLAGS:append = " -I ${STAGING_KERNEL_DIR}/include/uapi"
do_configure[depends] += "virtual/kernel:do_shared_workdir"
diff --git a/meta-openbmc-mods/meta-common/recipes-utilities/i3c-tools/i3c-tools.bb b/meta-openbmc-mods/meta-common/recipes-utilities/i3c-tools/i3c-tools.bb
index 89dbf1d68..89246bbdf 100644
--- a/meta-openbmc-mods/meta-common/recipes-utilities/i3c-tools/i3c-tools.bb
+++ b/meta-openbmc-mods/meta-common/recipes-utilities/i3c-tools/i3c-tools.bb
@@ -19,7 +19,7 @@ SRC_URI += "\
file://CMakeLists.txt \
"
-do_configure_prepend() {
+do_configure:prepend() {
cp -f ${WORKDIR}/CMakeLists.txt ${S}
}
diff --git a/meta-openbmc-mods/meta-common/recipes-utilities/lpc-cmds/files/lpc_cmds.c b/meta-openbmc-mods/meta-common/recipes-utilities/lpc-cmds/files/lpc_cmds.c
index bc215f60b..ff9498696 100644
--- a/meta-openbmc-mods/meta-common/recipes-utilities/lpc-cmds/files/lpc_cmds.c
+++ b/meta-openbmc-mods/meta-common/recipes-utilities/lpc-cmds/files/lpc_cmds.c
@@ -342,6 +342,27 @@ static void SIOSetBMCSCIEvent(unsigned short set)
close(fd);
}
+static void SIOSetBMCSMIEvent(unsigned short set)
+{
+ int fd;
+ struct sio_ioctl_data sio_data;
+
+ fd = open(SIO_DEVICE_NAME, O_RDWR | O_CLOEXEC);
+ if (fd < 0) {
+ printf("Error open %s\n", SIO_DEVICE_NAME);
+ exit(1);
+ }
+
+ sio_data.sio_cmd = SIO_SET_BMC_SMI_EVENT;
+ sio_data.param = set;
+
+ if (ioctl(fd, SIO_IOC_COMMAND, &sio_data) == 0)
+ printf("BMC SMI event is %s\n",
+ sio_data.data ? "set" : "cleared");
+
+ close(fd);
+}
+
/*********************************************************************************/
#if SUPPORT_MAILBOX
@@ -413,6 +434,8 @@ static void usage(void)
"\tlpc_cmds sio get_pfail_status\n"
"\tlpc_cmds sio set_bmc_sci_event\n"
"\tlpc_cmds sio clear_bmc_sci_event\n"
+ "\tlpc_cmds sio set_bmc_smi_event\n"
+ "\tlpc_cmds sio clear_bmc_smi_event\n"
"\n"
#if SUPPORT_KCS_ADDR_CMD
"\tlpc_cmds kcs [1 ~ 4] (getaddr / setaddr / quiet)\n"
@@ -472,6 +495,10 @@ int main(int argc, char** argv)
SIOSetBMCSCIEvent(1);
else if (strcmp(argv[2], "clear_bmc_sci_event") == 0)
SIOSetBMCSCIEvent(0);
+ else if (strcmp(argv[2], "set_bmc_smi_event") == 0)
+ SIOSetBMCSMIEvent(1);
+ else if (strcmp(argv[2], "clear_bmc_smi_event") == 0)
+ SIOSetBMCSMIEvent(0);
} else if (strcmp(cmd, "kcs") == 0) {
int ifc;
diff --git a/meta-openbmc-mods/meta-common/recipes-utilities/lpc-cmds/files/lpc_drv.h b/meta-openbmc-mods/meta-common/recipes-utilities/lpc-cmds/files/lpc_drv.h
index 793e8b49c..354210c8b 100644
--- a/meta-openbmc-mods/meta-common/recipes-utilities/lpc-cmds/files/lpc_drv.h
+++ b/meta-openbmc-mods/meta-common/recipes-utilities/lpc-cmds/files/lpc_drv.h
@@ -56,6 +56,7 @@ enum SIO_CMD {
SIO_GET_PWRBTN_OVERRIDE,
SIO_GET_PFAIL_STATUS, /* Start from AC Loss */
SIO_SET_BMC_SCI_EVENT,
+ SIO_SET_BMC_SMI_EVENT,
SIO_MAX_CMD
};
diff --git a/meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit/0003-Add-support-for-tls13-ciphers.patch b/meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit/0003-Add-support-for-tls13-ciphers.patch
new file mode 100644
index 000000000..398cef63c
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit/0003-Add-support-for-tls13-ciphers.patch
@@ -0,0 +1,39 @@
+diff --git a/plugins/curl/curl.c b/plugins/curl/curl.c
+index fad84140..d3dc3bde 100644
+--- a/plugins/curl/curl.c
++++ b/plugins/curl/curl.c
+@@ -85,6 +85,7 @@ const char *proxy_user = NULL;
+ bool sslverify = true;
+ const char *ssl_version = NULL;
+ const char *ssl_cipher_list = NULL;
++const char *tls13_ciphers = NULL;
+ bool tcp_keepalive = false;
+ bool tcp_nodelay = true;
+ uint32_t timeout = 0;
+@@ -309,6 +310,9 @@ curl_config (const char *key, const char *value)
+ else if (strcmp (key, "ssl-cipher-list") == 0)
+ ssl_cipher_list = value;
+
++ else if (strcmp (key, "tls13-ciphers") == 0)
++ tls13_ciphers = value;
++
+ else if (strcmp (key, "tcp-keepalive") == 0) {
+ r = nbdkit_parse_bool (value);
+ if (r == -1)
+@@ -413,6 +417,7 @@ curl_config_complete (void)
+ "sslverify=false Do not verify SSL certificate of remote host.\n" \
+ "ssl-version=<VERSION> Specify preferred TLS/SSL version.\n " \
+ "ssl-cipher-list=C1:C2:.. Specify TLS/SSL cipher suites to be used.\n" \
++ "tls13-ciphers=C1:C2:.. Specify TLS 1.3 cipher suites to be used.\n" \
+ "tcp-keepalive=true Enable TCP keepalives.\n" \
+ "tcp-nodelay=false Disable Nagle’s algorithm.\n" \
+ "unix-socket-path=<PATH> Open Unix domain socket instead of TCP/IP.\n" \
+@@ -550,6 +555,8 @@ curl_open (int readonly)
+ }
+ if (ssl_cipher_list)
+ curl_easy_setopt (h->c, CURLOPT_SSL_CIPHER_LIST, ssl_cipher_list);
++ if (tls13_ciphers)
++ curl_easy_setopt (h->c, CURLOPT_TLS13_CIPHERS, tls13_ciphers);
+ if (tcp_keepalive)
+ curl_easy_setopt (h->c, CURLOPT_TCP_KEEPALIVE, 1L);
+ if (!tcp_nodelay)
diff --git a/meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit/0004-Handle-empty-CAInfo-in-curl-plugin-correctly.patch b/meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit/0004-Handle-empty-CAInfo-in-curl-plugin-correctly.patch
new file mode 100644
index 000000000..867f2e166
--- /dev/null
+++ b/meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit/0004-Handle-empty-CAInfo-in-curl-plugin-correctly.patch
@@ -0,0 +1,35 @@
+From f86b22a450589cdcac6bb3afa1818dfa6d2eefe4 Mon Sep 17 00:00:00 2001
+From: Wiktor Golgowski <wiktor.golgowski@intel.com>
+Date: Fri, 27 Aug 2021 17:39:59 +0200
+Subject: [PATCH] Handle empty CAInfo in curl plugin correctly.
+
+Recent change in libcurl causes CAINFO option to be set when
+the library is compiled. If we do not want to use the default
+certificate store, we set the option to an empty string.
+This change recognizes zero-length CAInfo and clears the libcurl
+option.
+
+Signed-off-by: Wiktor Golgowski <wiktor.golgowski@intel.com>
+---
+ plugins/curl/curl.c | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/plugins/curl/curl.c b/plugins/curl/curl.c
+index fad84140..176f9a1f 100644
+--- a/plugins/curl/curl.c
++++ b/plugins/curl/curl.c
+@@ -498,8 +498,12 @@ curl_open (int readonly)
+ curl_easy_setopt (h->c, CURLOPT_FAILONERROR, 1L);
+
+ /* Options. */
+- if (cainfo)
+- curl_easy_setopt (h->c, CURLOPT_CAINFO, cainfo);
++ if (cainfo) {
++ if (strlen (cainfo) == 0)
++ curl_easy_setopt (h->c, CURLOPT_CAINFO, NULL);
++ else
++ curl_easy_setopt (h->c, CURLOPT_CAINFO, cainfo);
++ }
+ if (capath)
+ curl_easy_setopt (h->c, CURLOPT_CAPATH, capath);
+ if (cookie)
diff --git a/meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit_git.bb b/meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit_git.bb
index 89072b090..f7d690ff8 100644
--- a/meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit_git.bb
+++ b/meta-openbmc-mods/meta-common/recipes-utilities/nbdkit/nbdkit_git.bb
@@ -12,6 +12,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f9dcc2d8acdde215fa4bd6ac12bb14f0"
SRC_URI = "git://github.com/libguestfs/nbdkit.git;protocol=https"
SRC_URI += "file://0001-Force-nbdkit-to-send-PATCH-as-upload-method.patch"
SRC_URI += "file://0002-Add-support-for-ssl-config.patch"
+SRC_URI += "file://0003-Add-support-for-tls13-ciphers.patch"
+SRC_URI += "file://0004-Handle-empty-CAInfo-in-curl-plugin-correctly.patch"
PV = "1.25.5+git${SRCPV}"
SRCREV = "c828c6d48ff6b69454cad98054a1920d03c4b4c7"
@@ -29,7 +31,7 @@ EXTRA_OECONF = "--disable-python --disable-perl --disable-ocaml \
--disable-lua --disable-vddk --without-libvirt \
--without-libguestfs"
-do_install_append() {
+do_install:append() {
rm -f ${D}/usr/share/bash-completion/completions/nbdkit
rmdir ${D}/usr/share/bash-completion/completions
rmdir ${D}/usr/share/bash-completion
diff --git a/meta-openbmc-mods/meta-common/recipes-utilities/peci-hwmon-test/peci-hwmon-test.bb b/meta-openbmc-mods/meta-common/recipes-utilities/peci-hwmon-test/peci-hwmon-test.bb
index b3b4096a6..e8506d3e0 100644
--- a/meta-openbmc-mods/meta-common/recipes-utilities/peci-hwmon-test/peci-hwmon-test.bb
+++ b/meta-openbmc-mods/meta-common/recipes-utilities/peci-hwmon-test/peci-hwmon-test.bb
@@ -6,7 +6,7 @@ SRC_URI = "\
"
LICENSE = "CLOSED"
-RDEPENDS_${PN} += "python"
+RDEPENDS:${PN} += "python"
S = "${WORKDIR}"