summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-openembedded/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb')
-rw-r--r--meta-openembedded/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openembedded/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb b/meta-openembedded/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
new file mode 100644
index 000000000..2fa5ec1fb
--- /dev/null
+++ b/meta-openembedded/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
@@ -0,0 +1,25 @@
+SUMMARY = "This is a filesystem client based on the HTTP using FUSE"
+HOMEPAGE = "http://httpfs.sourceforge.net"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=83f224c5182f148ec92e0b9f84b3c6c7"
+
+inherit pkgconfig
+
+DEPENDS += "fuse"
+RDEPENDS_${PN} += "fuse"
+
+SRC_URI += "https://astuteinternet.dl.sourceforge.net/project/httpfs/httpfs2/httpfs2-${PV}.tar.gz"
+SRC_URI[sha256sum] = "01cb4bb38deb344f540da6f1464dc7edbdeb51213ad810b8c9c282c1e17e0fc1"
+
+S = "${WORKDIR}/httpfs2-${PV}"
+
+do_compile() {
+ cd ${S}
+ oe_runmake httpfs2
+}
+
+do_install() {
+ cd ${S}
+ install -d ${D}${bindir}
+ install -m 0755 httpfs2 ${D}${bindir}
+}