summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-gnome/recipes-gnome/gjs/gjs_1.58.7.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-05-05 16:53:09 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-05 16:53:37 +0300
commite231d58c35aabcb38dcd6470d232a738291d90fe (patch)
treea3b91de30b49acb14882df2223e2edc255ab95aa /meta-openembedded/meta-gnome/recipes-gnome/gjs/gjs_1.58.7.bb
parent82c905dc58a36aeae40b1b273a12f63fb1973cf4 (diff)
downloadopenbmc-e231d58c35aabcb38dcd6470d232a738291d90fe.tar.xz
meta-openembedded: subtree update:17fd382f34..679bb49126
Andreas Müller (9): gparted: upgrade 0.33.0 -> 1.1.0 gjs: 1.58.6 -> 1.58.7 nautilus: upgrade 3.34.2 -> 3.34.3 xfce4-whiskermenu-plugin: upgrade 2.4.3 -> 2.4.4 xfce4-panel: upgrade 4.14.3 -> 4.14.4 poppler: upgrade 0.86.1 -> 0.88.0 mutter: upgrade 3.34.5 -> 3.34.6 openvpn: upgrade 2.4.8 -> 2.4.9 file-roller: upgrade 3.32.4 -> 3.32.5 Honggyu Kim (1): uftrace: update commit hash to more robust version Khem Raj (6): luajit: Disable on rv32 abseil-cpp: Fix build on riscv32 rsyslog: Enable atomic builtins on rv32 python3-grpcio: Fix build with riscv32 waf: Add cross answers for riscv32 libnma: Fix build on riscv32 Mingli Yu (1): nss: enable uint128 support on mips64 Peter Kjellerstedt (2): samba: Remove the dependency on libbsd paho-mqtt-c: Update to the real 1.3.2, and correct the license Slater, Joseph (1): syslog-ng: change shebang to python3 Trevor Gamblin (2): python3-atomicwrites: add python3-misc to RDEPENDS python3-pysocks: add python3-logging to RDEPENDS zhengruoqin (4): python3-pytoml: Modify ptest output format python3-pytz: Modify ptest output format python3-scrypt: Modify ptest output format python3-serpent: Modify ptest output format Change-Id: I7f985b3e43196dfe5064a954a12411ab6debdb68 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openembedded/meta-gnome/recipes-gnome/gjs/gjs_1.58.7.bb')
-rw-r--r--meta-openembedded/meta-gnome/recipes-gnome/gjs/gjs_1.58.7.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/gjs/gjs_1.58.7.bb b/meta-openembedded/meta-gnome/recipes-gnome/gjs/gjs_1.58.7.bb
new file mode 100644
index 000000000..58342b6c2
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/gjs/gjs_1.58.7.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Javascript bindings for GNOME"
+LICENSE = "MIT & LGPLv2+"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=beb29cf17fabe736f0639b09ee6e76fa \
+ file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7 \
+"
+
+GNOMEBASEBUILDCLASS = "autotools"
+
+DEPENDS = "mozjs gtk+3"
+
+inherit gnomebase gsettings gobject-introspection vala gettext features_check upstream-version-is-even
+
+SRC_URI[archive.md5sum] = "c8c530d4593133f496ae69098273a675"
+SRC_URI[archive.sha256sum] = "2014509019ea4e7a8ab8e0dd0c472bbcf0ad3067928af88c29f5e2879c58c7a9"
+SRC_URI += "file://0001-Disable-tests-on-host.patch"
+
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
+
+EXTRA_OECONF = " \
+ --without-dbus-tests \
+ --disable-installed-tests \
+"
+
+do_configure_prepend() {
+ # make configure find gobject-introspection test code. Although we set
+ # --disable-installed-tests gjs builds them
+ sed -i 's|:$GI_DATADIR|:${STAGING_DIR_NATIVE}$GI_DATADIR|g' ${S}/configure.ac
+}
+
+FILES_${PN} += "${datadir}/gjs-1.0/lsan"
+
+PACKAGES =+ "${PN}-valgrind"
+FILES_${PN}-valgrind = "${datadir}/gjs-1.0/valgrind"
+RSEPENDS_${PN}-valgrind += "valgrind"