summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-gnome/recipes-gnome/gnome-terminal
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-20 13:15:02 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-20 13:15:14 +0300
commit23eaf03b3fff4acf8a79d082a85024bda6690436 (patch)
tree01b23dee8d55aea42b0fd9000c5ea0d32f5bd155 /meta-openembedded/meta-gnome/recipes-gnome/gnome-terminal
parentfb62a68f16d3fa64b242bd8c65abf64ef8088889 (diff)
downloadopenbmc-23eaf03b3fff4acf8a79d082a85024bda6690436.tar.xz
meta-openembedded: subtree update:55de2d06ad..53d431639a
Adrian Bunk (1): ltrace: Remove RDEPENDS on elfutils Andreas Müller (22): gedit: upgrade 2.30.4 -> 3.34.0 gtksourceview2: remove evolution-data-server: give up fine grained -dev/-dbg packages evolution-data-server: upgrade 3.26.6 -> 3.34.1 and rework gnome-font-viewer: initial add 3.34.0 evince: upgrade 3.28.2 -> 3.34.1 file-roller: inital add 3.32.2 gexiv2: initial add 0.12.0 gnome-autoar: inital add 0.2.3 tracker: initial add 2.3.1 nautilus: upgrade 3.18.5 -> 3.34.1 geocode-glib: initial add 3.26.1 libgweather: initial add 3.34.0 libwacom: initial add 0.33 gnome-settings-daemon: initial add 3.34.1 fluidsynth: upgrade 2.0.7 -> 2.0.9 gnome-terminal: re-add 3.34.2 gnome-terminal: Fix build for musl gmime: cleanup recipe gmime: move to meta-oe/recipes-gnome gmime: upgrade 3.2.4 -> 3.2.5 evolution-data-server: add upstream-version-is-even & gsettings to inherit Bartosz Golaszewski (1): libgpiod: put gpio utils into an actual separate package Gaylord Charles (1): nginx: fix install paths Khem Raj (11): evince: Fix build with clang poppler: Extend the c/c++ flags fix to cover clang pidgin-sipe: Fix another case of struct incompatiblility due to 64bit time_t gperftools: Convert static and libunwind support to packageconfig libmad: Define O2 for all arches as default optimization rsyslog: Dont force enable atomic builtins on mips libtorrent: Drop 64bit atomics patch for mips/ppc libtorrent: Disable instrumentation on ppc/mips libkcapi: Move static inline functions where used grpc: Link with libatomic on clang/x86 upm: Link with libatomic on clang/x86 Leon Anavi (1): surf: Add a simple web browser Martin Balik (1): squid: upgrade 4.6 -> 4.9 Nicola Lunghi (2): python-jsonschema: multiple fixes python-jsonschema: add PACKAGECONFIG nongpl option Oleksandr Kravchuk (1): flatbuffers: update to 1.11.0 Peter Kjellerstedt (1): libldb: Do not require the "pam" distro feature to be enabled nick83ola (2): python3-apply-defaults: add recipe python3-jsonrpcserver: add recipe Change-Id: I231fc015cba86b7c14915ffc3f6f123c9296fd68 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-gnome/recipes-gnome/gnome-terminal')
-rw-r--r--meta-openembedded/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal/0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch35
-rw-r--r--meta-openembedded/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.34.2.bb37
2 files changed, 72 insertions, 0 deletions
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal/0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch b/meta-openembedded/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal/0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch
new file mode 100644
index 000000000..a69390eb2
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal/0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch
@@ -0,0 +1,35 @@
+From f231cecc151930fd5b6309da317a8c5bc6001f38 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Sun, 17 Nov 2019 15:55:54 +0100
+Subject: [PATCH] Add W_EXITCODE macro for non-glibc systems
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Pending
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ src/terminal.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/src/terminal.c b/src/terminal.c
+index d06ce35..6284e4c 100644
+--- a/src/terminal.c
++++ b/src/terminal.c
+@@ -47,6 +47,12 @@
+ GS_DEFINE_CLEANUP_FUNCTION0(TerminalOptions*, gs_local_options_free, terminal_options_free)
+ #define gs_free_options __attribute__ ((cleanup(gs_local_options_free)))
+
++/* fix for musl */
++#ifndef W_EXITCODE
++#define W_EXITCODE(ret, sig) ((ret) << 8 | (sig))
++#endif
++
++
+ /* Wait-for-exit helper */
+
+ typedef struct {
+--
+2.21.0
+
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.34.2.bb b/meta-openembedded/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.34.2.bb
new file mode 100644
index 000000000..ffbabbf88
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/gnome-terminal/gnome-terminal_3.34.2.bb
@@ -0,0 +1,37 @@
+SUMMARY = "GNOME terminal"
+LICENSE = "GPLv3 & GFDL-1.3"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
+ file://COPYING.GFDL;md5=a22d0be1ce2284b67950a4d1673dd1b0 \
+"
+
+inherit gnomebase gnome-help gettext itstool upstream-version-is-even
+
+DEPENDS = " \
+ glib-2.0-native \
+ intltool-native \
+ yelp-tools-native \
+ desktop-file-utils-native \
+ gtk+3 \
+ gsettings-desktop-schemas \
+ vte \
+ dconf \
+ libpcre2 \
+"
+
+SRC_URI[archive.md5sum] = "13fa9f5f459481c7f05b6964c470ef16"
+SRC_URI[archive.sha256sum] = "3bd723f4058ec014da4715db4181b7d73eccc797b85ad5e6236996951c01803d"
+SRC_URI += "file://0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch"
+
+EXTRA_OECONF += " \
+ --disable-search-provider \
+ --without-nautilus-extension \
+"
+
+FILES_${PN} += " \
+ ${datadir}/metainfo \
+ ${datadir}/dbus-1 \
+ ${systemd_user_unitdir} \
+"
+
+RRECOMMENDS_${PN} += "vte-prompt gsettings-desktop-schemas"