summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.7.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-29 16:48:15 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-29 16:48:21 +0300
commit93c3acf56fcecefef579497263e98c15b6b0e34a (patch)
treeb2b86526293298bb30af7587d17d62405832b930 /meta-openembedded/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.7.bb
parentb350a87270ee007fb1da2c564c050184abd5ba1e (diff)
downloadopenbmc-93c3acf56fcecefef579497263e98c15b6b0e34a.tar.xz
meta-openembedded: subtree update:18506b797b..c986cbed93
Adrian Bunk (7): gpsd: Backport a memory leak fix gpsd: Stop depending on chrpath-native klibc: Upgrade 2.0.6 -> 2.0.7 gerbera: Upgrade 1.3.0 -> 1.3.2 gstd: Fix the version number webrtc-audio-processing: Upgrade 0.3 -> 0.3.1 vlc: Upgrade 3.0.6 -> 3.0.8 Andreas Müller (15): itstool: rework native shebang and add class to make native itstool work yelp-tools: use itstools.bbclass yelp-xsl: use itstool.bbclass yelp: use itstool.bbclass gnome-help.bbclass: Handle gnome-help files with new distro feature 'helpfiles' zenity: rework recipe dconf: extend to native build for upcoming gdm dconf-editor: upgrade 3.32.0 -> 3.34.0 gtksourceview4: upgrade 4.2.0 -> 4.4.0 gnome-menus3: upgrade 3.10.1 -> 3.32.0 gnome-desktop3: upgrade 3.34.0 -> 3.34.1 gnome-bluetooth: upgrade 3.32.1 -> 3.34.0 gspell: upgrade 1.8.1 -> 1.8.2 gnome-system-monitor: upgrade 3.32.0 -> 3.32.1 network-manager-applet: upgrade 1.8.22 -> 1.8.23 / build with meson / cleanup Luca Boccassi (4): dbus-broker: 19 -> 21 dbus-broker: backport patches from master dbus-broker: build with SELinux if it's enabled via DISTRO_FEATURES dbus-broker: add patch to fix build with musl libc Trevor Gamblin (1): rsyslog: upgrade from v8.1908.0 to v8.1910.0 Zang Ruochen (4): python-bitarray: upgrade 0.8.3 -> 1.0.1 python-can: upgrade 2.2.1 -> 3.3.2 python-daemonize: upgrade 2.4.7 -> 2.5.0 xmlsec1: upgrade 1.2.28 -> 1.2.29 Zheng Ruoqin (2): keepalived: upgrade 2.0.16 -> 2.0.19 postfix: upgrade 3.4.5 -> 3.4.7 Change-Id: Ibff272f163bb42473022825cfb17a284a0019e83 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.7.bb')
-rw-r--r--meta-openembedded/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.7.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openembedded/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.7.bb b/meta-openembedded/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.7.bb
new file mode 100644
index 000000000..4011aa231
--- /dev/null
+++ b/meta-openembedded/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.7.bb
@@ -0,0 +1,32 @@
+SUMMARY = "The klcc crosscompiler for klibc"
+
+require klibc.inc
+DEPENDS = "klibc"
+
+# no packaging for this crossscript
+PACKAGES = ""
+inherit nopackages
+
+SRC_URI += "file://use-env-for-perl.patch"
+
+# disable task already run in klibc recipe
+do_configure[noexec] = "1"
+
+do_compile() {
+ oe_runmake 'INSTALLDIR=${STAGING_DIR_TARGET}${libdir}/klibc' klcc
+}
+
+do_install() {
+ install -d ${D}${bindir_crossscripts}/
+ install -m 0755 klcc/klcc ${D}${bindir_crossscripts}/${TARGET_PREFIX}klcc
+ # Turn the horribly encoded paths into something which sstate can transform using its ususal
+ # magic by removing all the crazy escaping.
+ sed -i -e "2i \$TARGETSYSROOT = '${STAGING_DIR_TARGET}';" \
+ -e "2i \$NATIVESYSROOT = '${STAGING_DIR_NATIVE}';" \
+ -e 's#${@d.getVar("STAGING_DIR_NATIVE").replace("/", "\\\\/").replace("-", "\\\\-").replace(".", "\\\\.")}#${NATIVESYSROOT}#g;' \
+ -e 's#${@d.getVar("STAGING_DIR_TARGET").replace("/", "\\\\/").replace("-", "\\\\-").replace(".", "\\\\.")}#${TARGETSYSROOT}#g' \
+ ${D}${bindir_crossscripts}/${TARGET_PREFIX}klcc
+}
+
+SYSROOT_DIRS += "${bindir_crossscripts}"
+SSTATE_SCAN_FILES += "*-klcc"