summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/files/0001-meson-import-python3-to-use-also-from-sysroot.patch
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-04-13 21:39:40 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-05 16:30:44 +0300
commit82c905dc58a36aeae40b1b273a12f63fb1973cf4 (patch)
tree38caf00263451b5036435cdc36e035b25d32e623 /meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/files/0001-meson-import-python3-to-use-also-from-sysroot.patch
parent83ecb75644b3d677c274188f9ac0b2374d6f6925 (diff)
downloadopenbmc-82c905dc58a36aeae40b1b273a12f63fb1973cf4.tar.xz
meta-openembedded and poky: subtree updates
Squash of the following due to dependencies among them and OpenBMC changes: meta-openembedded: subtree update:d0748372d2..9201611135 meta-openembedded: subtree update:9201611135..17fd382f34 poky: subtree update:9052e5b32a..2e11d97b6c poky: subtree update:2e11d97b6c..a8544811d7 The change log was too large for the jenkins plugin to handle therefore it has been removed. Here is the first and last commit of each subtree: meta-openembedded:d0748372d2 cppzmq: bump to version 4.6.0 meta-openembedded:17fd382f34 mpv: Remove X11 dependency poky:9052e5b32a package_ipk: Remove pointless comment to trigger rebuild poky:a8544811d7 pbzip2: Fix license warning Change-Id: If0fc6c37629642ee207a4ca2f7aa501a2c673cd6 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/files/0001-meson-import-python3-to-use-also-from-sysroot.patch')
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/files/0001-meson-import-python3-to-use-also-from-sysroot.patch61
1 files changed, 0 insertions, 61 deletions
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/files/0001-meson-import-python3-to-use-also-from-sysroot.patch b/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/files/0001-meson-import-python3-to-use-also-from-sysroot.patch
deleted file mode 100644
index fc56a6852..000000000
--- a/meta-openembedded/meta-multimedia/recipes-multimedia/libcamera/files/0001-meson-import-python3-to-use-also-from-sysroot.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From ea47e53911213d71e997eb34848ae72735bacc82 Mon Sep 17 00:00:00 2001
-From: madhavank27 <madhavan.krishnan@linaro.org>
-Date: Thu, 9 Jan 2020 07:42:18 +0100
-Subject: [PATCH] meson: import python3 to use also from sysroot
-
-importing python module can provide the exact path
-which can be used in desktop build as well as from
-any build system
-
-Upstream-Status: Pending
-Signed-off-by: madhavank27 <madhavan.krishnan@linaro.org>
----
- include/libcamera/meson.build | 4 +++-
- src/libcamera/meson.build | 4 +++-
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/include/libcamera/meson.build b/include/libcamera/meson.build
-index 99abf06..83525e2 100644
---- a/include/libcamera/meson.build
-+++ b/include/libcamera/meson.build
-@@ -21,13 +21,15 @@ include_dir = join_paths(libcamera_include_dir, 'libcamera')
- install_headers(libcamera_api,
- subdir : include_dir)
-
-+python_mod = import('python3').find_python()
-+
- gen_controls = files('../../src/libcamera/gen-controls.py')
-
- control_ids_h = custom_target('control_ids_h',
- input : files('../../src/libcamera/control_ids.yaml', 'control_ids.h.in'),
- output : 'control_ids.h',
- depend_files : gen_controls,
-- command : [gen_controls, '-o', '@OUTPUT@', '@INPUT@'],
-+ command : [python_mod, gen_controls, '-o', '@OUTPUT@', '@INPUT@'],
- install : true,
- install_dir : join_paths('include', include_dir))
-
-diff --git a/src/libcamera/meson.build b/src/libcamera/meson.build
-index c4f965b..243935b 100644
---- a/src/libcamera/meson.build
-+++ b/src/libcamera/meson.build
-@@ -65,13 +65,15 @@ if libudev.found()
- ])
- endif
-
-+python_mod = import('python3').find_python()
-+
- gen_controls = files('gen-controls.py')
-
- control_ids_cpp = custom_target('control_ids_cpp',
- input : files('control_ids.yaml', 'control_ids.cpp.in'),
- output : 'control_ids.cpp',
- depend_files : gen_controls,
-- command : [gen_controls, '-o', '@OUTPUT@', '@INPUT@'])
-+ command : [python_mod, gen_controls, '-o', '@OUTPUT@', '@INPUT@'])
-
- libcamera_sources += control_ids_cpp
- libcamera_sources += control_ids_h
---
-2.7.4
-