summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/files/0005-Use-python3-and-pip3-instead-of-python-and-pip.patch
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-21 15:11:42 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-21 15:11:49 +0300
commit6a62e0e0f4642841f3956fe2977f9d57766c2f2b (patch)
treec158ee7227dd3b9137b3bad7f84358258868b5a9 /meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/files/0005-Use-python3-and-pip3-instead-of-python-and-pip.patch
parent87ad221ffb3753e69264f664dcfc4f8a2e3d9081 (diff)
downloadopenbmc-6a62e0e0f4642841f3956fe2977f9d57766c2f2b.tar.xz
meta-openembedded: subtree update:1bfaa2e63a..64224b92e5
Adrian Bunk (1): networkmanager: Upgrade 1.18.2 -> 1.18.4 Alistair Francis (5): mycroft: Bump to 19.8.1 mycroft: Run the files from /var python3-monotonic: Initial commit of version 1.5 python3-msk: Initial commit of version 0.3.13 python3-google-api-python-client: Initial commit of 1.7.11 Andreas Müller (3): exiv2: initial add 0.27.1 menulibre: upgrade 2.2.0 -> 2.2.1 libmbim: upgrade 1.18.0 -> 1.20.0 Callaghan, Dan (1): strongswan: add a PACKAGECONFIG for libbfd stack traces Changqing Li (1): kea: fix kea-dhcp4.service/kea-dhcp6.service start up failed Christophe PRIOUZEAU (14): xfce4-mpc-plugin: Clarify BSD license variant xfce4-diskperf-plugin: Clarify BSD license variant xfce4-wavelan-plugin: Clarify BSD license variant libmpdclient: Clarify BSD license variant tremor: Clarify BSD license variant xscreensaver: Clarify BSD license variant openjpeg: Clarify BSD license variant sdparm: Clarify BSD license variant onig: Clarify BSD license variant libssh2: Clarify BSD license variant libsmi: Clarify BSD license variant libinih: Clarify BSD license variant gperftools: Clarify BSD license variant daemonize: Clarify BSD license variant Fabio Berton (1): ifplugd: Add recipe for version 0.28 George Kiagiadakis (1): pipewire: Initial add of 0.2.7 Hongxu Jia (1): lvm2/libdevmapper: 2.03.02 -> 2.03.05 Khem Raj (4): wvstreams,wvdial: Mark incompatible for musl pidgin-sipe: Upgrade to 1.25.0 dconf: Upgrade to 0.34.0 libsmi: Fix and operator per SPDX Martin Siegumfeldt (3): Revert "libiio: fix build of python bindins" libiio: allow python3 bindings to be built libiio: bump to version 0.18+ Stefan Wiehler (1): nvme-cli: defer host ID generation to post installation Tekkub (1): nlohmann-fifo: Add recipe Trevor Gamblin (2): rsyslog: fix CVE-2019-17041 quagga: fix PIDFile path for service files Yi Zhao (2): freeradius: fix CVE-2019-10143 ipvsadm: install initscript to /etc/init.d Zang Ruochen (9): python-paste: upgrade 3.2.1 -> 3.2.2 python-pip: upgrade 19.2.3 -> 19.3 python-pyasn1-modules: upgrade 0.2.6 -> 0.2.7 python-pytest: upgrade 5.1.3 -> 5.2.1 python-pytz: upgrade 2019.2 -> 2019.3 python-xxhash: upgrade 1.4.1 -> 1.4.2 python-cffi: upgrade 1.12.3 -> 1.13.0 python-jsonschema: upgrade 3.0.2 -> 3.1.1 protobuf: upgrade 3.9.2 -> 3.10.0 Change-Id: I72806dd6bfe6427787917f687d058c6ced02a00c Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/files/0005-Use-python3-and-pip3-instead-of-python-and-pip.patch')
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/files/0005-Use-python3-and-pip3-instead-of-python-and-pip.patch121
1 files changed, 121 insertions, 0 deletions
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/files/0005-Use-python3-and-pip3-instead-of-python-and-pip.patch b/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/files/0005-Use-python3-and-pip3-instead-of-python-and-pip.patch
new file mode 100644
index 000000000..189b686c9
--- /dev/null
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/files/0005-Use-python3-and-pip3-instead-of-python-and-pip.patch
@@ -0,0 +1,121 @@
+From 9a0bd09706da3949db17ea7272d6647a487bb6ad Mon Sep 17 00:00:00 2001
+From: Alistair Francis <alistair.francis@wdc.com>
+Date: Tue, 19 Mar 2019 13:38:44 -0700
+Subject: [PATCH 5/5] Use python3 and pip3 instead of python and pip
+
+Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
+Upstream-Status: Inappropriate [embedded specific]
+---
+ bin/mycroft-cli-client | 2 +-
+ bin/mycroft-pip | 2 +-
+ bin/mycroft-say-to | 2 +-
+ bin/mycroft-skill-testrunner | 4 ++--
+ bin/mycroft-speak | 2 +-
+ dev_setup.sh | 6 +++---
+ scripts/install-pocketsphinx.sh | 2 +-
+ 7 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/bin/mycroft-cli-client b/bin/mycroft-cli-client
+index f40a316e3f6..de2040d9e67 100755
+--- a/bin/mycroft-cli-client
++++ b/bin/mycroft-cli-client
+@@ -21,4 +21,4 @@ DIR="$( dirname "$SOURCE" )"
+ source "$DIR/../venv-activate.sh" -q
+
+ # Invoke the Command Line Interface
+-python -m mycroft.client.text $@
++python3 -m mycroft.client.text $@
+diff --git a/bin/mycroft-pip b/bin/mycroft-pip
+index a42b16b847a..81bd5bfb3cf 100755
+--- a/bin/mycroft-pip
++++ b/bin/mycroft-pip
+@@ -21,4 +21,4 @@ DIR="$( dirname "$SOURCE" )"
+ source "$DIR/../venv-activate.sh" -q
+
+ # Install pip packages within the Mycroft venv
+-pip $@
+\ No newline at end of file
++pip3 $@
+\ No newline at end of file
+diff --git a/bin/mycroft-say-to b/bin/mycroft-say-to
+index 4ae597f3062..8bb4039996d 100755
+--- a/bin/mycroft-say-to
++++ b/bin/mycroft-say-to
+@@ -26,4 +26,4 @@ set -- "${1:-$(</dev/stdin)}" "${@:2}"
+
+ # Send a message to be spoken
+ data="$@"
+-output=$(python -m mycroft.messagebus.send "recognizer_loop:utterance" "{\"utterances\": [\"$data\"], \"lang\": \"en-us\"}")
++output=$(python3 -m mycroft.messagebus.send "recognizer_loop:utterance" "{\"utterances\": [\"$data\"], \"lang\": \"en-us\"}")
+diff --git a/bin/mycroft-skill-testrunner b/bin/mycroft-skill-testrunner
+index 9699a4d138f..282f5ca65b0 100755
+--- a/bin/mycroft-skill-testrunner
++++ b/bin/mycroft-skill-testrunner
+@@ -22,7 +22,7 @@ source "$DIR/../venv-activate.sh" -q
+
+ # Invoke the individual skill tester
+ if [ "$#" -eq 0 ] ; then
+- python -m test.integrationtests.skills.runner .
++ python3 -m test.integrationtests.skills.runner .
+ else
+- python -m test.integrationtests.skills.runner $@
++ python3 -m test.integrationtests.skills.runner $@
+ fi
+\ No newline at end of file
+diff --git a/bin/mycroft-speak b/bin/mycroft-speak
+index d80f0e75b13..9448ea3400f 100755
+--- a/bin/mycroft-speak
++++ b/bin/mycroft-speak
+@@ -24,4 +24,4 @@ source "$DIR/../venv-activate.sh" -q
+
+ # Send a message to be spoken
+ data="$@"
+-output=$(python -m mycroft.messagebus.send "speak" "{\"utterance\": \"$data\"}")
++output=$(python3 -m mycroft.messagebus.send "speak" "{\"utterance\": \"$data\"}")
+diff --git a/dev_setup.sh b/dev_setup.sh
+index b5ca6851631..fcd0834669f 100755
+--- a/dev_setup.sh
++++ b/dev_setup.sh
+@@ -48,7 +48,7 @@ param=''
+
+ for var in "$@" ; do
+ # Check if parameter should be read
+- if [[ $param == 'python' ]] ; then
++ if [[ $param == 'python3' ]] ; then
+ opt_python=$var
+ param=""
+ continue
+@@ -75,7 +75,7 @@ for var in "$@" ; do
+ opt_skipmimicbuild=true
+ fi
+ if [[ $var == '-p' || $var == '--python' ]] ; then
+- param='python'
++ param='python3'
+ fi
+ done
+
+@@ -355,7 +355,7 @@ else
+ fi
+ fi
+
+-PYTHON=$(python -c "import sys;print('python{}.{}'.format(sys.version_info[0], sys.version_info[1]))")
++PYTHON=$(python3 -c "import sys;print('python{}.{}'.format(sys.version_info[0], sys.version_info[1]))")
+
+ SYSMEM=$(free | awk '/^Mem:/ { print $2 }')
+ MAXCORES=$(($SYSMEM / 512000))
+diff --git a/scripts/install-pocketsphinx.sh b/scripts/install-pocketsphinx.sh
+index 44d329b7985..d45f5c22747 100755
+--- a/scripts/install-pocketsphinx.sh
++++ b/scripts/install-pocketsphinx.sh
+@@ -47,7 +47,7 @@ function install_pocketsphinx() {
+
+ # build and install pocketsphinx python bindings
+ cd ${TOP}/pocketsphinx-python
+- python setup.py install
++ python3 setup.py install
+ }
+
+ if [ "$1" = "-q" ] ; then
+--
+2.23.0
+