summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.2.2.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-08 22:21:03 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-08 22:21:12 +0300
commit34ae60030e520db4235f13b99849052e594fde7b (patch)
treef672a23d5bf8d8cf74737e80a304c55766a7d596 /meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.2.2.bb
parent4e3797a177a8edd3909ab428353e5186447b8312 (diff)
downloadopenbmc-34ae60030e520db4235f13b99849052e594fde7b.tar.xz
meta-openembedded: refresh master: 0435c9e193..4a9deabbc8
Update meta-openembedded to master HEAD. Alistair Francis (7): python3-pyaudio: Initial commit python3-pyfann2: Initial commit python3-pocketsphinx: Initial commit python3-xxhash: Initial commit mycroft: Initial commit libfann: Initial commit python-cryptography: Bump from 2.4.1 to 2.6.1 Andreas Müller (10): xfce4-screenshooter: upgrade 1.9.4 -> 1.9.5 networkmanager: Fix upstream regex for 1.16 networkmanager: fix build with musl gvfs: fix configure options and DDEPENDS rrdtool: fix build by disabling docs libpeas: rework gobject-introspection handling gvfs: Fix missing executable permission flags for files in libexec gnome-desktop3: remove gconf from DEPENDS gnome-desktop3: rework gobject-introspection handling gnome-desktop3: Disable libseccomp for all archs Brad Bishop (1): libvncserver: enable split client/server packages Fabio Berton (1): python*-requests: Update 2.20.1 -> 2.21.0 Gianfranco Costamagna (2): cpprest: fix build failure on 32bit systems, with upstream merged patch libmodbus: start to prefer version 3.1.4 as default Hongxu Jia (1): dracut: fix udevdir not found Khem Raj (5): ncmpc: Rename artist_screen to library_screen networkmanager: Fix build with clang alsa-oss: Upgrade to 1.1.8 redis: Fix ocasional parallel build failure lcdproc: Fix parallel build Nikolay Nizov (2): android-tools-conf: fix typo android-tools-conf: Make sure /dev/pts/0 exists Oleksandr Kravchuk (2): fping: update to 4.2 nuttcp: update to 7.3.3 Peter Kjellerstedt (1): doxygen: Make it build with ninja 1.9.0 Qi.Chen@windriver.com (2): openldap: add missing CVE tag to patch ipsec-tools: add missing CVE tags to patches Randy MacLeod (2): imagemagic: upgrade to 7.0.8-35 wolfssl: update to 3.15.8 and use github SRC_URI Slater, Joseph (1): tcpreplay: update to version 4.3.2 Vincent Prince (4): Rsyslog: Add mmjsonparse to PACKAGECONFIG zeromq: bump version 4.2.5 => 4.3.1 cppzmq: bump version 4.2.3 => 4.3.0 czmq: bump version 4.1.1 => 4.2.0 Yi Zhao (3): python-engineio: add recipe python-socketio: add recipe python-flask-socketio Zang Ruochen (4): augeas: upgrade 1.10.1 -> 1.11.0 libedit: upgrade 20181209-3.1 -> 20190324-3.1 mcelog: upgrade 161 -> 162 lockfile-progs: upgrade 0.1.17 -> 0.1.18 leimaohui (1): Fix build error for armeb. Change-Id: Ie79748c484bcf4fd28b3bde84e2194044e1c08a8 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.2.2.bb')
-rw-r--r--meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.2.2.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.2.2.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.2.2.bb
new file mode 100644
index 000000000..c8ae53468
--- /dev/null
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/mycroft/mycroft_19.2.2.bb
@@ -0,0 +1,73 @@
+SUMMARY = "Mycroft is a hackable open source voice assistant."
+DESCRIPTION = "Mycroft is the world’s first open source assistant. "
+HOMEPAGE = "https://mycroft.ai/"
+SECTION = "multimedia"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=79aa497b11564d1d419ee889e7b498f6"
+
+SRCREV = "6706c377820912f83c1838d9eb32950ca9e39ec7"
+SRC_URI = "git://github.com/MycroftAI/mycroft-core.git;branch=master \
+ file://0001-Remove-python-venv.patch \
+ file://0002-pip-requirements-Remove-ones-installed-by-OE.patch \
+ file://0003-Use-python3-and-pip3-instead-of-python-and-pip.patch \
+ file://0004-dev_setup.sh-Remove-the-git-dependency.patch \
+ file://0005-dev_setup.sh-Remove-the-test-setup-dependency.patch \
+ file://dev_opts.json \
+ file://mycroft-setup.service \
+ file://mycroft.service \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit systemd
+
+# Mycroft installs itself on the host
+# Just copy the setup files to the rootfs
+do_install() {
+ install -d ${D}${libdir}/
+ cp -r ${B} ${D}${libdir}/mycroft
+ rm -r ${D}${libdir}/mycroft/.git
+
+ # Install the dev opts so it doesn't ask us on initial setup.
+ install -m 644 ${WORKDIR}/dev_opts.json ${D}${libdir}/mycroft/.dev_opts.json
+
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d ${D}${systemd_unitdir}/system
+ install -m 644 ${WORKDIR}/mycroft-setup.service ${D}${systemd_unitdir}/system
+ sed -i -e 's,@LIBDIR@,${libdir},g' ${D}${systemd_unitdir}/system/mycroft-setup.service
+ fi
+
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d ${D}${systemd_unitdir}/system
+ install -m 644 ${WORKDIR}/mycroft.service ${D}${systemd_unitdir}/system
+ sed -i -e 's,@LIBDIR@,${libdir},g' ${D}${systemd_unitdir}/system/mycroft.service
+ fi
+}
+
+FILES_${PN} += "${libdir}/mycroft"
+
+RDEPENDS_${PN} = "python3"
+
+# Install as many Python packages as we can.
+# We don't yet have all the packages in meta-python.
+# Install as many as we can and we will install the rest on the target with pip.
+# TODO: Add all the remaining packages and remove pip
+RDEPENDS_${PN} += "python3-pip \
+ python3-requests python3-pillow \
+ python3-tornado python3-pyyaml \
+ python3-pyalsaaudio python3-inflection \
+ python3-pyserial python3-psutil \
+ python3-pyaudio python3-fann2 \
+ python3-pocketsphinx \
+ python3-xxhash \
+ "
+
+# Mycroft uses Alsa and PulseAudio
+RDEPENDS_${PN} += "alsa-oss alsa-utils alsa-plugins alsa-tools"
+RDEPENDS_${PN} += "pulseaudio pulseaudio-misc pulseaudio-server"
+
+# Mycroft can do this itself on the target, but it's quicker to do it here
+RDEPENDS_${PN} += "mimic"
+
+SYSTEMD_SERVICE_${PN} = "mycroft-setup.service mycroft.service"