summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-openembedded/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb')
-rw-r--r--meta-openembedded/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openembedded/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb b/meta-openembedded/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
new file mode 100644
index 000000000..744171663
--- /dev/null
+++ b/meta-openembedded/meta-multimedia/recipes-support/crossguid/crossguid_0.2.2.bb
@@ -0,0 +1,20 @@
+# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Lightweight cross platform C++ GUID/UUID library"
+HOMEPAGE = "https://github.com/graeme-hill/crossguid"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68"
+DEPENDS += "util-linux"
+
+SRCREV = "5b45cdd9a56ca9da35ee0f8845cb4e2603d245dc"
+SRC_URI = "git://github.com/graeme-hill/crossguid;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+do_install() {
+ install -D -m 0644 ${B}/libxg.a ${D}${libdir}/libxg.a
+ install -D -m 0644 ${S}/Guid.hpp ${D}${includedir}/Guid.hpp
+}