summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-connectivity/dhcp
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-10-04 22:42:48 +0300
committerGitHub <noreply@github.com>2021-10-04 22:42:48 +0300
commit0c9e31989c615598b5d042ffab385606660c93c0 (patch)
tree8019999b0ca042482e5193d6cabc06220c71d776 /meta-openembedded/meta-networking/recipes-connectivity/dhcp
parent04cd92067d2481643df5010cb39b2134b648cf4d (diff)
parentffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (diff)
downloadopenbmc-0c9e31989c615598b5d042ffab385606660c93c0.tar.xz
Merge pull request #72 from Intel-BMC/update2021-0.751-0.75
Update
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-connectivity/dhcp')
-rw-r--r--meta-openembedded/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb b/meta-openembedded/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
index 6ea5b4b27..93364758e 100644
--- a/meta-openembedded/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
+++ b/meta-openembedded/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.2p1.bb
@@ -32,11 +32,11 @@ S = "${WORKDIR}/dhcp-4.4.2-P1"
inherit autotools-brokensep systemd
-SYSTEMD_SERVICE_${PN} = "dhcrelay.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+SYSTEMD_SERVICE:${PN} = "dhcrelay.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"
CFLAGS += "-D_GNU_SOURCE -fcommon"
-LDFLAGS_append = " -pthread"
+LDFLAGS:append = " -pthread"
EXTRA_OECONF = "--enable-paranoia \
--disable-static \
@@ -46,13 +46,13 @@ EXTRA_OECONF = "--enable-paranoia \
EXTRA_OEMAKE += "LIBTOOL='${S}/${HOST_SYS}-libtool'"
# Enable shared libs per dhcp README
-do_configure_prepend () {
+do_configure:prepend () {
cp configure.ac+lt configure.ac
rm ${S}/bind/bind.tar.gz
mv ${WORKDIR}/bind.tar.gz ${S}/bind/
}
-do_compile_prepend() {
+do_compile:prepend() {
rm -rf ${S}/bind/bind-9.11.32/
tar xf ${S}/bind/bind.tar.gz -C ${S}/bind
install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/bind/bind-9.11.32/
@@ -62,7 +62,7 @@ do_compile_prepend() {
install -m 0755 ${S}/${HOST_SYS}-libtool ${S}/bind/bind-9.11.32/
}
-do_install_append () {
+do_install:append () {
install -d ${D}${sysconfdir}/default
install -m 0644 ${WORKDIR}/default-relay ${D}${sysconfdir}/default/dhcp-relay