summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-support/wireshark
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-10-04 22:42:48 +0300
committerGitHub <noreply@github.com>2021-10-04 22:42:48 +0300
commit0c9e31989c615598b5d042ffab385606660c93c0 (patch)
tree8019999b0ca042482e5193d6cabc06220c71d776 /meta-openembedded/meta-networking/recipes-support/wireshark
parent04cd92067d2481643df5010cb39b2134b648cf4d (diff)
parentffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (diff)
downloadopenbmc-0c9e31989c615598b5d042ffab385606660c93c0.tar.xz
Merge pull request #72 from Intel-BMC/update2021-0.751-0.75
Update
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-support/wireshark')
-rw-r--r--meta-openembedded/meta-networking/recipes-support/wireshark/README4
-rw-r--r--meta-openembedded/meta-networking/recipes-support/wireshark/wireshark_3.4.7.bb (renamed from meta-openembedded/meta-networking/recipes-support/wireshark/wireshark_3.4.6.bb)18
2 files changed, 11 insertions, 11 deletions
diff --git a/meta-openembedded/meta-networking/recipes-support/wireshark/README b/meta-openembedded/meta-networking/recipes-support/wireshark/README
index 63b5b7263..f5e4d0477 100644
--- a/meta-openembedded/meta-networking/recipes-support/wireshark/README
+++ b/meta-openembedded/meta-networking/recipes-support/wireshark/README
@@ -14,12 +14,12 @@ Adding the wireshark to your build
========================================
via local.conf
-IMAGE_INSTALL_append = " wireshark"
+IMAGE_INSTALL:append = " wireshark"
Adding the wireshark to your graphical build
========================================
via local.conf
-IMAGE_INSTALL_append = " wireshark"
+IMAGE_INSTALL:append = " wireshark"
and one of:
diff --git a/meta-openembedded/meta-networking/recipes-support/wireshark/wireshark_3.4.6.bb b/meta-openembedded/meta-networking/recipes-support/wireshark/wireshark_3.4.7.bb
index 3062633bc..fc360f669 100644
--- a/meta-openembedded/meta-networking/recipes-support/wireshark/wireshark_3.4.6.bb
+++ b/meta-openembedded/meta-networking/recipes-support/wireshark/wireshark_3.4.7.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6e271234ba1a13c6e512e76b94ac2f77"
DEPENDS = "pcre expat glib-2.0 glib-2.0-native libgcrypt libgpg-error libxml2 bison-native c-ares"
-DEPENDS_append_class-target = " wireshark-native chrpath-replacement-native "
+DEPENDS:append:class-target = " wireshark-native chrpath-replacement-native "
SRC_URI = "https://1.eu.dl.wireshark.org/src/all-versions/wireshark-${PV}.tar.xz"
@@ -19,7 +19,7 @@ SRC_URI += " \
UPSTREAM_CHECK_URI = "https://1.as.dl.wireshark.org/src"
-SRC_URI[sha256sum] = "12a678208f8cb009e6b9d96026e41a6ef03c7ad086b9e1029f42053b249b4628"
+SRC_URI[sha256sum] = "6c4cee51ef997cb9d9aaee84113525a5629157d3c743d7c4e320000de804a09d"
PE = "1"
@@ -27,7 +27,7 @@ inherit cmake pkgconfig python3native perlnative upstream-version-is-even mime m
PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc"
-PACKAGECONFIG_class-native = "libpcap gnutls ssl libssh"
+PACKAGECONFIG:class-native = "libpcap gnutls ssl libssh"
PACKAGECONFIG[libcap] = "-DENABLE_CAP=ON,-DENABLE_CAP=OFF -DENABLE_PCAP_NG_DEFAULT=ON, libcap"
PACKAGECONFIG[libpcap] = "-DENABLE_PCAP=ON,-DENABLE_PCAP=OFF -DENABLE_PCAP_NG_DEFAULT=ON , libpcap"
@@ -60,9 +60,9 @@ EXTRA_OECMAKE += "-DENABLE_NETLINK=ON \
-DM_INCLUDE_DIR=${includedir} \
-DM_LIBRARY=${libdir} \
"
-CFLAGS_append = " -lm"
+CFLAGS:append = " -lm"
-do_install_append_class-native() {
+do_install:append:class-native() {
install -d ${D}${bindir}
for f in lemon
do
@@ -70,7 +70,7 @@ do_install_append_class-native() {
done
}
-do_install_append_class-target() {
+do_install:append:class-target() {
for f in `find ${D}${libdir} ${D}${bindir} -type f -executable`
do
chrpath --delete $f
@@ -79,10 +79,10 @@ do_install_append_class-target() {
PACKAGE_BEFORE_PN += "tshark"
-FILES_tshark = "${bindir}/tshark ${mandir}/man1/tshark.*"
+FILES:tshark = "${bindir}/tshark ${mandir}/man1/tshark.*"
-FILES_${PN} += "${datadir}*"
+FILES:${PN} += "${datadir}*"
-RDEPENDS_tshark = "wireshark"
+RDEPENDS:tshark = "wireshark"
BBCLASSEXTEND = "native"