summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-09 16:56:13 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-09 16:56:15 +0300
commit63ae87823ca5774411cb29a7aebf35efae85f0b3 (patch)
tree406e837757534cef9e6f699194a91010847f1aab /meta-openembedded/meta-oe/recipes-benchmark
parent9e4e2b2411eb9336f6ae4f595eb4fc6884a9b0eb (diff)
downloadopenbmc-63ae87823ca5774411cb29a7aebf35efae85f0b3.tar.xz
meta-openembedded: subtree update:01d539b324..fd1a0c9210
Adrian Bunk (1): xmlrpc-c: Remove the RDEPENDS on perl Denys Dmytriyenko (1): mariadb: update SRC_URI to use archive.mariadb.org Khem Raj (7): xorg-fonts-100dpi: Change License Custom -> MIT fio: Depend on coreutils-native for fmt utility fio: Fix build when march is armv7ve pmdk: Update to 1.7 README: Document need for 32bit compiler mongodb: Turn system libpcre support into packageconfig grpc: Update to 1.24.1 Otavio Salvador (1): modemmanager: Upgrade 1.10.2 -> 1.10.6 Palmer Dabbelt (1): Add zeus compatibility to all layer.conf files Peiran Hong (1): tcpdump: upgrade 4.9.2 -> 4.9.3 Stefan Agner (1): zram: properly implement systemd service Stefan Wiehler (1): nvme-cli: upgrade 1.6 -> 1.9 Trevor Gamblin (2): gnome-desktop3: upgrade from 3.32.0 to 3.34.0 freeradius: add -latomic for armv5 William A. Kennington III via Openembedded-devel (1): log4cpp: Stop using RC as a variable Change-Id: I9b3bd69a061da11a59d38bce42543cb090b24601 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-benchmark')
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/fio/files/0001-arch-arm-Consider-armv7ve-arch-as-well.patch28
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/fio/fio_3.16.bb3
2 files changed, 30 insertions, 1 deletions
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/fio/files/0001-arch-arm-Consider-armv7ve-arch-as-well.patch b/meta-openembedded/meta-oe/recipes-benchmark/fio/files/0001-arch-arm-Consider-armv7ve-arch-as-well.patch
new file mode 100644
index 000000000..983a76fb6
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-benchmark/fio/files/0001-arch-arm-Consider-armv7ve-arch-as-well.patch
@@ -0,0 +1,28 @@
+From 2af58909cd9f2862d1dc07836e201361a2cd8d5d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 5 Oct 2019 08:53:22 -0700
+Subject: [PATCH] arch-arm: Consider armv7ve arch as well
+
+Upstream-Status: Submitted []
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ arch/arch-arm.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/arch/arch-arm.h b/arch/arch-arm.h
+index 78cb2ebe..4f722967 100644
+--- a/arch/arch-arm.h
++++ b/arch/arch-arm.h
+@@ -11,7 +11,7 @@
+ #define nop __asm__ __volatile__("mov\tr0,r0\t@ nop\n\t")
+ #define read_barrier() __asm__ __volatile__ ("" : : : "memory")
+ #define write_barrier() __asm__ __volatile__ ("" : : : "memory")
+-#elif defined(__ARM_ARCH_7A__) || defined(__ARM_ARCH_8A__)
++#elif defined(__ARM_ARCH_7A__) || defined(__ARM_ARCH_8A__) || defined(__ARM_ARCH_7VE__)
+ #define nop __asm__ __volatile__ ("nop")
+ #define read_barrier() __sync_synchronize()
+ #define write_barrier() __sync_synchronize()
+--
+2.23.0
+
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/fio/fio_3.16.bb b/meta-openembedded/meta-oe/recipes-benchmark/fio/fio_3.16.bb
index 092b2bead..adab61878 100644
--- a/meta-openembedded/meta-oe/recipes-benchmark/fio/fio_3.16.bb
+++ b/meta-openembedded/meta-oe/recipes-benchmark/fio/fio_3.16.bb
@@ -10,7 +10,7 @@ SECTION = "console/tests"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "libaio zlib"
+DEPENDS = "libaio zlib coreutils-native"
RDEPENDS_${PN} = "python bash"
PACKAGECONFIG_NUMA = "numa"
@@ -24,6 +24,7 @@ PACKAGECONFIG[numa] = ",--disable-numa,numactl"
SRCREV = "92f75708b530989fdb13b50be6604f44b80d038d"
SRC_URI = "git://git.kernel.dk/fio.git \
file://0001-update-the-interpreter-paths.patch \
+ file://0001-arch-arm-Consider-armv7ve-arch-as-well.patch \
"
S = "${WORKDIR}/git"