summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-08-31 21:23:16 +0300
committerGitHub <noreply@github.com>2021-08-31 21:23:16 +0300
commit04cd92067d2481643df5010cb39b2134b648cf4d (patch)
treed98626c9763ad9048ac9bfd8269e12eced18d496 /meta-openembedded/meta-oe/recipes-benchmark
parent10ad77d5bc86709d8ff7f95e7040e39f1c153903 (diff)
parent6f106a0a4ce15fe0678d4ffefd572e6978c72597 (diff)
downloadopenbmc-04cd92067d2481643df5010cb39b2134b648cf4d.tar.xz
Merge pull request #70 from Intel-BMC/update2021-0.701-0.70
Update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-benchmark')
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/fio/fio_3.27.bb (renamed from meta-openembedded/meta-oe/recipes-benchmark/fio/fio_3.26.bb)2
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/iozone3/iozone3/parallelism.patch35
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/iozone3/iozone3_492.bb (renamed from meta-openembedded/meta-oe/recipes-benchmark/iozone3/iozone3_490.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/libc-bench/libc-bench/0001-build-Do-not-override-ldflags-from-environment.patch30
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/libc-bench/libc-bench_git.bb1
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/memtester/memtester_4.5.1.bb (renamed from meta-openembedded/meta-oe/recipes-benchmark/memtester/memtester_4.5.0.bb)4
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch40
-rw-r--r--meta-openembedded/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb4
8 files changed, 100 insertions, 20 deletions
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/fio/fio_3.26.bb b/meta-openembedded/meta-oe/recipes-benchmark/fio/fio_3.27.bb
index 6f2464e5e..d18649db0 100644
--- a/meta-openembedded/meta-oe/recipes-benchmark/fio/fio_3.26.bb
+++ b/meta-openembedded/meta-oe/recipes-benchmark/fio/fio_3.27.bb
@@ -22,7 +22,7 @@ PACKAGECONFIG_NUMA_armeb = ""
PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
PACKAGECONFIG[numa] = ",--disable-numa,numactl"
-SRCREV = "267b164c372d57145880f365bab8d8a52bf8baa7"
+SRCREV = "0313e938c9c8bb37d71dade239f1f5326677b079"
SRC_URI = "git://git.kernel.dk/fio.git \
"
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/iozone3/iozone3/parallelism.patch b/meta-openembedded/meta-oe/recipes-benchmark/iozone3/iozone3/parallelism.patch
index d5622ed2c..48069ff14 100644
--- a/meta-openembedded/meta-oe/recipes-benchmark/iozone3/iozone3/parallelism.patch
+++ b/meta-openembedded/meta-oe/recipes-benchmark/iozone3/iozone3/parallelism.patch
@@ -10,20 +10,24 @@ Only fixed linux targets for now
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Upstream-Status: Pending
+---
+ current/makefile | 18 +++++++++---------
+ 1 file changed, 9 insertions(+), 9 deletions(-)
-
---- current/makefile.org 2016-12-06 02:19:10.367911020 +0000
-+++ current/makefile 2016-12-06 02:21:38.767911020 +0000
-@@ -167,7 +167,7 @@
+diff --git current/makefile current/makefile
+index 3a54701..7071427 100644
+--- current/makefile
++++ current/makefile
+@@ -171,7 +171,7 @@ hpux_no_ansi: iozone_hpux_no.o libbif.o
#
# GNU 'C' compiler Linux build with threads, largefiles, async I/O
#
-linux: iozone_linux.o libasync.o libbif.o fileop_linux.o pit_server.o
+linux: iozone_linux.o fileop_linux.o pit_server.o
- $(CC) -O3 $(LDFLAGS) iozone_linux.o libasync.o libbif.o -lpthread \
+ $(CC) -O3 $(CFLAGS) iozone_linux.o libasync.o libbif.o -lpthread \
-lrt -o iozone
- $(CC) -O3 -Dlinux fileop_linux.o -o fileop
-@@ -176,7 +176,7 @@
+ $(CC) -O3 $(CFLAGS) -Dlinux fileop_linux.o -o fileop
+@@ -180,7 +180,7 @@ linux: iozone_linux.o libasync.o libbif.o fileop_linux.o pit_server.o
#
# GNU 'C' compiler Linux build for powerpc chip with threads, largefiles, async I/O
#
@@ -32,7 +36,7 @@ Upstream-Status: Pending
$(CC) -O3 $(LDFLAGS) iozone_linux-powerpc.o libasync.o \
libbif.o -lpthread -lrt -o iozone
$(CC) -O3 -Dlinux fileop_linux-ppc.o -o fileop
-@@ -184,7 +184,7 @@
+@@ -188,7 +188,7 @@ linux-powerpc: iozone_linux-powerpc.o libbif.o libasync.o fileop_linux-ppc.o pi
#
# GNU 'C' compiler Linux build for sparc chip with threads, largefiles, async I/O
#
@@ -41,7 +45,7 @@ Upstream-Status: Pending
$(CC) -O3 $(LDFLAGS) iozone_linux-sparc.o libasync.o libbif.o \
-lpthread -lrt -o iozone
$(CC) -O3 -Dlinux fileop_linux.o -o fileop
-@@ -193,7 +193,7 @@
+@@ -197,7 +197,7 @@ linux-sparc: iozone_linux-sparc.o libbif.o libasync.o fileop_linux.o pit_server
#
# GNU 'C' compiler Linux build with threads, largefiles, async I/O
#
@@ -50,7 +54,7 @@ Upstream-Status: Pending
$(CC) -O3 $(LDFLAGS) iozone_linux-ia64.o libbif.o libasync.o \
-lrt -lpthread -o iozone
$(CC) -O3 -Dlinux fileop_linux-ia64.o -o fileop
-@@ -202,7 +202,7 @@
+@@ -206,7 +206,7 @@ linux-ia64: iozone_linux-ia64.o libbif.o libasync.o fileop_linux-ia64.o pit_ser
#
# GNU 'C' compiler Linux build for powerpc chip with threads, largefiles, async I/O
#
@@ -59,7 +63,7 @@ Upstream-Status: Pending
$(CC) -O3 -Dunix -DHAVE_ANSIC_C -DSHARED_MEM -DASYNC_IO \
-D_LARGEFILE64_SOURCE -Dlinux \
iozone_linux-powerpc64.o libasync.o libbif.o -lpthread \
-@@ -213,7 +213,7 @@
+@@ -217,7 +217,7 @@ linux-powerpc64: iozone_linux-powerpc64.o libbif.o libasync.o fileop_linux-ppc6
#
# GNU 'C' compiler Linux build with threads, largefiles, async I/O
#
@@ -68,7 +72,7 @@ Upstream-Status: Pending
$(CC) -O3 $(LDFLAGS) iozone_linux-arm.o libbif.o libasync.o \
-lrt -lpthread -o iozone
$(CC) -O3 -Dlinux fileop_linux-arm.o -o fileop
-@@ -222,7 +222,7 @@
+@@ -249,7 +249,7 @@ endif
#
# GNU 'C' compiler Linux build with threads, largefiles, async I/O
#
@@ -77,7 +81,7 @@ Upstream-Status: Pending
$(CC) -O3 $(LDFLAGS) iozone_linux-AMD64.o libbif.o libasync.o \
-lrt -lpthread -o iozone
$(CC) -O3 -Dlinux fileop_linux-AMD64.o -o fileop
-@@ -231,7 +231,7 @@
+@@ -258,7 +258,7 @@ linux-AMD64: iozone_linux-AMD64.o libbif.o libasync.o fileop_linux-AMD64.o pit_
#
# GNU 'C' compiler Linux build with S/390, threads, largfiles, async I/O
#
@@ -86,7 +90,7 @@ Upstream-Status: Pending
$(CC) -O2 $(LDFLAGS) -lpthread -lrt iozone_linux-s390.o \
libbif.o libasync.o -o iozone
$(CC) -O3 -Dlinux fileop_linux-s390.o -o fileop
-@@ -240,7 +240,7 @@
+@@ -267,7 +267,7 @@ linux-S390: iozone_linux-s390.o libbif.o libasync.o fileop_linux-s390.o pit_serv
#
# GNU 'C' compiler Linux build with S/390, threads, largfiles, async I/O
#
@@ -95,3 +99,6 @@ Upstream-Status: Pending
$(CC) -O2 $(LDFLAGS) -lpthread -lrt iozone_linux-s390x.o \
libbif.o libasync.o -o iozone
$(CC) -O3 -Dlinux fileop_linux-s390x.o -o fileop
+--
+2.25.1
+
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/iozone3/iozone3_490.bb b/meta-openembedded/meta-oe/recipes-benchmark/iozone3/iozone3_492.bb
index 1d2e53a31..a68a27c97 100644
--- a/meta-openembedded/meta-oe/recipes-benchmark/iozone3/iozone3_490.bb
+++ b/meta-openembedded/meta-oe/recipes-benchmark/iozone3/iozone3_492.bb
@@ -11,8 +11,8 @@ SRC_URI = "http://www.iozone.org/src/current/${BPN}_${PV}.tar \
file://0001-let-system-headers-provide-pread64.patch \
file://copyright.txt \
"
-SRC_URI[md5sum] = "95cb73dfdd58a0dfa42804f016dbb83c"
-SRC_URI[sha256sum] = "5eadb4235ae2a956911204c50ebf2d8d8d59ddcd4a2841a1baf42f3145ad4fed"
+SRC_URI[md5sum] = "228f54482c01d1c04c571a9414cd20e5"
+SRC_URI[sha256sum] = "322981e168f32bd39f54772b82b2906d598d958c37e954e75742e71baf58bb9b"
UPSTREAM_CHECK_REGEX = "iozone3_(?P<pver>\d+).tar"
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/libc-bench/libc-bench/0001-build-Do-not-override-ldflags-from-environment.patch b/meta-openembedded/meta-oe/recipes-benchmark/libc-bench/libc-bench/0001-build-Do-not-override-ldflags-from-environment.patch
new file mode 100644
index 000000000..060b418fc
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-benchmark/libc-bench/libc-bench/0001-build-Do-not-override-ldflags-from-environment.patch
@@ -0,0 +1,30 @@
+From 419dac71dd524a39ad2333e91334b4650e277a78 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 25 Jun 2021 09:43:00 -0700
+Subject: [PATCH] build: Do not override ldflags from environment
+
+bitbake passed LDFLAGS contain important information e.g. which compiler
+runtime to link etc. Therefore append -static to LDFLAGS instead
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index efda5c0..a867876 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@ SRCS = $(sort $(wildcard *.c))
+ OBJS = $(SRCS:.c=.o)
+
+ CFLAGS = -Os -D_XOPEN_SOURCE=700
+-LDFLAGS = -static
++LDFLAGS += -static
+ LIBS = -lpthread -lrt -lpthread
+
+
+--
+2.32.0
+
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/libc-bench/libc-bench_git.bb b/meta-openembedded/meta-oe/recipes-benchmark/libc-bench/libc-bench_git.bb
index e81389431..f16bd99d5 100644
--- a/meta-openembedded/meta-oe/recipes-benchmark/libc-bench/libc-bench_git.bb
+++ b/meta-openembedded/meta-oe/recipes-benchmark/libc-bench/libc-bench_git.bb
@@ -10,6 +10,7 @@ SRCREV = "b6b2ce5f9f87a09b14499cb00c600c601f022634"
PV = "20110206+git${SRCPV}"
SRC_URI = "git://git.musl-libc.org/libc-bench \
+ file://0001-build-Do-not-override-ldflags-from-environment.patch \
"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/memtester/memtester_4.5.0.bb b/meta-openembedded/meta-oe/recipes-benchmark/memtester/memtester_4.5.1.bb
index 1a041101b..1628a0519 100644
--- a/meta-openembedded/meta-oe/recipes-benchmark/memtester/memtester_4.5.0.bb
+++ b/meta-openembedded/meta-oe/recipes-benchmark/memtester/memtester_4.5.1.bb
@@ -8,8 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
SRC_URI = "http://pyropus.ca/software/memtester/old-versions/${BP}.tar.gz \
file://Makefile.patch \
"
-SRC_URI[md5sum] = "674a8a88ff54bdb229ca4148218a41f1"
-SRC_URI[sha256sum] = "8ed52b0d06d4aeb61954994146e2a5b2d20448a8f3ce3ee995120e6dbde2ae37"
+SRC_URI[md5sum] = "1bc22c01e987d6a67fac39dc5656a4d3"
+SRC_URI[sha256sum] = "1c5fc2382576c084b314cfd334d127a66c20bd63892cac9f445bc1d8b4ca5a47"
do_compile () {
echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch b/meta-openembedded/meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch
new file mode 100644
index 000000000..d628e81b5
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-benchmark/sysbench/sysbench/0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch
@@ -0,0 +1,40 @@
+From c1ebf893e32a0a77e820484d48a903523fef7c1b Mon Sep 17 00:00:00 2001
+From: Vasily Tarasov <tarasov@vasily.name>
+Date: Fri, 10 Jun 2016 14:33:48 -0400
+Subject: [PATCH] Adding volatile modifier to tmp variable in memory test
+
+Issue explanation:
+
+./sysbench/sysbench --test=memory --num-threads=16 \
+ --memory-block-size=268435456 \
+ --memory-total-size=137438953472 \
+ --memory-oper=read \
+ --memory-access-mode=seq \
+ --memory-scope=local run
+
+Without this commit the time to run the above command is 0.0004 seconds.
+With this commit the time is greater than 3 seconds. Essentially,
+without the volatile modifier, the compiler optimizes read access so
+that no real access happens.
+
+Upstream-Status: Backport [part of v1.0.0 https://github.com/akopytov/sysbench/commit/8753cb93be4c0b81a20b704ced91e7a422da52b1]
+
+(cherry picked from commit 8753cb93be4c0b81a20b704ced91e7a422da52b1)
+Signed-off-by: massimo toscanelli <massimo.toscanelli@leica-geosystems.com>
+---
+ sysbench/tests/memory/sb_memory.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/sysbench/tests/memory/sb_memory.c b/sysbench/tests/memory/sb_memory.c
+index 2e8998f..7d22bb9 100644
+--- a/sysbench/tests/memory/sb_memory.c
++++ b/sysbench/tests/memory/sb_memory.c
+@@ -244,7 +244,7 @@ sb_request_t memory_get_request(int tid)
+ int memory_execute_request(sb_request_t *sb_req, int thread_id)
+ {
+ sb_mem_request_t *mem_req = &sb_req->u.mem_request;
+- int tmp = 0;
++ volatile int tmp = 0;
+ int idx;
+ int *buf, *end;
+ log_msg_t msg;
diff --git a/meta-openembedded/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb b/meta-openembedded/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
index 708c71f4f..d1725dddd 100644
--- a/meta-openembedded/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
+++ b/meta-openembedded/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
@@ -8,7 +8,9 @@ inherit autotools
# The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from
# Launchpad until the next release is available from Github.
-SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz"
+SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz \
+ file://0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch \
+ "
SRC_URI[md5sum] = "3a6d54fdd3fe002328e4458206392b9d"
SRC_URI[sha256sum] = "83fa7464193e012c91254e595a89894d8e35b4a38324b52a5974777e3823ea9e"