summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-12-02 21:05:15 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-12-02 21:05:20 +0300
commit996bc45c6b2ab1ef612fa4710088373f1f627ea9 (patch)
tree5a16fa220483d7427ab4cec7612852a3149439dc /meta-openembedded/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
parent2eda1a371b06865fd2d4d84af3de14440e3bafa3 (diff)
downloadopenbmc-996bc45c6b2ab1ef612fa4710088373f1f627ea9.tar.xz
meta-openembedded: subtree update:e4ac09169d..459dbf1078
Alex Kiernan (1): leveldb: Upgrade 1.20 -> 1.22 Cengiz Can (1): recipes-support: gperftools: RDEPENDS for pprof Changqing Li (2): python3-django: upgrade 1.11.14 -> 2.2.7 python-sqlparse/python3-sqlparse: move from meta-cloud-services Christopher Larson (1): kconfig-frontends: drop unneeded target flex/bison deps Daniels Umanovskis (1): gattlib: add recipe Fabio Berton (3): mdbus2: Add recipe jpnevulator: Add recipe emlog: Add recipe Jacopo Dall'Aglio (1): python-netifaces: add recipes Khem Raj (8): packagegroup-meta-oe: Drop gperftools for mips/musl as well python-slip-dbus: Add missing rdep on six module htop: Use python3 pidgin: Use python3 mercurial: Upgrade to 5.2 and switch to py3 a2jmidid: Upgrade to release 9 pidgin: Use python3 during build tvheadend: Demand use of py3 during build Lei YU (1): googletest: Add PV and set to 1.10.0 Leon Anavi (1): stalonetray: Add a simple stand-alone system tray Li Zhou (1): libssh2: Security Advisory - libssh2 - CVE-2019-17498 Michael Haener (1): libmbim: upgrade 1.20.0 -> 1.20.2 Nicola Lunghi (2): python-configargparse: add package (version 0.15.1) python3-dbussy: add recipe (v1.2.1) Qi.Chen@windriver.com (1): python3-pid: upgrade to 2.2.5 Ross Burton (3): glmark2: upgrade to latest HEAD glmark2: use Python 3 to build jack: upgrade to 1.19.14 Ulrich Ölmann (1): python3-yarl: add missing dependencies Zang Ruochen (6): p910nd: upgrade 0.95 -> 0.97 links: upgrade 2.16 -> 2.20.2 links-x11: upgrade 2.16 -> 2.20.2 libmicrohttpd: upgrade 0.9.67 -> 0.9.68 gsoap: upgrade 2.8.51 -> 2.8.95 mksh: upgrade 56 -> 57 Zheng Ruoqin (1): libsdl: Refresh patch zhangxiao (1): syslog-ng: Fix multilib header conflict - syslog-ng-config.h Change-Id: I8557e00b893b61c10ee305fb3229db773b4b894f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb b/meta-openembedded/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
new file mode 100644
index 000000000..0e6fce9c9
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Bluetooth library with attribute support"
+SECTION = "libs/network"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://CMakeLists.txt;beginline=1;endline=20;md5=8d5efeb9189b60866baff80ff791bf00"
+
+DEPENDS = "bluez5 glib-2.0"
+DEPENDS += "glib-2.0-native"
+
+PV = "0.2+git${SRCPV}"
+
+SRC_URI = "git://github.com/labapart/gattlib.git"
+SRC_URI += "file://dbus-avoid-strange-chars-from-the-build-dir.patch"
+
+SRCBRANCH = "master"
+SRCREV = "c6a33252221dff904cf277e085e2ce70aced8788"
+
+S = "${WORKDIR}/git"
+
+PACKAGECONFIG[examples] = "-DGATTLIB_BUILD_EXAMPLES=ON,-DGATTLIB_BUILD_EXAMPLES=OFF"
+
+# Set this to force use of DBus API if Bluez version is older than 5.42
+PACKAGECONFIG[force-dbus] = "-DGATTLIB_FORCE_DBUS=TRUE,-DGATTLIB_FORCE_DBUS=FALSE"
+
+EXTRA_OECMAKE += "-DGATTLIB_BUILD_DOCS=OFF"
+
+inherit pkgconfig cmake
+
+FILES_${PN} = "${libdir}/* ${includedir}/*"
+FILES_${PN}-dev = "${includedir}/*"