summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-connectivity/libqmi
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-16 14:44:26 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-16 14:44:31 +0300
commit7e36d53b0e80af58191fd2680577e6d766af55c7 (patch)
tree44d45604599adc5b9d025802e6a3b527a34f9325 /meta-openembedded/meta-oe/recipes-connectivity/libqmi
parent7ec1d679d1961f22e47bcec8d7e79101edd6a131 (diff)
downloadopenbmc-7e36d53b0e80af58191fd2680577e6d766af55c7.tar.xz
meta-openembedded: subtree update:a2928764c2..19528ba2a6
Adrian Bunk (1): libqmi: Replace clang patch with configure option Bartosz Golaszewski (3): yad: new package zenity: new package unclutter-xfixes: new package Khem Raj (2): mycroft: Remove alsa-oss from rdeps bigbuckbunny: Use faster download mirrors Oleksandr Kravchuk (21): capnproto: update to 0.7.0 ddrescue: update to 1.24 fmt: update to 6.0.0 jsonrpc: update to 1.2.0 libburn: update to 1.5.0 libdvdread: update to 6.0.1 libev: update to 4.27 libmodplug: update to 0.8.9.0 libnice: update to 0.1.16 libopus: update to 1.3.1 libsass: update to 3.6.1 libuv: update to 1.32.0 libsocketcan: update to 0.0.11 tree: update to 1.8.0 xclock: update to 1.0.9 xcursorgen: update to 1.0.7 xfontsel: update to 1.0.6 xmag: update to 1.0.6 xmessage: update to 1.0.5 xorg-sgml-doctools: update to 1.11 evtest: update to 1.34 Peiran Hong (1): tcpdump: Fix CVE-2017-16808 Change-Id: I4f2f575382cd34404d10470ece0aae7620487902 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-connectivity/libqmi')
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi/0001-Detect-clang.patch85
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi_1.22.2.bb2
2 files changed, 1 insertions, 86 deletions
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi/0001-Detect-clang.patch b/meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi/0001-Detect-clang.patch
deleted file mode 100644
index 7a3429b9d..000000000
--- a/meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi/0001-Detect-clang.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From 4cfb728804157e8f3c69e11ba4df449d8f76388f Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 20 Oct 2016 04:42:26 +0000
-Subject: [PATCH] Detect clang
-
-Check for clang compiler since we need to disable
-unused-function warning for clang, at same time
-pass werror when checking for compiler options if
-werror is enabled so spurious options do not get
-enabled. Only the ones that are supported by given
-compiler are accepted.
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Upstream-Status: Pending
-
----
- m4/compiler-warnings.m4 | 29 +++++++++++++++++++++++++----
- 1 file changed, 25 insertions(+), 4 deletions(-)
-
-diff --git a/m4/compiler-warnings.m4 b/m4/compiler-warnings.m4
-index de4a8b0..e4ba718 100644
---- a/m4/compiler-warnings.m4
-+++ b/m4/compiler-warnings.m4
-@@ -2,10 +2,30 @@ AC_DEFUN([LIBQMI_COMPILER_WARNINGS],
- [AC_ARG_ENABLE(more-warnings,
- AS_HELP_STRING([--enable-more-warnings], [Possible values: no/yes/error]),
- set_more_warnings="$enableval",set_more_warnings=error)
-+
-+# Clang throws a lot of warnings when it does not understand a flag. Disable
-+# this warning for now so other warnings are visible.
-+AC_MSG_CHECKING([if compiling with clang])
-+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [[
-+#ifndef __clang__
-+ not clang
-+#endif
-+ ]])],
-+ [CLANG=yes],
-+ [CLANG=no]
-+)
-+AC_MSG_RESULT([$CLANG])
-+AS_IF([test "x$CLANG" = "xyes"], [CLANG_FLAGS=-Wno-error=unused-function])
-+CFLAGS="$CFLAGS $CLANG_FLAGS"
-+LDFLAGS="$LDFLAGS $CLANG_FLAGS"
-+
- AC_MSG_CHECKING(for more warnings)
- if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
- AC_MSG_RESULT(yes)
- CFLAGS="-Wall -std=gnu89 $CFLAGS"
-+ if test "x$set_more_warnings" = xerror; then
-+ WERROR="-Werror"
-+ fi
-
- for option in -Wmissing-declarations -Wmissing-prototypes \
- -Wdeclaration-after-statement -Wstrict-prototypes \
-@@ -17,22 +37,23 @@ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
- -Wmissing-include-dirs -Waggregate-return \
- -Wformat-security -Wtype-limits; do
- SAVE_CFLAGS="$CFLAGS"
-- CFLAGS="$CFLAGS $option"
-+ CFLAGS="$CFLAGS $option $WERROR"
- AC_MSG_CHECKING([whether gcc understands $option])
- AC_TRY_COMPILE([], [],
- has_option=yes,
- has_option=no,)
- if test $has_option = no; then
- CFLAGS="$SAVE_CFLAGS"
-+ else
-+ CFLAGS="$SAVE_CFLAGS $option"
- fi
- AC_MSG_RESULT($has_option)
- unset has_option
- unset SAVE_CFLAGS
- done
-+ CFLAGS="$CFLAGS $WERROR"
- unset option
-- if test "x$set_more_warnings" = xerror; then
-- CFLAGS="$CFLAGS -Werror"
-- fi
-+ unset WERROR
- else
- AC_MSG_RESULT(no)
- fi
---
-1.9.1
-
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi_1.22.2.bb b/meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi_1.22.2.bb
index da13286b4..3b2fe51bb 100644
--- a/meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi_1.22.2.bb
+++ b/meta-openembedded/meta-oe/recipes-connectivity/libqmi/libqmi_1.22.2.bb
@@ -12,7 +12,6 @@ DEPENDS = "glib-2.0 glib-2.0-native"
inherit autotools pkgconfig bash-completion
SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BPN}-${PV}.tar.xz \
- file://0001-Detect-clang.patch \
"
SRC_URI[md5sum] = "3fd831c1b0de4a4432be628432a960ff"
SRC_URI[sha256sum] = "f1f1e514a89b1dcba05cf7274895e7301a2da4c947b7c2f17acb84fc74038227"
@@ -21,3 +20,4 @@ PACKAGECONFIG ??= "udev mbim"
PACKAGECONFIG[udev] = ",--without-udev,libgudev"
PACKAGECONFIG[mbim] = "--enable-mbim-qmux,--disable-mbim-qmux,libmbim"
+EXTRA_OECONF_append_toolchain-clang = " --enable-more-warnings=no"