summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_3.2.0.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-18 13:27:43 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-18 13:36:02 +0300
commitb809eb9d31058aad51fb82ff321a6bef45b23e58 (patch)
tree79e830e2b140780b96250c595592e1172bf31869 /meta-openembedded/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_3.2.0.bb
parent85521d71312d95503e78e3470267cbd4d7a6ecfa (diff)
downloadopenbmc-b809eb9d31058aad51fb82ff321a6bef45b23e58.tar.xz
meta-openembedded: subtree update:19528ba2a6..ef1b17f4ef
Callaghan, Dan (1): lmsensors: add a PACKAGECONFIG for sensord Changqing Li (1): ntp: fix package split wrongly when enabled usrmerge Khem Raj (1): remove spurious file Nathan Rossi (3): libeigen: Add native and nativesdk to BBCLASSEXTEND python*-pyusb: Add native and nativesdk to BBCLASSEXTEND python*-pyserial: Add native and nativesdk to BBCLASSEXTEND Oleksandr Kravchuk (23): babl: update to 0.1.62 znc: update to 1.7.4 zlog: update to 1.2.14 wipe: update to 0.24 upower: update to 0.99.11 python-pyobject: update to 3.34.0 python-pytoml: update to 0.1.21 python-cpuset: update to 1.6 libwebsockets: update to 3.2.0 libvpx: update to 1.8.1 libvdpau: update to 1.3 libmicrohttpd: update to 0.9.66 lcms: update to 2.9 libblockdev: update to 2.23 libbytesize: update to 2.1 iwd: update to 0.20 gsl: update to 2.6 gflags: update to 2.2.2 digitemp: update to 3.7.2 catch2: update to 2.9.2 botan: update to 2.11.0 agent-proxy: update to 1.97 ceres-solver: fix package version Paul Eggleton (1): mosquitto: update to 1.6.5 Scott Ellis (1): wireguard: Upgrade 20190905 to 20190913 Trevor Gamblin (1): openjpeg: upgrade 2.3.0 -> 2.3.1 Yi Zhao (1): samba: upgrade 4.10.7 -> 4.10.8 Zang Ruochen (2): python-dbus: upgrade 1.2.10 -> 1.2.12 python-pluggy: upgrade 0.12.0 -> 0.13.0 Zheng Ruoqin (1): xrdp: 0.9.4 -> 0.9.11 Change-Id: I3152060569cc5af7f7950c7037f25f54191d20a9 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_3.2.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_3.2.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_3.2.0.bb b/meta-openembedded/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_3.2.0.bb
new file mode 100644
index 000000000..9c5503357
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_3.2.0.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Canonical libwebsockets.org websocket library"
+HOMEPAGE = "https://libwebsockets.org/"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ce87f3facb6f911c142c8bef9bfb380"
+
+DEPENDS = "zlib"
+
+S = "${WORKDIR}/git"
+SRCREV = "94931cad003faf9d316e698b557bbb6d245f1f91"
+SRC_URI = "git://github.com/warmcat/libwebsockets.git;protocol=https;branch=v3.2-stable"
+
+inherit cmake pkgconfig
+
+PACKAGECONFIG ?= "libuv client server http2 ssl"
+PACKAGECONFIG[client] = "-DLWS_WITHOUT_CLIENT=OFF,-DLWS_WITHOUT_CLIENT=ON,"
+PACKAGECONFIG[http2] = "-DLWS_WITH_HTTP2=ON,-DLWS_WITH_HTTP2=OFF,"
+PACKAGECONFIG[ipv6] = "-DLWS_IPV6=ON,-DLWS_IPV6=OFF,"
+PACKAGECONFIG[libev] = "-DLWS_WITH_LIBEV=ON,-DLWS_WITH_LIBEV=OFF,libev"
+PACKAGECONFIG[libuv] = "-DLWS_WITH_LIBUV=ON,-DLWS_WITH_LIBUV=OFF,libuv"
+PACKAGECONFIG[server] = "-DLWS_WITHOUT_SERVER=OFF,-DLWS_WITHOUT_SERVER=ON,"
+PACKAGECONFIG[ssl] = "-DLWS_WITH_SSL=ON,-DLWS_WITH_SSL=OFF,openssl"
+PACKAGECONFIG[testapps] = "-DLWS_WITHOUT_TESTAPPS=OFF,-DLWS_WITHOUT_TESTAPPS=ON,"
+
+EXTRA_OECMAKE += " \
+ -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
+"
+
+PACKAGES =+ "${PN}-testapps"
+
+FILES_${PN}-testapps += "${datadir}/libwebsockets-test-server/*"
+
+CFLAGS_append = " -Wno-error"