summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.11.0.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-18 13:27:43 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-18 13:36:02 +0300
commitb809eb9d31058aad51fb82ff321a6bef45b23e58 (patch)
tree79e830e2b140780b96250c595592e1172bf31869 /meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.11.0.bb
parent85521d71312d95503e78e3470267cbd4d7a6ecfa (diff)
downloadopenbmc-b809eb9d31058aad51fb82ff321a6bef45b23e58.tar.xz
meta-openembedded: subtree update:19528ba2a6..ef1b17f4ef
Callaghan, Dan (1): lmsensors: add a PACKAGECONFIG for sensord Changqing Li (1): ntp: fix package split wrongly when enabled usrmerge Khem Raj (1): remove spurious file Nathan Rossi (3): libeigen: Add native and nativesdk to BBCLASSEXTEND python*-pyusb: Add native and nativesdk to BBCLASSEXTEND python*-pyserial: Add native and nativesdk to BBCLASSEXTEND Oleksandr Kravchuk (23): babl: update to 0.1.62 znc: update to 1.7.4 zlog: update to 1.2.14 wipe: update to 0.24 upower: update to 0.99.11 python-pyobject: update to 3.34.0 python-pytoml: update to 0.1.21 python-cpuset: update to 1.6 libwebsockets: update to 3.2.0 libvpx: update to 1.8.1 libvdpau: update to 1.3 libmicrohttpd: update to 0.9.66 lcms: update to 2.9 libblockdev: update to 2.23 libbytesize: update to 2.1 iwd: update to 0.20 gsl: update to 2.6 gflags: update to 2.2.2 digitemp: update to 3.7.2 catch2: update to 2.9.2 botan: update to 2.11.0 agent-proxy: update to 1.97 ceres-solver: fix package version Paul Eggleton (1): mosquitto: update to 1.6.5 Scott Ellis (1): wireguard: Upgrade 20190905 to 20190913 Trevor Gamblin (1): openjpeg: upgrade 2.3.0 -> 2.3.1 Yi Zhao (1): samba: upgrade 4.10.7 -> 4.10.8 Zang Ruochen (2): python-dbus: upgrade 1.2.10 -> 1.2.12 python-pluggy: upgrade 0.12.0 -> 0.13.0 Zheng Ruoqin (1): xrdp: 0.9.4 -> 0.9.11 Change-Id: I3152060569cc5af7f7950c7037f25f54191d20a9 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.11.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.11.0.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.11.0.bb b/meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.11.0.bb
new file mode 100644
index 000000000..c2d644b41
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-crypto/botan/botan_2.11.0.bb
@@ -0,0 +1,50 @@
+SUMMARY = "Crypto and TLS for C++11"
+HOMEPAGE = "https://botan.randombit.net"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://license.txt;md5=f4c145d4d70a3244a053c9f90d4841fc"
+SECTION = "libs"
+
+SRC_URI = "https://botan.randombit.net/releases/Botan-${PV}.tar.xz"
+SRC_URI[md5sum] = "2dba13b0d25d0e9d2a6f9867c62c9f2e"
+SRC_URI[sha256sum] = "f7874da2aeb8c018fd77df40b2137879bf90b66f5589490c991e83fb3e8094be"
+
+S = "${WORKDIR}/Botan-${PV}"
+
+inherit python3native siteinfo lib_package
+
+CPU ?= "${TARGET_ARCH}"
+CPU_x86 = "x86_32"
+CPU_armv7a = "armv7"
+CPU_armv7ve = "armv7"
+
+do_configure() {
+ python3 ${S}/configure.py \
+ --prefix="${D}${prefix}" \
+ --cpu="${CPU}" \
+ --cc-bin="${CXX}" \
+ --cxxflags="${CXXFLAGS}" \
+ --ldflags="${LDFLAGS}" \
+ --with-endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
+ ${@bb.utils.contains("TUNE_FEATURES","neon","","--disable-neon",d)} \
+ --with-sysroot-dir=${STAGING_DIR_TARGET} \
+ --with-build-dir="${B}" \
+ --optimize-for-size \
+ --with-stack-protector \
+ --enable-shared-library \
+ --with-python-versions=3 \
+ ${EXTRA_OECONF}
+}
+
+do_compile() {
+ oe_runmake
+}
+do_install() {
+ oe_runmake install
+ sed -i -e "s|${D}||g" ${D}${libdir}/pkgconfig/botan-2.pc
+}
+
+PACKAGES += "${PN}-python3"
+
+FILES_${PN}-python3 = "${libdir}/python3"
+
+RDEPENDS_${PN}-python3 += "python3"