summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-crypto
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-20 13:15:02 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-20 13:15:14 +0300
commit23eaf03b3fff4acf8a79d082a85024bda6690436 (patch)
tree01b23dee8d55aea42b0fd9000c5ea0d32f5bd155 /meta-openembedded/meta-oe/recipes-crypto
parentfb62a68f16d3fa64b242bd8c65abf64ef8088889 (diff)
downloadopenbmc-23eaf03b3fff4acf8a79d082a85024bda6690436.tar.xz
meta-openembedded: subtree update:55de2d06ad..53d431639a
Adrian Bunk (1): ltrace: Remove RDEPENDS on elfutils Andreas Müller (22): gedit: upgrade 2.30.4 -> 3.34.0 gtksourceview2: remove evolution-data-server: give up fine grained -dev/-dbg packages evolution-data-server: upgrade 3.26.6 -> 3.34.1 and rework gnome-font-viewer: initial add 3.34.0 evince: upgrade 3.28.2 -> 3.34.1 file-roller: inital add 3.32.2 gexiv2: initial add 0.12.0 gnome-autoar: inital add 0.2.3 tracker: initial add 2.3.1 nautilus: upgrade 3.18.5 -> 3.34.1 geocode-glib: initial add 3.26.1 libgweather: initial add 3.34.0 libwacom: initial add 0.33 gnome-settings-daemon: initial add 3.34.1 fluidsynth: upgrade 2.0.7 -> 2.0.9 gnome-terminal: re-add 3.34.2 gnome-terminal: Fix build for musl gmime: cleanup recipe gmime: move to meta-oe/recipes-gnome gmime: upgrade 3.2.4 -> 3.2.5 evolution-data-server: add upstream-version-is-even & gsettings to inherit Bartosz Golaszewski (1): libgpiod: put gpio utils into an actual separate package Gaylord Charles (1): nginx: fix install paths Khem Raj (11): evince: Fix build with clang poppler: Extend the c/c++ flags fix to cover clang pidgin-sipe: Fix another case of struct incompatiblility due to 64bit time_t gperftools: Convert static and libunwind support to packageconfig libmad: Define O2 for all arches as default optimization rsyslog: Dont force enable atomic builtins on mips libtorrent: Drop 64bit atomics patch for mips/ppc libtorrent: Disable instrumentation on ppc/mips libkcapi: Move static inline functions where used grpc: Link with libatomic on clang/x86 upm: Link with libatomic on clang/x86 Leon Anavi (1): surf: Add a simple web browser Martin Balik (1): squid: upgrade 4.6 -> 4.9 Nicola Lunghi (2): python-jsonschema: multiple fixes python-jsonschema: add PACKAGECONFIG nongpl option Oleksandr Kravchuk (1): flatbuffers: update to 1.11.0 Peter Kjellerstedt (1): libldb: Do not require the "pam" distro feature to be enabled nick83ola (2): python3-apply-defaults: add recipe python3-jsonrpcserver: add recipe Change-Id: I231fc015cba86b7c14915ffc3f6f123c9296fd68 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-crypto')
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch71
-rw-r--r--meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb1
2 files changed, 72 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch
new file mode 100644
index 000000000..3dd7ea7f9
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-kcapi-kdf-Move-code-to-fix.patch
@@ -0,0 +1,71 @@
+From 00c1654e368f728b213c4e3782045d54098edb25 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 16 Nov 2019 23:03:51 -0800
+Subject: [PATCH] kcapi-kdf: Move code to fix
+
+Fixes clang build
+unused function '_bswap32' [-Werror,-Wunused-function]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ lib/kcapi-kdf.c | 36 ++++++++++++++++--------------------
+ 1 file changed, 16 insertions(+), 20 deletions(-)
+
+diff --git a/lib/kcapi-kdf.c b/lib/kcapi-kdf.c
+index ea39846..8e4a636 100644
+--- a/lib/kcapi-kdf.c
++++ b/lib/kcapi-kdf.c
+@@ -54,6 +54,20 @@
+ #include "kcapi.h"
+ #include "internal.h"
+
++#define GCC_VERSION (__GNUC__ * 10000 \
++ + __GNUC_MINOR__ * 100 \
++ + __GNUC_PATCHLEVEL__)
++#if GCC_VERSION >= 40400
++# define __HAVE_BUILTIN_BSWAP32__
++#endif
++
++#ifdef __HAVE_BUILTIN_BSWAP32__
++# define be_bswap32(x) (uint32_t)__builtin_bswap32((uint32_t)(x))
++/* Endian dependent byte swap operations. */
++#elif __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
++# define be_bswap32(x) ((uint32_t)(x))
++#elif __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
++
+ static inline uint32_t rol32(uint32_t x, int n)
+ {
+ return ( (x << (n&(32-1))) | (x >> ((32-n)&(32-1))) );
+@@ -68,27 +82,9 @@ static inline uint32_t _bswap32(uint32_t x)
+ {
+ return ((rol32(x, 8) & 0x00ff00ffL) | (ror32(x, 8) & 0xff00ff00L));
+ }
+-
+-#define GCC_VERSION (__GNUC__ * 10000 \
+- + __GNUC_MINOR__ * 100 \
+- + __GNUC_PATCHLEVEL__)
+-#if GCC_VERSION >= 40400
+-# define __HAVE_BUILTIN_BSWAP32__
+-#endif
+-
+-#ifdef __HAVE_BUILTIN_BSWAP32__
+-# define _swap32(x) (uint32_t)__builtin_bswap32((uint32_t)(x))
+-#else
+-# define _swap32(x) _bswap32(x)
+-#endif
+-
+-/* Endian dependent byte swap operations. */
+-#if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
+-# define be_bswap32(x) ((uint32_t)(x))
+-#elif __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
+-# define be_bswap32(x) _swap32(x)
++# define be_bswap32(x) _bswap32(x)
+ #else
+-#error "Endianess not defined"
++# error "Neither builtin_bswap32 nor endianess defined"
+ #endif
+
+ DSO_PUBLIC
+--
+2.24.0
+
diff --git a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
index 799070972..aa438e585 100644
--- a/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
+++ b/meta-openembedded/meta-oe/recipes-crypto/libkcapi/libkcapi_git.bb
@@ -10,6 +10,7 @@ SRCREV = "5649050d201856bf06c8738b5d2aa1710c86ac2f"
PV = "1.1.5"
SRC_URI = " \
git://github.com/smuellerDD/libkcapi.git \
+ file://0001-kcapi-kdf-Move-code-to-fix.patch \
"
inherit autotools