summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools/boost-url/boost-url_git.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@intel.com>2022-01-06 23:59:39 +0300
committerJason M. Bills <jason.m.bills@intel.com>2022-01-06 23:59:39 +0300
commit32777eec25d2c527a62e5ffab90a3dfef35855aa (patch)
tree588a90a6fe9fb0b35c7ce23ea3bd79fa5151ccde /meta-openembedded/meta-oe/recipes-devtools/boost-url/boost-url_git.bb
parent61f1ca1b31a9a1108e9e7f71e47fdc19beb0490b (diff)
parent5cc2f81c5b66da00cad24e18b0d23442af060c3f (diff)
downloadopenbmc-32777eec25d2c527a62e5ffab90a3dfef35855aa.tar.xz
Merge tag '0.86' of firmware.bmc.openbmc.yocto.openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools/boost-url/boost-url_git.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/boost-url/boost-url_git.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/boost-url/boost-url_git.bb b/meta-openembedded/meta-oe/recipes-devtools/boost-url/boost-url_git.bb
index cb3664fe3..9f759100b 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/boost-url/boost-url_git.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/boost-url/boost-url_git.bb
@@ -4,16 +4,17 @@ SECTION = "libs"
LICENSE = "BSL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
-SRC_URI = "git://github.com/CPPAlliance/url.git;branch=develop \
- file://0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch \
- "
+SRC_URI = "git://github.com/CPPAlliance/url.git;branch=develop"
-SRCREV = "2c867fbe284ae532f1329b87a86ad3f8cd382867"
+SRCREV = "4f712ed69a04a344957d22efa5dc111b415b3aff"
S = "${WORKDIR}/git"
-inherit cmake
-
DEPENDS = "boost"
BBCLASSEXTEND = "native nativesdk"
+
+do_install() {
+ mkdir -p ${D}/${includedir}
+ cp -r ${S}/include/** ${D}/${includedir}/
+}