summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-07 21:58:51 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-01 20:14:20 +0300
commit757e94a3dfd7ec792c01e3ecee295ea987955f5a (patch)
tree72fd9de1db26f666b0138c39fa150d8b8b0e8f07 /meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb
parent4a2471930c63da38cbea2270a313f1610274f7ba (diff)
downloadopenbmc-757e94a3dfd7ec792c01e3ecee295ea987955f5a.tar.xz
meta-openembedded: sumo refresh be79b8b111..2bb21ef27c
Update meta-openembedded to sumo HEAD. Armin Kuster (1): grpc: move it from oe to networking layer Khem Raj (2): gedit: Add dep on python-six-native poppler: Update to 0.64 Martin Jansa (2): libqb: Fix build with gold openocd: prevent fetching git submodules during do_configure Nicolas Dechesne (1): meta-multimedia: fixup LAYERDEPENDS Paul Eggleton (1): protobuf: make python-protobuf dependency optional and default to off Sinan Kaya (1): dnsmasq: CVE-2017-15107 Takuro Ashie (1): uim: Fix SRC_URI Change-Id: I611fc4019b8a7fcbcaf2bcca40d7e35a650e5120 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb26
1 files changed, 17 insertions, 9 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb
index 20bc663f9..1a15e53b8 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb
@@ -4,14 +4,22 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "libusb-compat libftdi"
RDEPENDS_${PN} = "libusb1"
-SRC_URI = "git://repo.or.cz/openocd.git \
- file://0001-Add-fallthrough-comments.patch \
- file://0002-Workaround-new-warnings-generated-by-GCC-7.patch \
- file://0003-armv7a-Add-missing-break-to-fix-fallthrough-warning.patch \
- file://0004-Fix-overflow-warning.patch \
- file://0005-command-Move-the-fall-through-comment-to-right-scope.patch \
+SRC_URI = " \
+ git://repo.or.cz/openocd.git;protocol=http;name=openocd \
+ git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \
+ git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \
+ git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
+ file://0001-Add-fallthrough-comments.patch \
+ file://0002-Workaround-new-warnings-generated-by-GCC-7.patch \
+ file://0003-armv7a-Add-missing-break-to-fix-fallthrough-warning.patch \
+ file://0004-Fix-overflow-warning.patch \
+ file://0005-command-Move-the-fall-through-comment-to-right-scope.patch \
"
-SRCREV = "1025be363e2bf42f1613083223a2322cc3a9bd4c"
+SRCREV_FORMAT = "openocd"
+SRCREV_openocd = "1025be363e2bf42f1613083223a2322cc3a9bd4c"
+SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba"
+SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787"
+SRCREV_libjaylink = "699b7001d34a79c8e7064503dde1bede786fd7f0"
PV = "0.10+gitr${SRCPV}"
S = "${WORKDIR}/git"
@@ -20,10 +28,10 @@ inherit pkgconfig autotools-brokensep gettext
BBCLASSEXTEND += "nativesdk"
-EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html "
+EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html"
do_configure() {
- ./bootstrap
+ ./bootstrap nosubmodule
oe_runconf ${EXTRA_OECONF}
}