summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-20 13:15:02 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-20 13:15:14 +0300
commit23eaf03b3fff4acf8a79d082a85024bda6690436 (patch)
tree01b23dee8d55aea42b0fd9000c5ea0d32f5bd155 /meta-openembedded/meta-oe/recipes-devtools
parentfb62a68f16d3fa64b242bd8c65abf64ef8088889 (diff)
downloadopenbmc-23eaf03b3fff4acf8a79d082a85024bda6690436.tar.xz
meta-openembedded: subtree update:55de2d06ad..53d431639a
Adrian Bunk (1): ltrace: Remove RDEPENDS on elfutils Andreas Müller (22): gedit: upgrade 2.30.4 -> 3.34.0 gtksourceview2: remove evolution-data-server: give up fine grained -dev/-dbg packages evolution-data-server: upgrade 3.26.6 -> 3.34.1 and rework gnome-font-viewer: initial add 3.34.0 evince: upgrade 3.28.2 -> 3.34.1 file-roller: inital add 3.32.2 gexiv2: initial add 0.12.0 gnome-autoar: inital add 0.2.3 tracker: initial add 2.3.1 nautilus: upgrade 3.18.5 -> 3.34.1 geocode-glib: initial add 3.26.1 libgweather: initial add 3.34.0 libwacom: initial add 0.33 gnome-settings-daemon: initial add 3.34.1 fluidsynth: upgrade 2.0.7 -> 2.0.9 gnome-terminal: re-add 3.34.2 gnome-terminal: Fix build for musl gmime: cleanup recipe gmime: move to meta-oe/recipes-gnome gmime: upgrade 3.2.4 -> 3.2.5 evolution-data-server: add upstream-version-is-even & gsettings to inherit Bartosz Golaszewski (1): libgpiod: put gpio utils into an actual separate package Gaylord Charles (1): nginx: fix install paths Khem Raj (11): evince: Fix build with clang poppler: Extend the c/c++ flags fix to cover clang pidgin-sipe: Fix another case of struct incompatiblility due to 64bit time_t gperftools: Convert static and libunwind support to packageconfig libmad: Define O2 for all arches as default optimization rsyslog: Dont force enable atomic builtins on mips libtorrent: Drop 64bit atomics patch for mips/ppc libtorrent: Disable instrumentation on ppc/mips libkcapi: Move static inline functions where used grpc: Link with libatomic on clang/x86 upm: Link with libatomic on clang/x86 Leon Anavi (1): surf: Add a simple web browser Martin Balik (1): squid: upgrade 4.6 -> 4.9 Nicola Lunghi (2): python-jsonschema: multiple fixes python-jsonschema: add PACKAGECONFIG nongpl option Oleksandr Kravchuk (1): flatbuffers: update to 1.11.0 Peter Kjellerstedt (1): libldb: Do not require the "pam" distro feature to be enabled nick83ola (2): python3-apply-defaults: add recipe python3-jsonrpcserver: add recipe Change-Id: I231fc015cba86b7c14915ffc3f6f123c9296fd68 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/flatbuffers/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch38
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.11.0.bb (renamed from meta-openembedded/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.10.0.bb)6
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/ltrace/ltrace_git.bb1
3 files changed, 42 insertions, 3 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/flatbuffers/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch b/meta-openembedded/meta-oe/recipes-devtools/flatbuffers/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch
new file mode 100644
index 000000000..f3e82101b
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/flatbuffers/flatbuffers/0001-Add-detection-of-strtoull_l-function.patch
@@ -0,0 +1,38 @@
+From bff7ffbc5130cd46caf33b76b4bb0593fcd15066 Mon Sep 17 00:00:00 2001
+From: Vladimir Glavnyy <31897320+vglavnyy@users.noreply.github.com>
+Date: Fri, 10 May 2019 00:15:29 +0700
+Subject: [PATCH] Add detection of strtoull_l function (#5333) (#5337)
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Retrieved from:
+https://github.com/google/flatbuffers/commit/bff7ffbc5130cd46caf33b76b4bb0593fcd15066]
+---
+ CMakeLists.txt | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0640c37b5..30be238fe 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -42,12 +42,18 @@ if(DEFINED FLATBUFFERS_MAX_PARSING_DEPTH)
+ message(STATUS "FLATBUFFERS_MAX_PARSING_DEPTH: ${FLATBUFFERS_MAX_PARSING_DEPTH}")
+ endif()
+
+-# Auto-detect locale-narrow 'strtod_l' function.
++# Auto-detect locale-narrow 'strtod_l' and 'strtoull_l' functions.
+ if(NOT DEFINED FLATBUFFERS_LOCALE_INDEPENDENT)
++ set(FLATBUFFERS_LOCALE_INDEPENDENT 0)
+ if(MSVC)
+- check_cxx_symbol_exists(_strtof_l stdlib.h FLATBUFFERS_LOCALE_INDEPENDENT)
++ check_cxx_symbol_exists(_strtof_l stdlib.h FLATBUFFERS_HAS_STRTOF_L)
++ check_cxx_symbol_exists(_strtoui64_l stdlib.h FLATBUFFERS_HAS_STRTOULL_L)
+ else()
+- check_cxx_symbol_exists(strtof_l stdlib.h FLATBUFFERS_LOCALE_INDEPENDENT)
++ check_cxx_symbol_exists(strtof_l stdlib.h FLATBUFFERS_HAS_STRTOF_L)
++ check_cxx_symbol_exists(strtoull_l stdlib.h FLATBUFFERS_HAS_STRTOULL_L)
++ endif()
++ if(FLATBUFFERS_HAS_STRTOF_L AND FLATBUFFERS_HAS_STRTOULL_L)
++ set(FLATBUFFERS_LOCALE_INDEPENDENT 1)
+ endif()
+ endif()
+ add_definitions(-DFLATBUFFERS_LOCALE_INDEPENDENT=$<BOOL:${FLATBUFFERS_LOCALE_INDEPENDENT}>)
diff --git a/meta-openembedded/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.10.0.bb b/meta-openembedded/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.11.0.bb
index 452e1e65a..bd6dcef4e 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.10.0.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.11.0.bb
@@ -10,9 +10,11 @@ RDEPENDS_${PN}-dev += "${PN}-compiler"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a873c5645c184d51e0f9b34e1d7cf559"
-SRCREV = "c0698cc33f1e534bb59c455909b88cc2726089af"
+SRCREV = "9e7e8cbe9f675123dd41b7c62868acad39188cae"
-SRC_URI = "git://github.com/google/flatbuffers.git"
+SRC_URI = "git://github.com/google/flatbuffers.git \
+ file://0001-Add-detection-of-strtoull_l-function.patch \
+ "
# Make sure C++11 is used, required for example for GCC 4.9
CXXFLAGS += "-std=c++11"
diff --git a/meta-openembedded/meta-oe/recipes-devtools/ltrace/ltrace_git.bb b/meta-openembedded/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
index 5c4e7c5b8..bb21cbca8 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
@@ -14,7 +14,6 @@ PV = "7.91+git${SRCPV}"
SRCREV = "c22d359433b333937ee3d803450dc41998115685"
DEPENDS = "elfutils"
-RDEPENDS_${PN} = "elfutils"
SRC_URI = "git://github.com/sparkleholic/ltrace.git;branch=master;protocol=http \
file://configure-allow-to-disable-selinux-support.patch \
file://0001-replace-readdir_r-with-readdir.patch \