summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.1.2.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.1.2.bb
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.1.2.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.1.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.1.2.bb b/meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.1.2.bb
new file mode 100644
index 000000000..e23733b0f
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.1.2.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "C++ client for Redis based on hiredis"
+HOMEPAGE = "https://github.com/sewenew/redis-plus-plus"
+SECTION = "libs"
+
+DEPENDS += "hiredis"
+RDEPENDS_${PN} += "hiredis"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+SRCREV = "b08b36a9a91de00636e583307610f49af7876f50"
+SRC_URI = "git://github.com/sewenew/redis-plus-plus"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES_SOLIBSDEV = ""
+FILES_${PN} += " ${libdir}/libredis++.so"