summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-27 15:23:48 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-27 15:23:52 +0300
commit779d0acafa041a9df8ff46c614778538ab68acbd (patch)
tree39df5c7c2c0040c667131b35e01fa2e674cb78e7 /meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
parent9856fce4c853303bacbe5464a24759daeeb34684 (diff)
downloadopenbmc-779d0acafa041a9df8ff46c614778538ab68acbd.tar.xz
meta-openembedded: subtree update:466fd78ac6..41fe46157c
Callaghan, Dan (2): firewalld: add UPSTREAM_CHECK_URI add new recipes for python-lrparsing, python3-lrparsing Khem Raj (2): mongodb: Remove non building arches from COMPATIBLE_HOST uim: Fix cross-builds Martin Jansa (1): libmicrohttpd: backport the fix for building with older gnutls Oleksandr Kravchuk (4): libyui: update to 3.6.0 libyui-ncurses: udpate to 2.52.0 sanlock: update to 3.6.0 tesseract-lang: update to 4.0.0 Randy MacLeod (1): crash: update from 7.2.6 to 7.2.7 Robert Yang (8): python-asn1crypto: extend to nativesdk python-incremental: Drop broken nativesdk fuse: Fix installed-vs-shipped for nativesdk keyutils: Fix installed-vs-shipped for nativesdk libnet-ssleay-perl: Drop broken native libnet-dns-sec-perl: Drop broken native iperf3: Drop broken native spice: Drop broken native Trevor Gamblin (1): haveged: upgrade v1.9.4 -> v1.9.6 Zang Ruochen (5): xterm: upgrade 348 -> 349 python-cmd2: upgrade 0.9.16 -> 0.9.17 python-protobuf: upgrade 3.9.1 -> 3.9.2 python-alembic: upgrade 1.2.0 -> 1.2.1 python-paste: upgrade 3.2.0 -> 3.2.1 Change-Id: I4491ea47f5e54f4f3843a77c720d0a89304c36a5 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb b/meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
new file mode 100644
index 000000000..9f7ce9c57
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/sanlock/sanlock_3.8.0.bb
@@ -0,0 +1,34 @@
+SUMMARY = "A shared storage lock manager"
+DESCRIPTION = "sanlock is a lock manager built on shared storage. Hosts with access \
+to the storage can perform locking. An application running on the \
+hosts is given a small amount of space on the shared block device or \
+file, and uses sanlock for its own application-specific synchronization. \
+Internally, the sanlock daemon manages locks using two disk-based \
+lease algorithms: delta leases and paxos leases."
+HOMEPAGE = "https://pagure.io/sanlock"
+SECTION = "utils"
+
+LICENSE = "LGPLv2+ & GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://README.license;md5=60487bf0bf429d6b5aa72b6d37a0eb22"
+
+SRC_URI = "git://pagure.io/sanlock.git;protocol=http"
+SRCREV = "7afe0e66f5c7f24894896fad20ffa6f39733d80f"
+S = "${WORKDIR}/git"
+
+DEPENDS = "libaio util-linux"
+
+inherit distutils
+
+do_configure[noexec] = "1"
+
+do_compile_prepend () {
+ oe_runmake -C wdmd CMD_LDFLAGS="${LDFLAGS}" LIB_LDFLAGS="${LDFLAGS}"
+ oe_runmake -C src CMD_LDFLAGS="${LDFLAGS}" LIB_ENTIRE_LDFLAGS="${LDFLAGS}" LIB_CLIENT_LDFLAGS="${LDFLAGS}"
+ cd ${S}/python
+}
+
+do_install_prepend () {
+ oe_runmake -C wdmd DESTDIR=${D} LIBDIR=${libdir} install
+ oe_runmake -C src DESTDIR=${D} LIBDIR=${libdir} install
+ cd ${S}/python
+}