summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended/sysdig
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-10-04 22:42:48 +0300
committerGitHub <noreply@github.com>2021-10-04 22:42:48 +0300
commit0c9e31989c615598b5d042ffab385606660c93c0 (patch)
tree8019999b0ca042482e5193d6cabc06220c71d776 /meta-openembedded/meta-oe/recipes-extended/sysdig
parent04cd92067d2481643df5010cb39b2134b648cf4d (diff)
parentffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (diff)
downloadopenbmc-0c9e31989c615598b5d042ffab385606660c93c0.tar.xz
Merge pull request #72 from Intel-BMC/update2021-0.751-0.75
Update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/sysdig')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/sysdig/sysdig_git.bb28
1 files changed, 14 insertions, 14 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/sysdig/sysdig_git.bb b/meta-openembedded/meta-oe/recipes-extended/sysdig/sysdig_git.bb
index a626e3b20..a12f8ba5e 100644
--- a/meta-openembedded/meta-oe/recipes-extended/sysdig/sysdig_git.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/sysdig/sysdig_git.bb
@@ -10,16 +10,16 @@ inherit cmake pkgconfig
#OECMAKE_GENERATOR = "Unix Makefiles"
JIT ?= "jit"
-JIT_mipsarchn32 = ""
-JIT_mipsarchn64 = ""
-JIT_riscv64 = ""
-JIT_riscv32 = ""
-JIT_powerpc = ""
-JIT_powerpc64le = ""
-JIT_powerpc64 = ""
+JIT:mipsarchn32 = ""
+JIT:mipsarchn64 = ""
+JIT:riscv64 = ""
+JIT:riscv32 = ""
+JIT:powerpc = ""
+JIT:powerpc64le = ""
+JIT:powerpc64 = ""
DEPENDS += "libb64 lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp tbb jq openssl elfutils protobuf protobuf-native jq-native"
-RDEPENDS_${PN} = "bash"
+RDEPENDS:${PN} = "bash"
SRC_URI = "git://github.com/draios/sysdig.git;branch=dev \
file://0001-fix-build-with-LuaJIT-2.1-betas.patch \
@@ -39,7 +39,7 @@ EXTRA_OECMAKE = "\
-DLUA_LIBRARY=libluajit-5.1.so \
"
-FILES_${PN} += " \
+FILES:${PN} += " \
${DIR_ETC}/* \
${datadir}/zsh/* \
${prefix}/src/* \
@@ -48,8 +48,8 @@ FILES_${PN} += " \
# It should be fixed in sysdig, until then disable
# on musl
# Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it
-COMPATIBLE_HOST_libc-musl = "null"
-COMPATIBLE_HOST_mips = "null"
-COMPATIBLE_HOST_riscv64 = "null"
-COMPATIBLE_HOST_riscv32 = "null"
-COMPATIBLE_HOST_powerpc = "null"
+COMPATIBLE_HOST:libc-musl = "null"
+COMPATIBLE_HOST:mips = "null"
+COMPATIBLE_HOST:riscv64 = "null"
+COMPATIBLE_HOST:riscv32 = "null"
+COMPATIBLE_HOST:powerpc = "null"