summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-21 15:07:33 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-21 15:07:37 +0300
commitba6de43c25453413491a8bac2d6f7f7011c9b326 (patch)
tree566a4990318c50f8b73e7cf43012eb1705e82d09 /meta-openembedded/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb
parent0e04b2e9b4857f65a89e16d3c14e16166b2cd8ea (diff)
downloadopenbmc-ba6de43c25453413491a8bac2d6f7f7011c9b326.tar.xz
meta-openembedded: subtree update:1ecd8b4364..f3018013ff
Adrian Bunk (1): Add irda-utils Khem Raj (1): openocd: Upgrade to latest git version Martin Jansa (8): gtkwave: add distro_features_check ndctl: make MACHINE_ARCH and ignore from libblockdev oprofile: make MACHINE_ARCH umip: make MACHINE_ARCH mscgen: fix SRC_URI for multilib python-cassandra-driver.inc: fix DEPENDS triggerhappy: fix issues opencv: use the same package name in PACKAGES and RDEPENDS Oleksandr Kravchuk (4): znc: update to 1.7.3 pure-ftpd: update to 1.0.47 xl2tpd: update to 1.3.14 ell: remove recipe Scott Ellis (1): wireguard: Upgrade 20190123 -> 20190406 Tom Rini (1): toybox: Re-order inherit location so we can override do_configure Zang Ruochen (8): python-pyparsing: upgrade 2.2.0 -> 2.4.0 python-six: upgrade 1.11.0 -> 1.12.0 python-typing: upgrade 3.6.4 -> 3.6.6 python-urllib3: upgrade 1.23 -> 1.25.2 python-wrapt: upgrade 1.10.11 -> 1.11.1 python-mako:upgrade 1.0.9 -> 1.0.10 python-pip: upgrade 19.1 -> 19.1.1 python-pysocks: upgrade 1.6.8 -> 1.7.0 Change-Id: I9a4d8fb60195b1cfd0f39cebf8b113b3bb63808d Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb b/meta-openembedded/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb
new file mode 100644
index 000000000..24df750e0
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb
@@ -0,0 +1,47 @@
+SUMMARY = "A lightweight hotkey daemon"
+HOMEPAGE = "https://github.com/wertarbyte/triggerhappy"
+
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+# matches debian/0.5.0-1 tag
+SRCREV = "44a173195986d0d853316cb02a58785ded66c12b"
+PV = "0.5.0+git${SRCPV}"
+SRC_URI = "git://github.com/wertarbyte/${BPN}.git;branch=debian"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep pkgconfig update-rc.d systemd
+
+PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
+PACKAGECONFIG[systemd] = ",,systemd"
+
+INITSCRIPT_NAME = "triggerhappy"
+INITSCRIPT_PARAMS = "defaults"
+SYSTEMD_SERVICE_${PN} = "triggerhappy.service triggerhappy.socket"
+
+FILES_${PN} = "\
+ ${sbindir}/thd \
+ ${sbindir}/th-cmd \
+ ${sysconfdir}/triggerhappy/triggers.d \
+ ${nonarch_base_libdir}/udev/rules.d/80-triggerhappy.rules \
+ ${sysconfdir}/init.d/triggerhappy \
+ ${systemd_unitdir}/system \
+"
+CONFFILES_${PN} = "${sysconfdir}/udev/rules.d/80-triggerhappy.rules"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/triggerhappy/triggers.d
+
+ install -d ${D}${nonarch_base_libdir}/udev/rules.d
+ install -m 0644 ${S}/udev/triggerhappy-udev.rules ${D}${nonarch_base_libdir}/udev/rules.d/80-triggerhappy.rules
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${S}/debian/init.d ${D}${sysconfdir}/init.d/triggerhappy
+
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}/${systemd_unitdir}/system
+ install -m 0644 ${S}/systemd/triggerhappy.socket ${D}${systemd_unitdir}/system
+ install -m 0644 ${S}/systemd/triggerhappy.service ${D}${systemd_unitdir}/system
+ fi
+}