summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-20 13:15:02 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-11-20 13:15:14 +0300
commit23eaf03b3fff4acf8a79d082a85024bda6690436 (patch)
tree01b23dee8d55aea42b0fd9000c5ea0d32f5bd155 /meta-openembedded/meta-oe/recipes-extended
parentfb62a68f16d3fa64b242bd8c65abf64ef8088889 (diff)
downloadopenbmc-23eaf03b3fff4acf8a79d082a85024bda6690436.tar.xz
meta-openembedded: subtree update:55de2d06ad..53d431639a
Adrian Bunk (1): ltrace: Remove RDEPENDS on elfutils Andreas Müller (22): gedit: upgrade 2.30.4 -> 3.34.0 gtksourceview2: remove evolution-data-server: give up fine grained -dev/-dbg packages evolution-data-server: upgrade 3.26.6 -> 3.34.1 and rework gnome-font-viewer: initial add 3.34.0 evince: upgrade 3.28.2 -> 3.34.1 file-roller: inital add 3.32.2 gexiv2: initial add 0.12.0 gnome-autoar: inital add 0.2.3 tracker: initial add 2.3.1 nautilus: upgrade 3.18.5 -> 3.34.1 geocode-glib: initial add 3.26.1 libgweather: initial add 3.34.0 libwacom: initial add 0.33 gnome-settings-daemon: initial add 3.34.1 fluidsynth: upgrade 2.0.7 -> 2.0.9 gnome-terminal: re-add 3.34.2 gnome-terminal: Fix build for musl gmime: cleanup recipe gmime: move to meta-oe/recipes-gnome gmime: upgrade 3.2.4 -> 3.2.5 evolution-data-server: add upstream-version-is-even & gsettings to inherit Bartosz Golaszewski (1): libgpiod: put gpio utils into an actual separate package Gaylord Charles (1): nginx: fix install paths Khem Raj (11): evince: Fix build with clang poppler: Extend the c/c++ flags fix to cover clang pidgin-sipe: Fix another case of struct incompatiblility due to 64bit time_t gperftools: Convert static and libunwind support to packageconfig libmad: Define O2 for all arches as default optimization rsyslog: Dont force enable atomic builtins on mips libtorrent: Drop 64bit atomics patch for mips/ppc libtorrent: Disable instrumentation on ppc/mips libkcapi: Move static inline functions where used grpc: Link with libatomic on clang/x86 upm: Link with libatomic on clang/x86 Leon Anavi (1): surf: Add a simple web browser Martin Balik (1): squid: upgrade 4.6 -> 4.9 Nicola Lunghi (2): python-jsonschema: multiple fixes python-jsonschema: add PACKAGECONFIG nongpl option Oleksandr Kravchuk (1): flatbuffers: update to 1.11.0 Peter Kjellerstedt (1): libldb: Do not require the "pam" distro feature to be enabled nick83ola (2): python3-apply-defaults: add recipe python3-jsonrpcserver: add recipe Change-Id: I231fc015cba86b7c14915ffc3f6f123c9296fd68 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/rsyslog/rsyslog_8.1910.0.bb1
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/upm/upm/0001-nmea_gps-Link-with-latomic.patch27
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/upm/upm_git.bb2
3 files changed, 30 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/rsyslog/rsyslog_8.1910.0.bb b/meta-openembedded/meta-oe/recipes-extended/rsyslog/rsyslog_8.1910.0.bb
index f50f9a34b..8287d2b7f 100644
--- a/meta-openembedded/meta-oe/recipes-extended/rsyslog/rsyslog_8.1910.0.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/rsyslog/rsyslog_8.1910.0.bb
@@ -39,6 +39,7 @@ inherit autotools pkgconfig systemd update-rc.d ptest
EXTRA_OECONF += "--disable-generate-man-pages ap_cv_atomic_builtins=yes"
EXTRA_OECONF += "--enable-imfile-tests"
+EXTRA_OECONF_remove_mipsarch = "ap_cv_atomic_builtins=yes"
# first line is default yes in configure
PACKAGECONFIG ??= " \
diff --git a/meta-openembedded/meta-oe/recipes-extended/upm/upm/0001-nmea_gps-Link-with-latomic.patch b/meta-openembedded/meta-oe/recipes-extended/upm/upm/0001-nmea_gps-Link-with-latomic.patch
new file mode 100644
index 000000000..c16b8dbc5
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/upm/upm/0001-nmea_gps-Link-with-latomic.patch
@@ -0,0 +1,27 @@
+From 996d37fc0b7177ee57788399b9140032d5de2765 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 18 Nov 2019 15:50:02 -0800
+Subject: [PATCH] nmea_gps: Link with latomic
+
+clang/x86 ends up with missing symbols for atomics due to atomic<double>
+with libstdc++, it works ok with libc++
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/nmea_gps/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/nmea_gps/CMakeLists.txt b/src/nmea_gps/CMakeLists.txt
+index b3fb6591..5280bfed 100644
+--- a/src/nmea_gps/CMakeLists.txt
++++ b/src/nmea_gps/CMakeLists.txt
+@@ -6,4 +6,4 @@ upm_mixed_module_init (NAME nmea_gps
+ CPP_SRC nmea_gps.cxx
+ FTI_SRC nmea_gps_fti.c
+ CPP_WRAPS_C
+- REQUIRES mraa utilities-c ${CMAKE_THREAD_LIBS_INIT})
++ REQUIRES mraa utilities-c atomic ${CMAKE_THREAD_LIBS_INIT})
+--
+2.24.0
+
diff --git a/meta-openembedded/meta-oe/recipes-extended/upm/upm_git.bb b/meta-openembedded/meta-oe/recipes-extended/upm/upm_git.bb
index fb22e8335..dbe97370d 100644
--- a/meta-openembedded/meta-oe/recipes-extended/upm/upm_git.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/upm/upm_git.bb
@@ -15,6 +15,8 @@ SRC_URI = "git://github.com/intel-iot-devkit/${BPN}.git;protocol=http \
file://0001-Use-stdint-types.patch \
"
+SRC_URI_append_toolchain-clang_x86 = " file://0001-nmea_gps-Link-with-latomic.patch "
+
S = "${WORKDIR}/git"
# Depends on mraa which only supports x86 and ARM for now