summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.28.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-20 16:15:15 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-20 16:15:22 +0300
commit90ca747aa04f375af7ff86462a52028245b174b9 (patch)
treefb660879f07363805138d821882c4092ac47c047 /meta-openembedded/meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.28.bb
parent0b251f46569493f7a028b31031e50316dd584299 (diff)
downloadopenbmc-90ca747aa04f375af7ff86462a52028245b174b9.tar.xz
meta-openembedded: subtree update: c95842cdca..509d40153d
Andreas Müller (13): xfce4-whiskermenu-plugin: upgrade 2.3.2 -> 2.3.3 xfmpc: upgrade 0.2.3 -> 0.3.0 xfce4-cpugraph-plugin: upgrade 1.0.5 -> 1.1.0 xfce4-terminal: upgrase 0.8.7.4 -> 0.8.8 gtksourceview3: upgrade 3.24.10 -> 3.24.11 mousepad: move to gtk3 mousepad: upgrade 0.4.1 -> 0.4.2 ristretto: upgrade 0.8.4 -> 0.10.0 catfish: upgrade 1.4.7 -> 1.4.8 xfce4-datetime-plugin: upgrade 0.7.1 -> 0.8.0 xfce4-places-plugin: 1.8.0 -> 1.8.1 xfce4-pulseaudio-plugin: upgrade 0.4.1 -> 0.4.2 parole: upgrade 1.0.2 -> 1.0.4 Brad Bishop (1): cli11: Remove dev pkg dep to main pkg Kai Kang (1): packagegroup-tools-bluetooth: correct RDEPENDS Khem Raj (8): libopus: Limit forcing ARM mode ISA to v5 only mime-construct,libextutils-parsexs-perl: add runtime dependency on perl webmin: Add perl to rdeps for modules hplip: Add python to rdeps klibc: Disable bcmp builtin for clang on glibc as well python3-blivet: Add python3 to rdeps grubby: Add bash to rdeps ufs-tool: Do not force static linking Martin Jansa (10): nodejs: fix QA error about /usr/bin/python dependency iotop: add runtime dependency on python-core freeradius: add runtime dependency on perl scsirastools: add runtime dependency on bash libcec: add runtime dependency on python3-core dnf-plugin-tui: add runtime dependency on bash edac-utils: add runtime dependency on perl lmsensors: add runtime dependency on bash libdbi-perl: add runtime dependency on perl scsirastools: add runtime dependency on bash II Piotr Tworek (4): telepathy-glib: Update to version 0.24.1 telepathy-glib: Enable vala bindings gnome-themes-standard: Update to version 3.28 libgdata: Update to version 0.17.10. Slater, Joseph (1): php: zlib and zip support Yuan Chao (3): xfsprogs: upgrade 5.1.0 -> 5.2.0 xfsdump: fix error to work with xfsprogs 5.2.0 python-pymongo: upgrade 3.8.0 -> 3.9.0 Change-Id: I9450310b0c5abd766ecd0ee21c9338159b36e940 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.28.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.28.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.28.bb b/meta-openembedded/meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.28.bb
new file mode 100644
index 000000000..53eb32be9
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.28.bb
@@ -0,0 +1,45 @@
+SUMMARY = "GTK+2 standard themes"
+HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/"
+BUGTRACKER = "https://bugzilla.gnome.org/"
+SECTION = "x11/gnome"
+
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+# Upstream renamed this package to gnome-themes-extra at some point
+BPN = "gnome-themes-extra"
+
+inherit gnomebase gettext gtk-icon-cache upstream-version-is-even distro_features_check
+
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
+
+DEPENDS += "intltool-native gtk+"
+
+SRC_URI[archive.md5sum] = "f9f2c6c521948da427f702372e16f826"
+SRC_URI[archive.sha256sum] = "7c4ba0bff001f06d8983cfc105adaac42df1d1267a2591798a780bac557a5819"
+
+EXTRA_OECONF = "--disable-gtk3-engine"
+
+do_install_append() {
+ # Only building Adwaita, remove highcontrast files
+ rm -rf ${D}${prefix}/share/themes/HighContrast \
+ ${D}${prefix}/share/icons
+
+ # The libtool archive file is unneeded with shared libs on modern Linux
+ rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la
+}
+
+# There could be gnome-theme-highcontrast as well but that requires
+# gtk+3 and includes lots of icons (is also broken with B != S).
+PACKAGES += "gnome-theme-adwaita \
+ gnome-theme-adwaita-dark \
+ "
+
+FILES_gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \
+ ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so"
+
+FILES_gnome-theme-adwaita-dark = "${prefix}/share/themes/Adwaita-dark"
+RDEPENDS_gnome-theme-adwaita-dark = "gnome-theme-adwaita"
+
+# gnome-themes-standard is empty and doesn't exist
+RDEPENDS_${PN}-dev = ""