summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics/graphviz
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
commitd73e39703a0260c8911cb439b579e1c2bada4b20 (patch)
tree4fa9f965ae954c587ab773ecaced6b8f8e18d359 /meta-openembedded/meta-oe/recipes-graphics/graphviz
parent6f106a0a4ce15fe0678d4ffefd572e6978c72597 (diff)
parent6d8c5d2c6204714ca6b7a43f04348162b683cdbc (diff)
downloadopenbmc-d73e39703a0260c8911cb439b579e1c2bada4b20.tar.xz
Merge tag '0.75' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics/graphviz')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.44.1.bb44
1 files changed, 22 insertions, 22 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.44.1.bb b/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.44.1.bb
index 8fe837b75..7d2515e07 100644
--- a/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.44.1.bb
+++ b/meta-openembedded/meta-oe/recipes-graphics/graphviz/graphviz_2.44.1.bb
@@ -15,8 +15,8 @@ DEPENDS = " \
expat \
freetype \
"
-DEPENDS_append_class-target = " ${BPN}-native"
-DEPENDS_append_class-nativesdk = " ${BPN}-native"
+DEPENDS:append:class-target = " ${BPN}-native"
+DEPENDS:append:class-nativesdk = " ${BPN}-native"
inherit autotools-brokensep pkgconfig gettext
@@ -24,19 +24,19 @@ SRC_URI = "https://www2.graphviz.org/Packages/stable/portable_source/${BP}.tar.g
file://0001-plugin-pango-Include-freetype-headers-explicitly.patch \
"
# Use native mkdefs
-SRC_URI_append_class-target = "\
+SRC_URI:append:class-target = "\
file://0001-Use-native-mkdefs.patch \
file://0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch \
"
-SRC_URI_append_class-nativesdk = "\
+SRC_URI:append:class-nativesdk = "\
file://0001-Use-native-mkdefs.patch \
file://graphviz-setup.sh \
"
SRC_URI[sha256sum] = "8e1b34763254935243ccdb83c6ce108f531876d7a5dfd443f255e6418b8ea313"
-EXTRA_OECONF_append = " PS2PDF=/bin/echo"
+EXTRA_OECONF:append = " PS2PDF=/bin/echo"
-EXTRA_OECONF_class-target = "\
+EXTRA_OECONF:class-target = "\
--with-expatincludedir=${STAGING_INCDIR} \
--with-expatlibdir=${STAGING_LIBDIR} \
--without-included-ltdl \
@@ -45,7 +45,7 @@ EXTRA_OECONF_class-target = "\
--disable-r \
--disable-sharp \
"
-EXTRA_OECONF_class-nativesdk = "\
+EXTRA_OECONF:class-nativesdk = "\
--with-expatincludedir=${STAGING_INCDIR} \
--with-expatlibdir=${STAGING_LIBDIR} \
--without-included-ltdl \
@@ -54,39 +54,39 @@ EXTRA_OECONF_class-nativesdk = "\
--disable-r \
--disable-sharp \
"
-CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1"
-CFLAGS_append_class-nativesdk = " -D_typ_ssize_t=1 -D_long_double=1"
-do_configure_prepend() {
+CFLAGS:append:class-target = " -D_typ_ssize_t=1 -D_long_double=1"
+CFLAGS:append:class-nativesdk = " -D_typ_ssize_t=1 -D_long_double=1"
+do_configure:prepend() {
cd ${S}
# create version.m4 and ignore libtoolize errors
./autogen.sh NOCONFIG || true
}
-do_install_append_class-native() {
+do_install:append:class-native() {
# install mkdefs for target build
install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir}
}
-do_install_append_class-nativesdk() {
+do_install:append:class-nativesdk() {
# graphviz-setup.sh must be executed at SDK installation
install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d
install -m 0755 ${WORKDIR}/graphviz-setup.sh ${D}${SDKPATHNATIVE}/post-relocate-setup.d
}
-FILES_${PN}_class-nativesdk += "${SDKPATHNATIVE}"
+FILES:${PN}:class-nativesdk += "${SDKPATHNATIVE}"
PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo"
-FILES_${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/"
-FILES_${PN}-perl += "${libdir}/perl5/*/vendor_perl/ ${libdir}/graphviz/perl/"
-FILES_${PN}-demo += "${datadir}/graphviz/demo/"
+FILES:${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/"
+FILES:${PN}-perl += "${libdir}/perl5/*/vendor_perl/ ${libdir}/graphviz/perl/"
+FILES:${PN}-demo += "${datadir}/graphviz/demo/"
-RDEPENDS_${PN}-perl += "perl"
-RDEPENDS_${PN}-python += "python3"
-RDEPENDS_${PN}-demo += "python3 perl"
+RDEPENDS:${PN}-perl += "perl"
+RDEPENDS:${PN}-python += "python3"
+RDEPENDS:${PN}-demo += "python3 perl"
-INSANE_SKIP_${PN}-perl = "dev-so"
-INSANE_SKIP_${PN}-python = "dev-so"
+INSANE_SKIP:${PN}-perl = "dev-so"
+INSANE_SKIP:${PN}-python = "dev-so"
-FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}"
+FILES_SOLIBSDEV:append = " ${libdir}/graphviz/lib*${SOLIBSDEV}"
BBCLASSEXTEND = "native nativesdk"