summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/fix-buildscripts.patch
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-12-17 04:11:34 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-01-09 02:21:44 +0300
commit1a4b7ee28bf7413af6513fb45ad0d0736048f866 (patch)
tree79f6d8ea698cab8f2eaf4f54b793d2ca7a1451ce /meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/fix-buildscripts.patch
parent5b9ede0403237c7dace972affa65cf64a1aadd0e (diff)
downloadopenbmc-1a4b7ee28bf7413af6513fb45ad0d0736048f866.tar.xz
reset upstream subtrees to yocto 2.6
Reset the following subtrees on thud HEAD: poky: 87e3a9739d meta-openembedded: 6094ae18c8 meta-security: 31dc4e7532 meta-raspberrypi: a48743dc36 meta-xilinx: c42016e2e6 Also re-apply backports that didn't make it into thud: poky: 17726d0 systemd-systemctl-native: handle Install wildcards meta-openembedded: 4321a5d libtinyxml2: update to 7.0.1 042f0a3 libcereal: Add native and nativesdk classes e23284f libcereal: Allow empty package 030e8d4 rsyslog: curl-less build with fmhttp PACKAGECONFIG 179a1b9 gtest: update to 1.8.1 Squashed OpenBMC subtree compatibility updates: meta-aspeed: Brad Bishop (1): aspeed: add yocto 2.6 compatibility meta-ibm: Brad Bishop (1): ibm: prepare for yocto 2.6 meta-ingrasys: Brad Bishop (1): ingrasys: set layer compatibility to yocto 2.6 meta-openpower: Brad Bishop (1): openpower: set layer compatibility to yocto 2.6 meta-phosphor: Brad Bishop (3): phosphor: set layer compatibility to thud phosphor: libgpg-error: drop patches phosphor: react to fitimage artifact rename Ed Tanous (4): Dropbear: upgrade options for latest upgrade yocto2.6: update openssl options busybox: remove upstream watchdog patch systemd: Rebase CONFIG_CGROUP_BPF patch Change-Id: I7b1fe71cca880d0372a82d94b5fd785323e3a9e7 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/fix-buildscripts.patch')
-rw-r--r--meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/fix-buildscripts.patch116
1 files changed, 116 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/fix-buildscripts.patch b/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/fix-buildscripts.patch
new file mode 100644
index 000000000..3a50eff83
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/xscreensaver/files/fix-buildscripts.patch
@@ -0,0 +1,116 @@
+--- xscreensaver-5.39.orig/configure.in
++++ xscreensaver-5.39/configure.in
+@@ -14,6 +14,9 @@
+ #
+ ###############################################################################
+
++includedir=''
++libdir=''
++
+ AH_TOP([
+ /* config.h.in --- xscreensaver, Copyright (c) 1991-2014 Jamie Zawinski.
+ *
+@@ -422,12 +425,12 @@
+
+ OBJCC="$CC"
+
+- AC_MSG_CHECKING([whether the compiler works on ANSI C])
+- AC_TRY_RUN([ main(int ac, char **av) { return 0; } ],
+- AC_MSG_RESULT(yes),
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR(Couldn't build even a trivial ANSI C program: check CC.),
+- AC_MSG_ERROR(Couldn't build even a trivial ANSI C program: check CC.))
++# AC_MSG_CHECKING([whether the compiler works on ANSI C])
++# AC_TRY_RUN([ main(int ac, char **av) { return 0; } ],
++# AC_MSG_RESULT(yes),
++# AC_MSG_RESULT(no)
++# AC_MSG_ERROR(Couldn't build even a trivial ANSI C program: check CC.),
++# AC_MSG_ERROR(Couldn't build even a trivial ANSI C program: check CC.))
+
+ if test -n "$GCC"; then
+ AC_MSG_RESULT(Turning on gcc compiler warnings.)
+--- xscreensaver-5.39.orig/Makefile.in
++++ xscreensaver-5.39/Makefile.in
+@@ -6,7 +6,7 @@
+ VPATH = @srcdir@
+
+ SHELL = /bin/sh
+-SUBDIRS = utils jwxyz hacks/images hacks hacks/glx driver po
++SUBDIRS = utils jwxyz hacks/images hacks driver
+ SUBDIRS2 = $(SUBDIRS) OSX android
+ TARFILES = README README.hacking README.VMS INSTALL \
+ configure configure.in Makefile.in config.h.in \
+--- xscreensaver-5.39.orig/driver/Makefile.in
++++ xscreensaver-5.39/driver/Makefile.in
+@@ -10,7 +10,7 @@
+ top_srcdir = @top_srcdir@
+ top_builddir = ..
+
+-install_prefix =
++install_prefix = ${DESTDIR}
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ bindir = @bindir@
+@@ -221,7 +221,7 @@
+ SCRIPTS_1 = xscreensaver-getimage-file xscreensaver-getimage-video \
+ xscreensaver-text
+ SCRIPTS_OSX = xscreensaver-getimage-desktop
+-SCRIPTS = $(SCRIPTS_1) @SCRIPTS_OSX@
++#SCRIPTS = $(SCRIPTS_1) @SCRIPTS_OSX@
+
+ HDRS = XScreenSaver_ad.h XScreenSaver_Xm_ad.h \
+ xscreensaver.h prefs.h remote.h exec.h \
+--- xscreensaver-5.39.orig/hacks/Makefile.in
++++ xscreensaver-5.39/hacks/Makefile.in
+@@ -10,7 +10,7 @@
+ top_srcdir = @top_srcdir@
+ top_builddir = ..
+
+-install_prefix =
++install_prefix = ${DESTDIR}
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ bindir = @bindir@
+@@ -122,7 +122,7 @@
+ asm6502.c abstractile.c lcdscrub.c hexadrop.c \
+ tessellimage.c delaunay.c recanim.c binaryring.c \
+ webcollage-cocoa.m webcollage-helper-cocoa.m testx11.c
+-SCRIPTS = vidwhacker webcollage ljlatest
++#SCRIPTS = vidwhacker webcollage ljlatest
+
+ # Programs that are mentioned in XScreenSaver.ad, and that have XML files,
+ # but that are not shipped with xscreensaver itself.
+@@ -163,7 +163,13 @@
+ lcdscrub.o hexadrop.o tessellimage.o delaunay.o recanim.o \
+ binaryring.o testx11.o
+
+-EXES = attraction blitspin bouboule braid decayscreen deco \
++EXES = fontglide
++JPEG_EXES = webcollage-helper
++
++RETIRED_EXES = ant bubbles critical flag forest hyperball hypercube laser \
++ lightning lisa lissie lmorph rotor sphere spiral t3d vines \
++ whirlygig worm xsublim juggle testx11 \
++ attraction blitspin bouboule braid decayscreen deco \
+ drift flame galaxy grav greynetic halo \
+ helix hopalong ifs imsmap julia kaleidescope \
+ maze moire noseguy pedal \
+@@ -179,17 +185,12 @@
+ speedmine vermiculate twang apollonian euler2d \
+ polyominoes thornbird fluidballs anemone halftone \
+ metaballs eruption popsquares barcode piecewise cloudlife \
+- fontglide apple2 xanalogtv pong wormhole \
++ apple2 xanalogtv pong wormhole \
+ pacman fuzzyflakes anemotaxis memscroller substrate \
+ intermomentary fireworkx fiberlamp boxfit interaggregate \
+ celtic cwaves m6502 abstractile lcdscrub hexadrop \
+ tessellimage binaryring \
+ @JPEG_EXES@
+-JPEG_EXES = webcollage-helper
+-
+-RETIRED_EXES = ant bubbles critical flag forest hyperball hypercube laser \
+- lightning lisa lissie lmorph rotor sphere spiral t3d vines \
+- whirlygig worm xsublim juggle testx11
+
+ HACK_OBJS_1 = fps.o $(UTILS_BIN)/resources.o $(UTILS_BIN)/visual.o \
+ $(UTILS_BIN)/usleep.o $(UTILS_BIN)/yarandom.o \