summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
diff options
context:
space:
mode:
authorjmbills <42755197+jmbills@users.noreply.github.com>2020-07-11 02:37:34 +0300
committerGitHub <noreply@github.com>2020-07-11 02:37:34 +0300
commit2a11ae52fca0d1c0e12b4f18da637645eecc213c (patch)
tree05a1d365e0faa6ce8570b2d0c2d0f100dc8df1d4 /meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
parentefa39df15c70a1ab300cfa87e9895d5ee1feb5be (diff)
parentd071adf43ac87f21dde2f84287120960c723962c (diff)
downloadopenbmc-2a11ae52fca0d1c0e12b4f18da637645eecc213c.tar.xz
Merge pull request #44 from Intel-BMC/update
Update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb b/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
index 63a9fa88e..a1378866a 100644
--- a/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
+++ b/meta-openembedded/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
@@ -12,11 +12,22 @@ SRC_URI = "git://github.com/intel/pm-graph.git \
"
S = "${WORKDIR}/git"
+# Apart from the listed RDEPENDS, analyze-suspend depends on some features
+# provided by the kernel. These options are:
+# - CONFIG_PM_DEBUG=y
+# - CONFIG_PM_SLEEP_DEBUG=y
+# - CONFIG_FTRACE=y
+# - CONFIG_FUNCTION_TRACER=y
+# - CONFIG_FUNCTION_GRAPH_TRACER=y
+
COMPATIBLE_HOST='(i.86|x86_64).*'
EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}"
do_install() {
oe_runmake install
+ install -Dm 0755 ${S}/analyze_suspend.py ${D}${bindir}/analyze_suspend.py
}
RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression"
+RPROVIDES_${PN} = "analyze-suspend"
+BBCLASSEXTEND = "native nativesdk"