summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2019-02-23 01:03:50 +0300
committerAndrew Geissler <geissonator@yahoo.com>2019-02-23 01:05:07 +0300
commit1548c07ccf17a3a7a4fad7f31fb62d117bcb674f (patch)
treedc38b5d3eba36dab80ecd70556e05f4fae917c12 /meta-openembedded/meta-oe/recipes-multimedia
parent8704effb21a9aac3e4c97d234149887b6acfa941 (diff)
downloadopenbmc-1548c07ccf17a3a7a4fad7f31fb62d117bcb674f.tar.xz
meta-openembedded: refresh thud: cca27b5ea7..6ef9657068
Update meta-openembedded to thud HEAD. Alexander Kanavin (2): packagegroup-meta-oe: drop ptest packages that do not exist packagegroup-meta-oe: rename the group that contains ptest packages Andrea Adami (4): klibc: fix build for mipsel and mips64el with security flags enabled waf-cross-answers: Add cross-answers-mips64el.txt kexec-tools-klibc: fix build for mipsel and mips64el samba: fix build on qemumips64 with musl Andreas Müller (1): libgit2: Fix install for multilib Armin Kuster (1): wireshark: update to 2.6.6 Craig McQueen (1): python3-multidict: Workaround for broken make clean Eduardas Meile (1): toybox: fix to use "usrmerge" distro feature properly Haiqing Bai (1): ptpd: fixed the issue of ptpd2 daemon takes 100% CPU Hong Liu (1): wireshark: upgrade to 2.6.5 Hongxu Jia (1): python-pyparted/python3-pyparted: drop incorrect and redundant PV Kai Kang (1): net-snmp: inherit ptest Khem Raj (16): xscreensaver: Define consistent app-defaults dir a2jmidid: Define own do_configure bpftool: don't build under musl packagegroup-meta-oe: Remove arch specific packages as needed packagegroup-meta-oe: Remove packages which don't build for musl modemmanager: Fix build with clang klibc: Fix build with clang srecord: GPL-3.0 and LGPL-3.0 is correct license packagegroup-meta-oe: Exclude unbuildable packages on mips64 packagegroup-meta-oe: Exclude android-tools breakpad on ppc packagegroup-meta-oe: Remove unbuildable packages on risc-v from rdep mpv: Disable lua on mips/aarch64 luajit: Disable for mips n64/n32 hosts licenses: Add Arphic-Public-License text nmap: Fix build with clang8/musl/libc++ mozjs: Fix symbol visibility with clang/libc++ Marc Ferland (1): networkmanager: fix QA issue when using modemmanager and ppp in PACKAGECONFIG Martin Jansa (1): open-vm-tools: fix indentation and drop FILES_${PN}-dbg Mingli Yu (1): vim: improve reproducibility Niko Mauno (7): python-pygobject: Fix invalid install path python-pygobject: Drop redundant PYTHON* refs python-pygobject: Drop redundant dependencies python-pygobject: Only check for even upstream versions python-pygobject: Remove duplication in inherit python-pygobject: Fix style issue python-pygobject: Tune remove operation Otavio Salvador (2): mozjs: Avoid use of X11 from host when X11 is disabled postgresql: Allow successful run of postgresql-setup Primoz Fiser (1): sedutil: fix compile errors on big endian architectures Scott Ellis (2): nmap: Fix typo in pcre PACKAGECONFIG nmap: Include additional FILES path for certs leimaohui (2): mraa: To file do_package error in multilib. makedumpfile: Add aarch64 into COMPATIBLE_HOST. thc (1): fix networkmanager apppend Change-Id: I979f5ccefeec364f27df10888ae6258923a30659 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-multimedia')
-rw-r--r--meta-openembedded/meta-oe/recipes-multimedia/jack/a2jmidid_8.bb5
-rw-r--r--meta-openembedded/meta-oe/recipes-multimedia/mplayer/mpv_0.26.0.bb5
2 files changed, 9 insertions, 1 deletions
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/jack/a2jmidid_8.bb b/meta-openembedded/meta-oe/recipes-multimedia/jack/a2jmidid_8.bb
index 59b73f8e8..7dcaaf682 100644
--- a/meta-openembedded/meta-oe/recipes-multimedia/jack/a2jmidid_8.bb
+++ b/meta-openembedded/meta-oe/recipes-multimedia/jack/a2jmidid_8.bb
@@ -23,4 +23,9 @@ LDFLAGS_append_libc-musl = " -lexecinfo"
export LINKFLAGS="${LDFLAGS}"
+do_configure() {
+ sed -i 's|/usr/bin/.*python$|/usr/bin/env python2|' ${S}/a2j_control ${S}/waf ${S}/wscript
+ (cd ${B} && ${S}/waf configure --prefix=${prefix} ${WAF_EXTRA_CONF} ${EXTRA_OECONF})
+}
+
FILES_${PN} += "${datadir}/dbus-1/services"
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/mplayer/mpv_0.26.0.bb b/meta-openembedded/meta-oe/recipes-multimedia/mplayer/mpv_0.26.0.bb
index c2e8e3d57..6586e352e 100644
--- a/meta-openembedded/meta-oe/recipes-multimedia/mplayer/mpv_0.26.0.bb
+++ b/meta-openembedded/meta-oe/recipes-multimedia/mplayer/mpv_0.26.0.bb
@@ -25,9 +25,12 @@ SRC_URI[waf.sha256sum] = "01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f2
inherit waf pkgconfig pythonnative distro_features_check
+LUA ?= "lua"
+LUA_mips64 = ""
+LUA_aarch64 = ""
# Note: both lua and libass are required to get on-screen-display (controls)
PACKAGECONFIG ??= " \
- lua \
+ ${LUA} \
libass \
${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \
"