summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/colord/colord.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2019-12-05 23:27:58 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2019-12-05 23:27:58 +0300
commitccd6cab15aedd223a42dfdb110ab2d71d8a87141 (patch)
tree2050b16c5978dbf1268ea0f1a65d15026ec25831 /meta-openembedded/meta-oe/recipes-support/colord/colord.bb
parent6f65bb40d3e8b7fe978698488c2ea93f077bfcd6 (diff)
parent6dbb316ab9052d4dbf158377e1ffe36f205d5477 (diff)
downloadopenbmc-ccd6cab15aedd223a42dfdb110ab2d71d8a87141.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/colord/colord.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/colord/colord.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/colord/colord.bb b/meta-openembedded/meta-oe/recipes-support/colord/colord.bb
new file mode 100644
index 000000000..df86708e2
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/colord/colord.bb
@@ -0,0 +1,45 @@
+require ${BPN}.inc
+
+inherit meson gobject-introspection gsettings gettext bash-completion systemd features_check useradd
+
+# polkit and gobject-introspection are mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES = "polkit gobject-introspection-data"
+UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
+
+DEPENDS += " \
+ ${BPN}-native \
+ glib-2.0 \
+ lcms \
+ sqlite3 \
+ libgusb \
+ libgudev \
+ polkit \
+"
+
+SRC_URI += " \
+ file://0001-Run-native-cd_idt8-cd_create_profile.patch \
+"
+
+EXTRA_OEMESON = " \
+ -Dman=false \
+ -Ddocs=false \
+"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
+
+SYSTEMD_SERVICE_${PN} = "colord.service"
+
+FILES_${PN} += " \
+ ${datadir}/dbus-1 \
+ ${datadir}/polkit-1 \
+ ${datadir}/glib-2.0 \
+ ${datadir}/color \
+ ${systemd_user_unitdir} \
+ ${libdir}/tmpfiles.d \
+ ${libdir}/colord-plugins \
+ ${libdir}/colord-sensors \
+"
+
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} = "--system --user-group -d /var/lib/colord -s /bin/false colord"