summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_1.4.bb
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-04-15 23:11:05 +0300
committerEd Tanous <ed.tanous@intel.com>2019-04-15 23:11:05 +0300
commita75bff085ba9443315222231c42692745e5781e9 (patch)
treee1aa422babae0dffc866af076a0274ff26c2c4b2 /meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_1.4.bb
parent3e809d0d5cf96c18c5720d1b6b3b53e9f4c0cfae (diff)
parent6d4bcf0a75b2a6055055c9ad8ed6b93599082385 (diff)
downloadopenbmc-a75bff085ba9443315222231c42692745e5781e9.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into intel
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_1.4.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_1.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_1.4.bb b/meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_1.4.bb
new file mode 100644
index 000000000..863ce428f
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_1.4.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The goal of this project is to provide a tiny library that would \
+facilitate the common operations with sizes in bytes."
+HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
+LICENSE = "LGPLv2+"
+SECTION = "devel/lib"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+SRCREV = "ebbda2217d177d2a17f917d7a3e3d132a26db791"
+SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master \
+"
+
+inherit gettext autotools python3native
+
+DEPENDS += " \
+ libpcre \
+ gmp \
+ mpfr \
+"
+
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
+
+PACKAGECONFIG ??= "python3"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
+PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
+PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
+
+EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"
+
+