summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-11-05 18:45:06 +0300
committerGitHub <noreply@github.com>2021-11-05 18:45:06 +0300
commit4dac5fcd49b5e2de1074f1363775ec0f19041072 (patch)
tree5aadf91080299b1583caed86a31da368dfcda2da /meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb
parent0c9e31989c615598b5d042ffab385606660c93c0 (diff)
parent61f1ca1b31a9a1108e9e7f71e47fdc19beb0490b (diff)
downloadopenbmc-4dac5fcd49b5e2de1074f1363775ec0f19041072.tar.xz
Merge pull request #74 from Intel-BMC/update2021-0.771-0.77
Update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb b/meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb
new file mode 100644
index 000000000..118259e4f
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/libbytesize/libbytesize_2.6.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "The goal of this project is to provide a tiny library that would \
+facilitate the common operations with sizes in bytes."
+HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
+LICENSE = "LGPLv2+"
+SECTION = "devel/lib"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+SRCREV = "c9864f4dd03736839f40d225da494cb1eb64e654"
+SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master"
+
+inherit gettext autotools python3native
+
+DEPENDS += " \
+ libpcre2 \
+ gmp \
+ mpfr \
+ gettext-native \
+"
+
+FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
+
+PACKAGECONFIG ??= "python3"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3-core"
+
+EXTRA_OECONF = "--without-gtk-doc"
+EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"