summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.0.1.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.0.1.bb
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.0.1.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.0.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.0.1.bb b/meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.0.1.bb
new file mode 100644
index 000000000..363ed4d65
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/libgit2/libgit2_1.0.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "the Git linkable library"
+HOMEPAGE = "http://libgit2.github.com/"
+LICENSE = "GPL-2.0-with-GCC-exception & MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5b002a195fb7ea2d8d583f07eaff3a8e"
+
+DEPENDS = "curl openssl zlib libssh2 libgcrypt libpcre2"
+
+SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v1.0"
+SRCREV = "0ced29612dacb67eefe0c562a5c1d3aab21cce96"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "\
+ -DBUILD_CLAR=OFF \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DLIB_INSTALL_DIR=${libdir} \
+ -DREGEX_BACKEND='pcre2' \
+"
+
+BBCLASSEXTEND = "native"