summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/lio-utils
diff options
context:
space:
mode:
authorjmbills <42755197+jmbills@users.noreply.github.com>2020-07-11 02:37:34 +0300
committerGitHub <noreply@github.com>2020-07-11 02:37:34 +0300
commit2a11ae52fca0d1c0e12b4f18da637645eecc213c (patch)
tree05a1d365e0faa6ce8570b2d0c2d0f100dc8df1d4 /meta-openembedded/meta-oe/recipes-support/lio-utils
parentefa39df15c70a1ab300cfa87e9895d5ee1feb5be (diff)
parentd071adf43ac87f21dde2f84287120960c723962c (diff)
downloadopenbmc-2a11ae52fca0d1c0e12b4f18da637645eecc213c.tar.xz
Merge pull request #44 from Intel-BMC/update
Update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/lio-utils')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb b/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
index ea54e7552..0fb4a6e51 100644
--- a/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
+++ b/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/Datera/lio-utils.git \
SRCREV = "0ac9091c1ff7a52d5435a4f4449e82637142e06e"
S = "${WORKDIR}/git"
-inherit distutils
+inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "distutils", "", d)}
EXTRA_OEMAKE += "DESTDIR=${D}"
@@ -64,3 +64,10 @@ FILES_${PN} += "${sbindir}/* /etc/init.d/* /etc/target/*"
# http://errors.yoctoproject.org/Errors/Details/184712/
# python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory
CLEANBROKEN = "1"
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}
+
+