summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-03-02 22:06:48 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-03-02 22:06:48 +0300
commit9600a7403ba2848c8751280077503a3e0f2f3481 (patch)
tree996726918f255cc9686dec34628fab410ac8f550 /meta-openembedded/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb
parentb11bad1ba28f79c08266efb9cc265d89103e5939 (diff)
parent5ec7af7413906b500cce396255bde69c9770f6d8 (diff)
downloadopenbmc-9600a7403ba2848c8751280077503a3e0f2f3481.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb b/meta-openembedded/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb
index 5b862bd1f..9d8800ebd 100644
--- a/meta-openembedded/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb
+++ b/meta-openembedded/meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb
@@ -15,15 +15,15 @@ SRC_URI[debianpatch.md5sum] = "5ef6267c42fca9145e0af006ccb6aff7"
SRC_URI[debianpatch.sha256sum] = "a5405c6ee5e97e45eeb1c81330a7e9f444a58bda5e6771fa30007516c115007e"
inherit lib_package perlnative
-export basedir="${D}${prefix}"
CFLAGS += " -D__GNU_LIBRARY__"
TARGET_CC_ARCH += "${LDFLAGS}"
+EXTRA_OEMAKE = "basedir=${D}${prefix} baselib=${baselib} LD='${CC}' LD='${CC}'"
do_compile() {
- oe_runmake basedir=${D}${prefix} LD="${CC}" LD="${CC}" shared static
+ oe_runmake shared static
}
do_install() {
- oe_runmake DESTDIR=${D} basedir=${D}${prefix} install
+ oe_runmake DESTDIR=${D} install
}