summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.36.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-03-26 01:28:45 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-03-26 01:28:45 +0300
commit0a1ece0568a37de9f17fd6e0bcdfd2cad2c6503f (patch)
treeb985c9ca29cb3cf19b04e248c868fa18abf07dcc /meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.36.bb
parent0cfc19e6565d8e3a1aa563c59edb347f9128026f (diff)
parent983ec41074988cf15d98bf8c929efee125682eeb (diff)
downloadopenbmc-0a1ece0568a37de9f17fd6e0bcdfd2cad2c6503f.tar.xz
Merge tag '0.43' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.36.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.36.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.36.bb b/meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.36.bb
new file mode 100644
index 000000000..b6988baa7
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/satyr/satyr_0.36.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
+failure processing, analysis, and reporting supporting kernel space, user \
+space, Python, and Java programs"
+
+HOMEPAGE = "https://github.com/abrt/satyr"
+LICENSE = "GPLv2"
+
+inherit autotools-brokensep python3native pkgconfig
+
+SRC_URI = "git://github.com/abrt/satyr.git \
+ file://0002-fix-compile-failure-against-musl-C-library.patch \
+"
+SRCREV = "a1f232b7dbca7ff787076fcfb63ce7d7fb15b753"
+S = "${WORKDIR}/git"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS += " \
+ gdb \
+ gperf-native \
+ json-c \
+ nettle \
+ glib-2.0 \
+"
+
+PACKAGES += "python3-${BPN}"
+FILES_python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
+
+PACKAGECONFIG ??= "python3 rpm"
+PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
+PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
+
+do_configure_prepend() {
+ ${S}/gen-version
+}