summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.15.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-01-27 22:27:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-01-27 22:27:17 +0300
commit98cc5cd6483975b64d80e8323f7f659dd1337d75 (patch)
tree5fa64e93d57396bc4c76aa3537156205b4b424ac /meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.15.bb
parent82dbc15a05125a812c140a3c8cff81c366482229 (diff)
parent8fc454f9beebdd347403145c991697019a593cff (diff)
downloadopenbmc-98cc5cd6483975b64d80e8323f7f659dd1337d75.tar.xz
Merge tag '0.29' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.15.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.15.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.15.bb b/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.15.bb
new file mode 100644
index 000000000..41c4b76d2
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/zile/zile_2.4.15.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Zile is lossy Emacs"
+HOMEPAGE = "http://zile.sourceforge.net/"
+DEPENDS = "ncurses bdwgc"
+
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
+
+SRC_URI = "${GNU_MIRROR}/zile/${BP}.tar.gz \
+ file://remove-help2man.patch \
+"
+
+SRC_URI[md5sum] = "05efa90dfee1821ca018b0b2ef8f50a8"
+SRC_URI[sha256sum] = "39c300a34f78c37ba67793cf74685935a15568e14237a3a66fda8fcf40e3035e"
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ rm -rf ${D}${libdir}/charset.alias
+ rmdir --ignore-fail-on-non-empty ${D}${libdir} || true
+}
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG_append = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}"
+
+PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"